Upstream information

CVE-2017-15098 at MITRE

Description

Invalid json_populate_recordset or jsonb_populate_recordset function calls in PostgreSQL 10.x before 10.1, 9.6.x before 9.6.6, 9.5.x before 9.5.10, 9.4.x before 9.4.15, and 9.3.x before 9.3.20 can crash the server or disclose a few bytes of server memory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5.5 6.4
Vector AV:N/AC:L/Au:S/C:P/I:N/A:P AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication Single None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 7.1
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1067844 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libecpg6 >= 9.6.6-3.10.1
  • libpq5 >= 9.6.6-3.10.1
  • libpq5-32bit >= 9.6.6-3.10.1
  • postgresql94 >= 9.4.15-21.13.1
  • postgresql96 >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-2127
SUSE-SLE-DESKTOP-12-SP2-2018-63
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 9.6.6-3.10.1
  • libpq5 >= 9.6.6-3.10.1
  • libpq5-32bit >= 9.6.6-3.10.1
  • postgresql96 >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-2127
SUSE Linux Enterprise Module for Basesystem 15
  • libpq5 >= 10.3-2.8
  • postgresql10 >= 10.3-2.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpq5
SUSE Linux Enterprise Module for Server Applications 15
  • libecpg6 >= 10.3-2.8
  • postgresql10-contrib >= 10.3-2.8
  • postgresql10-devel >= 10.3-2.8
  • postgresql10-docs >= 10.3-2.8
  • postgresql10-plperl >= 10.3-2.8
  • postgresql10-plpython >= 10.3-2.8
  • postgresql10-pltcl >= 10.3-2.8
  • postgresql10-server >= 10.3-2.8
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libecpg6
SUSE Linux Enterprise Server 11 SP4
  • libecpg6 >= 9.4.15-0.23.10.1
  • libpq5 >= 9.4.15-0.23.10.1
  • libpq5-32bit >= 9.4.15-0.23.10.1
  • postgresql94 >= 9.4.15-0.23.10.1
  • postgresql94-contrib >= 9.4.15-0.23.10.1
  • postgresql94-docs >= 9.4.15-0.23.10.1
  • postgresql94-libs >= 9.4.15-0.23.10.1
  • postgresql94-server >= 9.4.15-0.23.10.1
Patchnames:
slessp4-postgresql94-13411
SUSE Linux Enterprise Server 12 SP2
  • libecpg6 >= 9.6.6-3.10.1
  • libpq5 >= 9.6.6-3.10.1
  • libpq5-32bit >= 9.6.6-3.10.1
  • postgresql94 >= 9.4.15-21.13.1
  • postgresql94-contrib >= 9.4.15-21.13.1
  • postgresql94-docs >= 9.4.15-21.13.1
  • postgresql94-server >= 9.4.15-21.13.1
  • postgresql96 >= 9.6.6-3.10.1
  • postgresql96-contrib >= 9.6.6-3.10.1
  • postgresql96-docs >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
  • postgresql96-server >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-2127
SUSE-SLE-SERVER-12-SP2-2018-63
SUSE Linux Enterprise Server 12 SP3
  • libecpg6 >= 9.6.6-3.10.1
  • libpq5 >= 9.6.6-3.10.1
  • libpq5-32bit >= 9.6.6-3.10.1
  • postgresql96 >= 9.6.6-3.10.1
  • postgresql96-contrib >= 9.6.6-3.10.1
  • postgresql96-docs >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
  • postgresql96-server >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-2127
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libecpg6 >= 9.6.6-3.10.1
  • libpq5 >= 9.6.6-3.10.1
  • postgresql94 >= 9.4.15-21.13.1
  • postgresql94-contrib >= 9.4.15-21.13.1
  • postgresql94-docs >= 9.4.15-21.13.1
  • postgresql94-server >= 9.4.15-21.13.1
  • postgresql96 >= 9.6.6-3.10.1
  • postgresql96-contrib >= 9.6.6-3.10.1
  • postgresql96-docs >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
  • postgresql96-server >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-2127
SUSE-SLE-RPI-12-SP2-2018-63
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libecpg6 >= 9.4.15-0.23.10.1
  • libpq5 >= 9.4.15-0.23.10.1
  • libpq5-32bit >= 9.4.15-0.23.10.1
  • postgresql94 >= 9.4.15-0.23.10.1
  • postgresql94-contrib >= 9.4.15-0.23.10.1
  • postgresql94-docs >= 9.4.15-0.23.10.1
  • postgresql94-libs >= 9.4.15-0.23.10.1
  • postgresql94-server >= 9.4.15-0.23.10.1
Patchnames:
slessp4-postgresql94-13411
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libecpg6 >= 9.6.6-3.10.1
  • libpq5 >= 9.6.6-3.10.1
  • libpq5-32bit >= 9.6.6-3.10.1
  • postgresql94 >= 9.4.15-21.13.1
  • postgresql94-contrib >= 9.4.15-21.13.1
  • postgresql94-docs >= 9.4.15-21.13.1
  • postgresql94-server >= 9.4.15-21.13.1
  • postgresql96 >= 9.6.6-3.10.1
  • postgresql96-contrib >= 9.6.6-3.10.1
  • postgresql96-docs >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
  • postgresql96-server >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-2127
SUSE-SLE-SERVER-12-SP2-2018-63
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libecpg6 >= 9.6.6-3.10.1
  • libpq5 >= 9.6.6-3.10.1
  • libpq5-32bit >= 9.6.6-3.10.1
  • postgresql96 >= 9.6.6-3.10.1
  • postgresql96-contrib >= 9.6.6-3.10.1
  • postgresql96-docs >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
  • postgresql96-server >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-2127
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql94-devel >= 9.4.15-0.23.10.1
  • postgresql94-libs >= 9.4.15-0.23.10.1
Patchnames:
sdksp4-postgresql94-13411
SUSE Linux Enterprise Software Development Kit 12 SP2
  • postgresql94-devel >= 9.4.15-21.13.1
  • postgresql94-libs >= 9.4.15-21.13.1
  • postgresql96-devel >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-2127
SUSE-SLE-SDK-12-SP2-2018-63
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql96-devel >= 9.6.6-3.10.1
  • postgresql96-libs >= 9.6.6-3.10.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-2127
openSUSE Leap 15.0
  • libpq5 >= 10.3-lp150.2.2
  • postgresql10 >= 10.3-lp150.2.1
  • postgresql10-server >= 10.3-lp150.2.1
  • postgresql96 >= 9.6.8-lp150.1.2
  • postgresql96-server >= 9.6.8-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA libpq5
openSUSE Leap 15.0 GA postgresql96
openSUSE Leap 42.2
  • libecpg6 >= 9.6.6-8.1
  • libecpg6-32bit >= 9.6.6-8.1
  • libecpg6-debuginfo >= 9.6.6-8.1
  • libecpg6-debuginfo-32bit >= 9.6.6-8.1
  • libpq5 >= 9.6.6-8.1
  • libpq5-32bit >= 9.6.6-8.1
  • libpq5-debuginfo >= 9.6.6-8.1
  • libpq5-debuginfo-32bit >= 9.6.6-8.1
  • postgresql94 >= 9.4.15-9.12.1
  • postgresql94-contrib >= 9.4.15-9.12.1
  • postgresql94-contrib-debuginfo >= 9.4.15-9.12.1
  • postgresql94-debuginfo >= 9.4.15-9.12.1
  • postgresql94-debugsource >= 9.4.15-9.12.1
  • postgresql94-devel >= 9.4.15-9.12.1
  • postgresql94-devel-debuginfo >= 9.4.15-9.12.1
  • postgresql94-docs >= 9.4.15-9.12.1
  • postgresql94-libs >= 9.4.15-9.12.1
  • postgresql94-libs-debugsource >= 9.4.15-9.12.1
  • postgresql94-plperl >= 9.4.15-9.12.1
  • postgresql94-plperl-debuginfo >= 9.4.15-9.12.1
  • postgresql94-plpython >= 9.4.15-9.12.1
  • postgresql94-plpython-debuginfo >= 9.4.15-9.12.1
  • postgresql94-pltcl >= 9.4.15-9.12.1
  • postgresql94-pltcl-debuginfo >= 9.4.15-9.12.1
  • postgresql94-server >= 9.4.15-9.12.1
  • postgresql94-server-debuginfo >= 9.4.15-9.12.1
  • postgresql94-test >= 9.4.15-9.12.1
  • postgresql96 >= 9.6.6-8.1
  • postgresql96-contrib >= 9.6.6-8.1
  • postgresql96-contrib-debuginfo >= 9.6.6-8.1
  • postgresql96-debuginfo >= 9.6.6-8.1
  • postgresql96-debugsource >= 9.6.6-8.1
  • postgresql96-devel >= 9.6.6-8.1
  • postgresql96-devel-debuginfo >= 9.6.6-8.1
  • postgresql96-docs >= 9.6.6-8.1
  • postgresql96-libs >= 9.6.6-8.1
  • postgresql96-libs-debugsource >= 9.6.6-8.1
  • postgresql96-plperl >= 9.6.6-8.1
  • postgresql96-plperl-debuginfo >= 9.6.6-8.1
  • postgresql96-plpython >= 9.6.6-8.1
  • postgresql96-plpython-debuginfo >= 9.6.6-8.1
  • postgresql96-pltcl >= 9.6.6-8.1
  • postgresql96-pltcl-debuginfo >= 9.6.6-8.1
  • postgresql96-server >= 9.6.6-8.1
  • postgresql96-server-debuginfo >= 9.6.6-8.1
  • postgresql96-test >= 9.6.6-8.1
Patchnames:
openSUSE-2017-1411
openSUSE-2018-38
openSUSE Leap 42.3
  • libecpg6 >= 9.6.6-9.1
  • libecpg6-32bit >= 9.6.6-9.1
  • libecpg6-debuginfo >= 9.6.6-9.1
  • libecpg6-debuginfo-32bit >= 9.6.6-9.1
  • libpq5 >= 9.6.6-9.1
  • libpq5-32bit >= 9.6.6-9.1
  • libpq5-debuginfo >= 9.6.6-9.1
  • libpq5-debuginfo-32bit >= 9.6.6-9.1
  • postgresql94 >= 9.4.15-15.1
  • postgresql94-contrib >= 9.4.15-15.1
  • postgresql94-contrib-debuginfo >= 9.4.15-15.1
  • postgresql94-debuginfo >= 9.4.15-15.1
  • postgresql94-debugsource >= 9.4.15-15.1
  • postgresql94-devel >= 9.4.15-15.1
  • postgresql94-devel-debuginfo >= 9.4.15-15.1
  • postgresql94-docs >= 9.4.15-15.1
  • postgresql94-libs >= 9.4.15-15.1
  • postgresql94-libs-debugsource >= 9.4.15-15.1
  • postgresql94-plperl >= 9.4.15-15.1
  • postgresql94-plperl-debuginfo >= 9.4.15-15.1
  • postgresql94-plpython >= 9.4.15-15.1
  • postgresql94-plpython-debuginfo >= 9.4.15-15.1
  • postgresql94-pltcl >= 9.4.15-15.1
  • postgresql94-pltcl-debuginfo >= 9.4.15-15.1
  • postgresql94-server >= 9.4.15-15.1
  • postgresql94-server-debuginfo >= 9.4.15-15.1
  • postgresql94-test >= 9.4.15-15.1
  • postgresql95 >= 9.5.11-2.3.1
  • postgresql95-contrib >= 9.5.11-2.3.1
  • postgresql95-contrib-debuginfo >= 9.5.11-2.3.1
  • postgresql95-debuginfo >= 9.5.11-2.3.1
  • postgresql95-debugsource >= 9.5.11-2.3.1
  • postgresql95-devel >= 9.5.11-2.3.1
  • postgresql95-devel-debuginfo >= 9.5.11-2.3.1
  • postgresql95-docs >= 9.5.11-2.3.1
  • postgresql95-libs >= 9.5.11-2.3.1
  • postgresql95-libs-debugsource >= 9.5.11-2.3.1
  • postgresql95-plperl >= 9.5.11-2.3.1
  • postgresql95-plperl-debuginfo >= 9.5.11-2.3.1
  • postgresql95-plpython >= 9.5.11-2.3.1
  • postgresql95-plpython-debuginfo >= 9.5.11-2.3.1
  • postgresql95-pltcl >= 9.5.11-2.3.1
  • postgresql95-pltcl-debuginfo >= 9.5.11-2.3.1
  • postgresql95-server >= 9.5.11-2.3.1
  • postgresql95-server-debuginfo >= 9.5.11-2.3.1
  • postgresql95-test >= 9.5.11-2.3.1
  • postgresql96 >= 9.6.6-9.1
  • postgresql96-contrib >= 9.6.6-9.1
  • postgresql96-contrib-debuginfo >= 9.6.6-9.1
  • postgresql96-debuginfo >= 9.6.6-9.1
  • postgresql96-debugsource >= 9.6.6-9.1
  • postgresql96-devel >= 9.6.6-9.1
  • postgresql96-devel-debuginfo >= 9.6.6-9.1
  • postgresql96-docs >= 9.6.6-9.1
  • postgresql96-libs >= 9.6.6-9.1
  • postgresql96-libs-debugsource >= 9.6.6-9.1
  • postgresql96-plperl >= 9.6.6-9.1
  • postgresql96-plperl-debuginfo >= 9.6.6-9.1
  • postgresql96-plpython >= 9.6.6-9.1
  • postgresql96-plpython-debuginfo >= 9.6.6-9.1
  • postgresql96-pltcl >= 9.6.6-9.1
  • postgresql96-pltcl-debuginfo >= 9.6.6-9.1
  • postgresql96-server >= 9.6.6-9.1
  • postgresql96-server-debuginfo >= 9.6.6-9.1
  • postgresql96-test >= 9.6.6-9.1
Patchnames:
openSUSE-2017-1411
openSUSE-2018-204
openSUSE-2018-38


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 postgresql94 Released
SUSE Linux Enterprise Desktop 12 SP2 postgresql96 Released
SUSE Linux Enterprise Desktop 12 SP3 postgresql96 Released
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Affected
SUSE Linux Enterprise Server 11 SP4 postgresql94 Released
SUSE Linux Enterprise Server 12 GA LTSS postgresql94 Affected
SUSE Linux Enterprise Server 12 GA LTSS postgresql96 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql94 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql96 Affected
SUSE Linux Enterprise Server 12 SP2 postgresql94 Released
SUSE Linux Enterprise Server 12 SP2 postgresql96 Released
SUSE Linux Enterprise Server 12 SP3 postgresql96 Released