Upstream information

CVE-2017-15088 at MITRE

Description

plugins/preauth/pkinit/pkinit_crypto_openssl.c in MIT Kerberos 5 (aka krb5) through 1.15.2 mishandles Distinguished Name (DN) fields, which allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) in situations involving untrusted X.509 data, related to the get_matching_data and X509_NAME_oneline_ex functions. NOTE: this has security relevance only in use cases outside of the MIT Kerberos distribution, e.g., the use of get_matching_data in KDC certauth plugin code that is specific to Red Hat.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.1
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:S/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Low High
Authentication None Single
Confidentiality Impact Partial Complete
Integrity Impact Partial Complete
Availability Impact Partial Complete
CVSS v3 Scores
  SUSE
Base Score 7.5
Vector AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1065274 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • krb5 >= 1.12.5-40.16.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1826
SUSE CaaS Platform ALL
  • krb5 >= 1.12.5-40.16.1
Patchnames:
SUSE-CAASP-ALL-2017-1826
SUSE Linux Enterprise Build System Kit 12 SP2
  • krb5-mini >= 1.12.5-40.16.1
  • krb5-mini-devel >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-BSK-12-SP2-2017-1826
SUSE Linux Enterprise Build System Kit 12 SP3
  • krb5-mini >= 1.12.5-40.16.1
  • krb5-mini-devel >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2017-1826
SUSE Linux Enterprise Desktop 12 SP2
  • krb5 >= 1.12.5-40.16.1
  • krb5-32bit >= 1.12.5-40.16.1
  • krb5-client >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1826
SUSE Linux Enterprise Desktop 12 SP3
  • krb5 >= 1.12.5-40.16.1
  • krb5-32bit >= 1.12.5-40.16.1
  • krb5-client >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1826
SUSE Linux Enterprise Server 12 SP2
  • krb5 >= 1.12.5-40.16.1
  • krb5-32bit >= 1.12.5-40.16.1
  • krb5-client >= 1.12.5-40.16.1
  • krb5-doc >= 1.12.5-40.16.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.16.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.16.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.16.1
  • krb5-server >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1826
SUSE Linux Enterprise Server 12 SP3
  • krb5 >= 1.12.5-40.16.1
  • krb5-32bit >= 1.12.5-40.16.1
  • krb5-client >= 1.12.5-40.16.1
  • krb5-doc >= 1.12.5-40.16.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.16.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.16.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.16.1
  • krb5-server >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1826
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • krb5 >= 1.12.5-40.16.1
  • krb5-client >= 1.12.5-40.16.1
  • krb5-doc >= 1.12.5-40.16.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.16.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.16.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.16.1
  • krb5-server >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1826
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • krb5 >= 1.12.5-40.16.1
  • krb5-32bit >= 1.12.5-40.16.1
  • krb5-client >= 1.12.5-40.16.1
  • krb5-doc >= 1.12.5-40.16.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.16.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.16.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.16.1
  • krb5-server >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1826
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • krb5 >= 1.12.5-40.16.1
  • krb5-32bit >= 1.12.5-40.16.1
  • krb5-client >= 1.12.5-40.16.1
  • krb5-doc >= 1.12.5-40.16.1
  • krb5-plugin-kdb-ldap >= 1.12.5-40.16.1
  • krb5-plugin-preauth-otp >= 1.12.5-40.16.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-40.16.1
  • krb5-server >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1826
SUSE Linux Enterprise Software Development Kit 12 SP2
  • krb5 >= 1.12.5-40.16.1
  • krb5-devel >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1826
SUSE Linux Enterprise Software Development Kit 12 SP3
  • krb5 >= 1.12.5-40.16.1
  • krb5-devel >= 1.12.5-40.16.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1826
openSUSE Leap 42.2
  • krb5 >= 1.12.5-6.6.1
  • krb5-32bit >= 1.12.5-6.6.1
  • krb5-client >= 1.12.5-6.6.1
  • krb5-client-debuginfo >= 1.12.5-6.6.1
  • krb5-debuginfo >= 1.12.5-6.6.1
  • krb5-debuginfo-32bit >= 1.12.5-6.6.1
  • krb5-debugsource >= 1.12.5-6.6.1
  • krb5-devel >= 1.12.5-6.6.1
  • krb5-devel-32bit >= 1.12.5-6.6.1
  • krb5-doc >= 1.12.5-6.6.1
  • krb5-mini >= 1.12.5-6.6.1
  • krb5-mini-debuginfo >= 1.12.5-6.6.1
  • krb5-mini-debugsource >= 1.12.5-6.6.1
  • krb5-mini-devel >= 1.12.5-6.6.1
  • krb5-plugin-kdb-ldap >= 1.12.5-6.6.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.12.5-6.6.1
  • krb5-plugin-preauth-otp >= 1.12.5-6.6.1
  • krb5-plugin-preauth-otp-debuginfo >= 1.12.5-6.6.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-6.6.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.12.5-6.6.1
  • krb5-server >= 1.12.5-6.6.1
  • krb5-server-debuginfo >= 1.12.5-6.6.1
Patchnames:
openSUSE-2017-1266
openSUSE Leap 42.3
  • krb5 >= 1.12.5-12.1
  • krb5-32bit >= 1.12.5-12.1
  • krb5-client >= 1.12.5-12.1
  • krb5-client-debuginfo >= 1.12.5-12.1
  • krb5-debuginfo >= 1.12.5-12.1
  • krb5-debuginfo-32bit >= 1.12.5-12.1
  • krb5-debugsource >= 1.12.5-12.1
  • krb5-devel >= 1.12.5-12.1
  • krb5-devel-32bit >= 1.12.5-12.1
  • krb5-doc >= 1.12.5-12.1
  • krb5-mini >= 1.12.5-12.1
  • krb5-mini-debuginfo >= 1.12.5-12.1
  • krb5-mini-debugsource >= 1.12.5-12.1
  • krb5-mini-devel >= 1.12.5-12.1
  • krb5-plugin-kdb-ldap >= 1.12.5-12.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.12.5-12.1
  • krb5-plugin-preauth-otp >= 1.12.5-12.1
  • krb5-plugin-preauth-otp-debuginfo >= 1.12.5-12.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-12.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.12.5-12.1
  • krb5-server >= 1.12.5-12.1
  • krb5-server-debuginfo >= 1.12.5-12.1
Patchnames:
openSUSE-2017-1266


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 krb5 Released
CaaS Platform 2.0 krb5 Released
OpenStack Cloud Magnum Orchestration 7.0 krb5 Released
SUSE Linux Enterprise Desktop 12 SP2 krb5 Released
SUSE Linux Enterprise Desktop 12 SP3 krb5 Released
SUSE Linux Enterprise SDK 11 SP4 krb5 Not affected
SUSE Linux Enterprise SDK 12 SP2 krb5 Released
SUSE Linux Enterprise SDK 12 SP3 krb5 Released
SUSE Linux Enterprise Server 11 SP3 LTSS krb5 Not affected
SUSE Linux Enterprise Server 11 SP4 krb5 Not affected
SUSE Linux Enterprise Server 12 SP2 krb5 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI krb5 Released
SUSE Linux Enterprise Server 12 SP3 krb5 Released