Upstream information

CVE-2017-14919 at MITRE

Description

Node.js before 4.8.5, 6.x before 6.11.5, and 8.x before 8.8.0 allows remote attackers to cause a denial of service (uncaught exception and crash) by leveraging a change in the zlib module 1.2.9 making 8 an invalid value for the windowBits parameter.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 1059050 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-Storage-4-2018-2
SUSE-Storage-4-2018-203
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs4-devel >= 4.8.7-15.8.1
  • nodejs4-docs >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
  • nodejs6-devel >= 6.12.2-11.8.1
  • nodejs6-docs >= 6.12.2-11.8.1
  • npm4 >= 4.8.7-15.8.1
  • npm6 >= 6.12.2-11.8.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2018-2
SUSE-SLE-Module-Web-Scripting-12-2018-203
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.1-1.19
  • nodejs8-devel >= 8.11.1-1.19
  • nodejs8-docs >= 8.11.1-1.19
  • npm8 >= 8.11.1-1.19
Patchnames:
SUSE Linux Enterprise Module for Web Scripting 15 GA nodejs8
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-203
openSUSE Leap 42.2
  • nodejs4 >= 4.8.7-5.9.1
  • nodejs4-debuginfo >= 4.8.7-5.9.1
  • nodejs4-debugsource >= 4.8.7-5.9.1
  • nodejs4-devel >= 4.8.7-5.9.1
  • nodejs4-docs >= 4.8.7-5.9.1
  • npm4 >= 4.8.7-5.9.1
Patchnames:
openSUSE-2018-5
openSUSE Leap 42.3
  • nodejs4 >= 4.8.7-11.1
  • nodejs4-debuginfo >= 4.8.7-11.1
  • nodejs4-debugsource >= 4.8.7-11.1
  • nodejs4-devel >= 4.8.7-11.1
  • nodejs4-docs >= 4.8.7-11.1
  • nodejs6 >= 6.12.2-6.1
  • nodejs6-debuginfo >= 6.12.2-6.1
  • nodejs6-debugsource >= 6.12.2-6.1
  • nodejs6-devel >= 6.12.2-6.1
  • nodejs6-docs >= 6.12.2-6.1
  • npm4 >= 4.8.7-11.1
  • npm6 >= 6.12.2-6.1
Patchnames:
openSUSE-2018-116
openSUSE-2018-5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 binutils Released
SUSE Linux Enterprise Desktop 12 SP2 binutils Released
SUSE Linux Enterprise Desktop 12 SP3 binutils Released
SUSE Linux Enterprise SDK 11 SP4 binutils Ignore
SUSE Linux Enterprise SDK 12 SP2 binutils Released
SUSE Linux Enterprise SDK 12 SP3 binutils Released
SUSE Linux Enterprise Server 11 SP3 LTSS binutils Ignore
SUSE Linux Enterprise Server 11 SP4 binutils Ignore
SUSE Linux Enterprise Server 12 GA LTSS binutils In progress
SUSE Linux Enterprise Server 12 SP1 LTSS binutils In progress
SUSE Linux Enterprise Server 12 SP2 binutils Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI binutils Released
SUSE Linux Enterprise Server 12 SP3 binutils Released