Upstream information

CVE-2017-14226 at MITRE

Description

WP1StylesListener.cpp, WP5StylesListener.cpp, and WP42StylesListener.cpp in libwpd 0.10.1 mishandle iterators, which allows remote attackers to cause a denial of service (heap-based buffer over-read in the WPXTableList class in WPXTable.cpp). This vulnerability can be triggered in LibreOffice before 5.3.7. It may lead to suffering a remote attack against a LibreOffice application.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 7.5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 7.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1058025 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libwpd >= 0.10.2-2.4.1
  • libwpd-0_10-10 >= 0.10.2-2.4.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1816
SUSE Linux Enterprise Desktop 12 SP3
  • libwpd >= 0.10.2-2.4.1
  • libwpd-0_10-10 >= 0.10.2-2.4.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1816
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libwpd >= 0.10.2-2.4.1
  • libwpd-0_10-10 >= 0.10.2-2.4.1
  • libwpd-devel >= 0.10.2-2.4.1
  • libwpd-devel-doc >= 0.10.2-2.4.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1816
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libwpd >= 0.10.2-2.4.1
  • libwpd-0_10-10 >= 0.10.2-2.4.1
  • libwpd-devel >= 0.10.2-2.4.1
  • libwpd-devel-doc >= 0.10.2-2.4.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1816
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libwpd >= 0.10.2-2.4.1
  • libwpd-0_10-10 >= 0.10.2-2.4.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-1816
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libwpd >= 0.10.2-2.4.1
  • libwpd-0_10-10 >= 0.10.2-2.4.1
Patchnames:
SUSE-SLE-WE-12-SP3-2017-1816
SUSE Linux Enterprise Workstation Extension 15
  • libwpd-0_10-10 >= 0.10.2-1.28
  • libwpd-devel >= 0.10.2-1.28
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA libwpd-0_10-10
openSUSE Leap 15.0
  • libwpd-0_10-10 >= 0.10.2-lp150.1.9
Patchnames:
openSUSE Leap 15.0 GA libwpd-0_10-10
openSUSE Leap 42.2
  • libwpd >= 0.10.2-5.3.1
  • libwpd-0_10-10 >= 0.10.2-5.3.1
  • libwpd-0_10-10-debuginfo >= 0.10.2-5.3.1
  • libwpd-debugsource >= 0.10.2-5.3.1
  • libwpd-devel >= 0.10.2-5.3.1
  • libwpd-devel-doc >= 0.10.2-5.3.1
  • libwpd-tools >= 0.10.2-5.3.1
  • libwpd-tools-debuginfo >= 0.10.2-5.3.1
Patchnames:
openSUSE-2017-1247
openSUSE Leap 42.3
  • libwpd >= 0.10.2-8.1
  • libwpd-0_10-10 >= 0.10.2-8.1
  • libwpd-0_10-10-debuginfo >= 0.10.2-8.1
  • libwpd-debugsource >= 0.10.2-8.1
  • libwpd-devel >= 0.10.2-8.1
  • libwpd-devel-doc >= 0.10.2-8.1
  • libwpd-tools >= 0.10.2-8.1
  • libwpd-tools-debuginfo >= 0.10.2-8.1
Patchnames:
openSUSE-2017-1247


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libwpd Released
SUSE Linux Enterprise Desktop 12 SP3 libwpd Released
SUSE Linux Enterprise SDK 11 SP4 libwpd Ignore
SUSE Linux Enterprise SDK 12 SP2 libwpd Released
SUSE Linux Enterprise SDK 12 SP3 libwpd Released
SUSE Linux Enterprise Workstation Extension 12 SP2 libwpd Released
SUSE Linux Enterprise Workstation Extension 12 SP3 libwpd Released