Upstream information

CVE-2017-13803 at MITRE

Description

An issue was discovered in certain Apple products. iOS before 11.1 is affected. Safari before 11.0.1 is affected. iCloud before 7.1 on Windows is affected. iTunes before 12.7.1 on Windows is affected. tvOS before 11.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption and application crash) via a crafted web site.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1069925 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Desktop 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.18.5-2.18.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37 >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.18.5-2.18.1
  • libwebkit2gtk3-lang >= 2.18.5-2.18.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.5-2.18.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.18.5-2.18.1
  • webkit2gtk3 >= 2.18.5-2.18.1
  • webkit2gtk3-debugsource >= 2.18.5-2.18.1
SUSE Linux Enterprise Desktop 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.18.5-2.18.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37 >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.18.5-2.18.1
  • libwebkit2gtk3-lang >= 2.18.5-2.18.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.5-2.18.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.18.5-2.18.1
  • webkit2gtk3 >= 2.18.5-2.18.1
  • webkit2gtk3-debugsource >= 2.18.5-2.18.1
SUSE Linux Enterprise Server 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.18.5-2.18.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37 >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.18.5-2.18.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.5-2.18.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.18.5-2.18.1
  • webkit2gtk3 >= 2.18.5-2.18.1
  • webkit2gtk3-debugsource >= 2.18.5-2.18.1
SUSE Linux Enterprise Server 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.18.5-2.18.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37 >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.18.5-2.18.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.5-2.18.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.18.5-2.18.1
  • webkit2gtk3 >= 2.18.5-2.18.1
  • webkit2gtk3-debugsource >= 2.18.5-2.18.1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.18.5-2.18.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37 >= 2.18.5-2.18.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.18.5-2.18.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.5-2.18.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.5-2.18.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.18.5-2.18.1
  • webkit2gtk3 >= 2.18.5-2.18.1
  • webkit2gtk3-debugsource >= 2.18.5-2.18.1
SUSE Linux Enterprise Software Development Kit 12 SP2
  • webkit2gtk3 >= 2.18.5-2.18.1
  • webkit2gtk3-debugsource >= 2.18.5-2.18.1
  • webkit2gtk3-devel >= 2.18.5-2.18.1
SUSE Linux Enterprise Software Development Kit 12 SP3
  • webkit2gtk3 >= 2.18.5-2.18.1
  • webkit2gtk3-debugsource >= 2.18.5-2.18.1
  • webkit2gtk3-devel >= 2.18.5-2.18.1
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libwebkit2gtk3-lang >= 2.18.5-2.18.1
  • webkit2gtk3 >= 2.18.5-2.18.1
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libwebkit2gtk3-lang >= 2.18.5-2.18.1
  • webkit2gtk3 >= 2.18.5-2.18.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 webkit2gtk3 In progress
SUSE Linux Enterprise Desktop 12 SP3 webkit2gtk3 In progress
SUSE Linux Enterprise SDK 12 SP2 webkit2gtk3 In progress
SUSE Linux Enterprise SDK 12 SP3 webkit2gtk3 In progress
SUSE Linux Enterprise Server 12 SP2 webkit2gtk3 In progress
SUSE Linux Enterprise Server 12 SP3 webkit2gtk3 In progress
SUSE Linux Enterprise Workstation Extension 12 SP2 webkit2gtk3 In progress
SUSE Linux Enterprise Workstation Extension 12 SP3 webkit2gtk3 In progress