Upstream information

CVE-2017-12904 at MITRE

Description

Improper Neutralization of Special Elements used in an OS Command in bookmarking function of Newsbeuter versions 0.7 through 2.9 allows remote attackers to perform user-assisted code execution by crafting an RSS item that includes shell code in its title and/or URL.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 1054578 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • newsbeuter >= 2.9-2.3.1
  • newsbeuter-debuginfo >= 2.9-2.3.1
  • newsbeuter-debugsource >= 2.9-2.3.1
  • newsbeuter-lang >= 2.9-2.3.1
Patchnames:
openSUSE-2018-62
openSUSE Leap 42.3
  • newsbeuter >= 2.9-5.1
  • newsbeuter-debuginfo >= 2.9-5.1
  • newsbeuter-debugsource >= 2.9-5.1
  • newsbeuter-lang >= 2.9-5.1
Patchnames:
openSUSE-2018-62