Upstream information

CVE-2017-12883 at MITRE

Description

Buffer overflow in the S_grok_bslash_N function in regcomp.c in Perl 5 before 5.24.3-RC1 and 5.26.x before 5.26.1-RC1 allows remote attackers to disclose sensitive information or cause a denial of service (application crash) via a crafted regular expression with an invalid '\N{U+...}' escape.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 3.6
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:L/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 5.1
Vector AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1057721 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • perl >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1903
SUSE CaaS Platform ALL
  • perl >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • sles12-caasp-dex-image >= 2.0.0-3.3.11
  • sles12-dnsmasq-nanny-image >= 2.0.1-2.3.15
  • sles12-haproxy-image >= 2.0.1-2.3.16
  • sles12-kubedns-image >= 2.0.1-2.3.11
  • sles12-mariadb-image >= 2.0.1-2.3.15
  • sles12-openldap-image >= 2.0.0-2.3.11
  • sles12-pause-image >= 2.0.1-2.3.9
  • sles12-pv-recycler-node-image >= 2.0.1-2.3.10
  • sles12-salt-api-image >= 2.0.1-2.3.10
  • sles12-salt-master-image >= 2.0.1-2.3.10
  • sles12-salt-minion-image >= 2.0.1-2.3.14
  • sles12-sidecar-image >= 2.0.1-2.3.11
  • sles12-tiller-image >= 2.0.0-2.3.11
  • sles12-velum-image >= 2.0.1-2.3.13
Patchnames:
SUSE-CAASP-ALL-2017-1903
SUSE-CAASP-ALL-2018-40
SUSE Linux Enterprise Desktop 12 SP2
  • perl >= 5.18.2-12.3.1
  • perl-32bit >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • perl-doc >= 5.18.2-12.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1903
SUSE Linux Enterprise Desktop 12 SP3
  • perl >= 5.18.2-12.3.1
  • perl-32bit >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • perl-doc >= 5.18.2-12.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1903
SUSE Linux Enterprise Module for Basesystem 15
  • perl >= 5.26.1-5.41
  • perl-base >= 5.26.1-5.41
  • perl-base-32bit >= 5.26.1-5.41
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA perl
SUSE Linux Enterprise Module for Development Tools 15
  • perl-doc >= 5.26.1-5.41
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA perl-doc
SUSE Linux Enterprise Server 12 SP2
  • perl >= 5.18.2-12.3.1
  • perl-32bit >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • perl-doc >= 5.18.2-12.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1903
SUSE Linux Enterprise Server 12 SP3
  • perl >= 5.18.2-12.3.1
  • perl-32bit >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • perl-doc >= 5.18.2-12.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1903
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • perl >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • perl-doc >= 5.18.2-12.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1903
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • perl >= 5.18.2-12.3.1
  • perl-32bit >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • perl-doc >= 5.18.2-12.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1903
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • perl >= 5.18.2-12.3.1
  • perl-32bit >= 5.18.2-12.3.1
  • perl-base >= 5.18.2-12.3.1
  • perl-doc >= 5.18.2-12.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1903
openSUSE Leap 15.0
  • perl >= 5.26.1-lp150.5.19
  • perl-base >= 5.26.1-lp150.5.19
  • perl-base-32bit >= 5.26.1-lp150.5.19
Patchnames:
openSUSE Leap 15.0 GA perl
openSUSE Leap 42.2
  • perl >= 5.18.2-6.3.1
  • perl-32bit >= 5.18.2-6.3.1
  • perl-base >= 5.18.2-6.3.1
  • perl-base-32bit >= 5.18.2-6.3.1
  • perl-base-debuginfo >= 5.18.2-6.3.1
  • perl-base-debuginfo-32bit >= 5.18.2-6.3.1
  • perl-debuginfo >= 5.18.2-6.3.1
  • perl-debuginfo-32bit >= 5.18.2-6.3.1
  • perl-debugsource >= 5.18.2-6.3.1
  • perl-doc >= 5.18.2-6.3.1
Patchnames:
openSUSE-2017-1304
openSUSE Leap 42.3
  • perl >= 5.18.2-9.1
  • perl-32bit >= 5.18.2-9.1
  • perl-base >= 5.18.2-9.1
  • perl-base-32bit >= 5.18.2-9.1
  • perl-base-debuginfo >= 5.18.2-9.1
  • perl-base-debuginfo-32bit >= 5.18.2-9.1
  • perl-debuginfo >= 5.18.2-9.1
  • perl-debuginfo-32bit >= 5.18.2-9.1
  • perl-debugsource >= 5.18.2-9.1
  • perl-doc >= 5.18.2-9.1
Patchnames:
openSUSE-2017-1304


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 perl Released
CaaS Platform 2.0 perl Released
OpenStack Cloud Magnum Orchestration 7.0 perl Released
SUSE Linux Enterprise Desktop 12 SP2 perl Released
SUSE Linux Enterprise Desktop 12 SP3 perl Released
SUSE Linux Enterprise SDK 11 SP4 perl Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS perl Not affected
SUSE Linux Enterprise Server 11 SP4 perl Not affected
SUSE Linux Enterprise Server 12 GA LTSS perl Affected
SUSE Linux Enterprise Server 12 SP1 LTSS perl Affected
SUSE Linux Enterprise Server 12 SP2 perl Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI perl Released
SUSE Linux Enterprise Server 12 SP3 perl Released