Upstream information

CVE-2017-12627 at MITRE

Description

In Apache Xerces-C XML Parser library before 3.2.1, processing of external DTD paths can result in a null pointer dereference under certain conditions.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High None
Integrity Impact High None
Availability Impact High Low
SUSE Bugzilla entry: 1083630 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libxerces-c-3_1 >= 3.1.4-3.3.25
  • libxerces-c-devel >= 3.1.4-3.3.25
  • xerces-c >= 3.1.4-3.3.25
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-977
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libxerces-c-3_1 >= 3.1.4-3.3.25
  • libxerces-c-devel >= 3.1.4-3.3.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 SP1 GA libxerces-c-3_1
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • xerces-c >= 3.1.4-3.3.25
  • xerces-c-doc >= 3.1.4-3.3.25
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-977
SUSE Linux Enterprise Software Development Kit 11 SP4
  • Xerces-c >= 2.8.0-29.17.5.1
  • libXerces-c-devel >= 2.8.0-29.17.5.1
  • libXerces-c28 >= 2.8.0-29.17.5.1
Patchnames:
sdksp4-Xerces-c-13828
openSUSE Leap 15.0
  • libxerces-c-3_1 >= 3.1.4-lp150.2.3.1
  • libxerces-c-3_1-32bit >= 3.1.4-lp150.2.3.1
  • libxerces-c-3_1-32bit-debuginfo >= 3.1.4-lp150.2.3.1
  • libxerces-c-3_1-debuginfo >= 3.1.4-lp150.2.3.1
  • libxerces-c-devel >= 3.1.4-lp150.2.3.1
  • xerces-c >= 3.1.4-lp150.2.3.1
  • xerces-c-debuginfo >= 3.1.4-lp150.2.3.1
  • xerces-c-debugsource >= 3.1.4-lp150.2.3.1
  • xerces-c-doc >= 3.1.4-lp150.2.3.1
Patchnames:
openSUSE-2019-1283


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 xerces-c In progress
CaaS Platform 3.0 xerces-c In progress
SUSE Linux Enterprise Desktop 12 SP2 xerces-c Affected
SUSE Linux Enterprise Desktop 12 SP3 xerces-c In progress
SUSE Linux Enterprise Desktop 12 SP4 xerces-c In progress
SUSE Linux Enterprise High Performance Computing 12 xerces-c In progress
SUSE Linux Enterprise Module for Basesystem 15 GA xerces-c Released
SUSE Linux Enterprise SDK 11 SP4 Xerces-c Released
SUSE Linux Enterprise SDK 12 SP2 xerces-c Affected
SUSE Linux Enterprise SDK 12 SP3 xerces-c In progress
SUSE Linux Enterprise SDK 12 SP4 xerces-c In progress
SUSE Linux Enterprise Server 12 SP1 LTSS xerces-c Affected
SUSE Linux Enterprise Server 12 SP2 xerces-c Affected
SUSE Linux Enterprise Server 12 SP3 xerces-c In progress
SUSE Linux Enterprise Server 12 SP4 xerces-c In progress
SUSE Linux Enterprise Server for SAP Applications 12 SP3 xerces-c Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 xerces-c In progress