Upstream information

CVE-2017-12194 at MITRE

Description

A flaw was found in the way spice-client processed certain messages sent from the server. An attacker, having control of malicious spice-server, could use this flaw to crash the client or execute arbitrary code with permissions of the user running the client. spice-gtk versions through 0.34 are believed to be vulnerable.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  SUSE
Base Score 4.6
Vector AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:L
Access Vector Network
Access Complexity High
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1085415 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • libspice-client-glib-2_0-8 >= 0.33-3.3.2
  • libspice-client-glib-helper >= 0.33-3.3.2
  • libspice-client-gtk-3_0-5 >= 0.33-3.3.2
  • libspice-controller0 >= 0.33-3.3.2
  • spice-gtk >= 0.33-3.3.2
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-3.3.2
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-592
SUSE Linux Enterprise Server 12 SP3
  • libspice-client-glib-2_0-8 >= 0.33-3.3.2
  • libspice-client-glib-helper >= 0.33-3.3.2
  • libspice-client-gtk-3_0-5 >= 0.33-3.3.2
  • libspice-controller0 >= 0.33-3.3.2
  • spice-gtk >= 0.33-3.3.2
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-3.3.2
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-592
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libspice-client-glib-2_0-8 >= 0.33-3.3.2
  • libspice-client-glib-helper >= 0.33-3.3.2
  • libspice-client-gtk-3_0-5 >= 0.33-3.3.2
  • libspice-controller0 >= 0.33-3.3.2
  • spice-gtk >= 0.33-3.3.2
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-3.3.2
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-592
SUSE Linux Enterprise Software Development Kit 12 SP3
  • spice-gtk >= 0.33-3.3.2
  • spice-gtk-devel >= 0.33-3.3.2
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-3.3.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-592
openSUSE Leap 42.3
  • libspice-client-glib-2_0-8 >= 0.33-2.3.1
  • libspice-client-glib-2_0-8-debuginfo >= 0.33-2.3.1
  • libspice-client-glib-helper >= 0.33-2.3.1
  • libspice-client-glib-helper-debuginfo >= 0.33-2.3.1
  • libspice-client-gtk-3_0-5 >= 0.33-2.3.1
  • libspice-client-gtk-3_0-5-debuginfo >= 0.33-2.3.1
  • libspice-controller0 >= 0.33-2.3.1
  • libspice-controller0-debuginfo >= 0.33-2.3.1
  • spice-gtk >= 0.33-2.3.1
  • spice-gtk-debuginfo >= 0.33-2.3.1
  • spice-gtk-debugsource >= 0.33-2.3.1
  • spice-gtk-devel >= 0.33-2.3.1
  • spice-gtk-lang >= 0.33-2.3.1
  • typelib-1_0-SpiceClientGlib-2_0 >= 0.33-2.3.1
  • typelib-1_0-SpiceClientGtk-3_0 >= 0.33-2.3.1
Patchnames:
openSUSE-2018-342


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 spice-gtk Affected
SUSE Linux Enterprise Desktop 12 SP3 spice-gtk Released
SUSE Linux Enterprise SDK 12 SP2 spice-gtk Affected
SUSE Linux Enterprise SDK 12 SP3 spice-gtk Released
SUSE Linux Enterprise Server 12 SP2 spice-gtk Affected
SUSE Linux Enterprise Server 12 SP3 spice-gtk Released