Upstream information

CVE-2017-12135 at MITRE

Description

Xen allows local OS guest users to cause a denial of service (crash) or possibly obtain sensitive information or gain privileges via vectors involving transitive grants.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.6 5.2
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P AV:L/AC:H/Au:N/C:P/I:P/A:C
Access Vector Local Local
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Complete
CVSS v3 Scores
  SUSE
Base Score 7.3
Vector AV:L/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:H
Access Vector Local
Access Complexity High
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact High
SUSE Bugzilla entry: 1051787 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • xen >= 4.7.3_03-43.9.1
  • xen-libs >= 4.7.3_03-43.9.1
  • xen-tools-domU >= 4.7.3_03-43.9.1
Patchnames:
SUSE-CAASP-ALL-2017-1438
SUSE Linux Enterprise Desktop 12 SP2
  • xen >= 4.7.3_03-43.9.1
  • xen-libs >= 4.7.3_03-43.9.1
  • xen-libs-32bit >= 4.7.3_03-43.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1438
SUSE Linux Enterprise Desktop 12 SP3
  • xen >= 4.9.0_11-3.9.1
  • xen-libs >= 4.9.0_11-3.9.1
  • xen-libs-32bit >= 4.9.0_11-3.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1437
SUSE Linux Enterprise Point of Sale 11 SP3
  • xen >= 4.2.5_21-45.5.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.105-45.5.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.105-45.5.1
  • xen-libs >= 4.2.5_21-45.5.1
  • xen-tools-domU >= 4.2.5_21-45.5.1
Patchnames:
sleposp3-xen-13259
SUSE Linux Enterprise Server 11 SP3-LTSS
  • xen >= 4.2.5_21-45.5.1
  • xen-doc-html >= 4.2.5_21-45.5.1
  • xen-doc-pdf >= 4.2.5_21-45.5.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.105-45.5.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.105-45.5.1
  • xen-libs >= 4.2.5_21-45.5.1
  • xen-libs-32bit >= 4.2.5_21-45.5.1
  • xen-tools >= 4.2.5_21-45.5.1
  • xen-tools-domU >= 4.2.5_21-45.5.1
Patchnames:
slessp3-xen-13259
SUSE Linux Enterprise Server 11 SP4
  • xen >= 4.4.4_22-61.9.2
  • xen-doc-html >= 4.4.4_22-61.9.2
  • xen-kmp-default >= 4.4.4_22_3.0.101_108.7-61.9.2
  • xen-kmp-pae >= 4.4.4_22_3.0.101_108.7-61.9.2
  • xen-libs >= 4.4.4_22-61.9.2
  • xen-libs-32bit >= 4.4.4_22-61.9.2
  • xen-tools >= 4.4.4_22-61.9.2
  • xen-tools-domU >= 4.4.4_22-61.9.2
Patchnames:
slessp4-xen-13281
SUSE Linux Enterprise Server 12 SP1-LTSS
  • xen >= 4.5.5_14-22.25.1
  • xen-doc-html >= 4.5.5_14-22.25.1
  • xen-kmp-default >= 4.5.5_14_k3.12.74_60.64.54-22.25.1
  • xen-libs >= 4.5.5_14-22.25.1
  • xen-libs-32bit >= 4.5.5_14-22.25.1
  • xen-tools >= 4.5.5_14-22.25.1
  • xen-tools-domU >= 4.5.5_14-22.25.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1428
SUSE Linux Enterprise Server 12 SP2
  • xen >= 4.7.3_03-43.9.1
  • xen-doc-html >= 4.7.3_03-43.9.1
  • xen-libs >= 4.7.3_03-43.9.1
  • xen-libs-32bit >= 4.7.3_03-43.9.1
  • xen-tools >= 4.7.3_03-43.9.1
  • xen-tools-domU >= 4.7.3_03-43.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1438
SUSE Linux Enterprise Server 12 SP3
  • xen >= 4.9.0_11-3.9.1
  • xen-doc-html >= 4.9.0_11-3.9.1
  • xen-libs >= 4.9.0_11-3.9.1
  • xen-libs-32bit >= 4.9.0_11-3.9.1
  • xen-tools >= 4.9.0_11-3.9.1
  • xen-tools-domU >= 4.9.0_11-3.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1437
SUSE Linux Enterprise Server 12-LTSS
  • xen >= 4.4.4_22-22.51.2
  • xen-doc-html >= 4.4.4_22-22.51.2
  • xen-kmp-default >= 4.4.4_22_k3.12.61_52.89-22.51.2
  • xen-libs >= 4.4.4_22-22.51.2
  • xen-libs-32bit >= 4.4.4_22-22.51.2
  • xen-tools >= 4.4.4_22-22.51.2
  • xen-tools-domU >= 4.4.4_22-22.51.2
Patchnames:
SUSE-SLE-SERVER-12-2017-1576
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xen >= 4.4.4_22-61.9.2
  • xen-devel >= 4.4.4_22-61.9.2
Patchnames:
sdksp4-xen-13281
SUSE Linux Enterprise Software Development Kit 12 SP2
  • xen >= 4.7.3_03-43.9.1
  • xen-devel >= 4.7.3_03-43.9.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1438
SUSE Linux Enterprise Software Development Kit 12 SP3
  • xen >= 4.9.0_11-3.9.1
  • xen-devel >= 4.9.0_11-3.9.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1437
SUSE Linux Enterprise for SAP 12
  • xen >= 4.4.4_22-22.51.2
  • xen-doc-html >= 4.4.4_22-22.51.2
  • xen-kmp-default >= 4.4.4_22_k3.12.61_52.89-22.51.2
  • xen-libs >= 4.4.4_22-22.51.2
  • xen-libs-32bit >= 4.4.4_22-22.51.2
  • xen-tools >= 4.4.4_22-22.51.2
  • xen-tools-domU >= 4.4.4_22-22.51.2
Patchnames:
SUSE-SLE-SAP-12-2017-1576
SUSE Linux Enterprise for SAP 12 SP1
  • xen >= 4.5.5_14-22.25.1
  • xen-doc-html >= 4.5.5_14-22.25.1
  • xen-kmp-default >= 4.5.5_14_k3.12.74_60.64.54-22.25.1
  • xen-libs >= 4.5.5_14-22.25.1
  • xen-libs-32bit >= 4.5.5_14-22.25.1
  • xen-tools >= 4.5.5_14-22.25.1
  • xen-tools-domU >= 4.5.5_14-22.25.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1428
SUSE OpenStack Cloud 6
  • xen >= 4.5.5_14-22.25.1
  • xen-doc-html >= 4.5.5_14-22.25.1
  • xen-kmp-default >= 4.5.5_14_k3.12.74_60.64.54-22.25.1
  • xen-libs >= 4.5.5_14-22.25.1
  • xen-libs-32bit >= 4.5.5_14-22.25.1
  • xen-tools >= 4.5.5_14-22.25.1
  • xen-tools-domU >= 4.5.5_14-22.25.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1428
openSUSE Leap 42.2
  • xen >= 4.7.3_03-11.12.1
  • xen-debugsource >= 4.7.3_03-11.12.1
  • xen-devel >= 4.7.3_03-11.12.1
  • xen-doc-html >= 4.7.3_03-11.12.1
  • xen-libs >= 4.7.3_03-11.12.1
  • xen-libs-32bit >= 4.7.3_03-11.12.1
  • xen-libs-debuginfo >= 4.7.3_03-11.12.1
  • xen-libs-debuginfo-32bit >= 4.7.3_03-11.12.1
  • xen-tools >= 4.7.3_03-11.12.1
  • xen-tools-debuginfo >= 4.7.3_03-11.12.1
  • xen-tools-domU >= 4.7.3_03-11.12.1
  • xen-tools-domU-debuginfo >= 4.7.3_03-11.12.1
Patchnames:
openSUSE-2017-1022
openSUSE Leap 42.3
  • xen >= 4.9.0_11-4.1
  • xen-debugsource >= 4.9.0_11-4.1
  • xen-devel >= 4.9.0_11-4.1
  • xen-doc-html >= 4.9.0_11-4.1
  • xen-libs >= 4.9.0_11-4.1
  • xen-libs-debuginfo >= 4.9.0_11-4.1
  • xen-tools >= 4.9.0_11-4.1
  • xen-tools-debuginfo >= 4.9.0_11-4.1
  • xen-tools-domU >= 4.9.0_11-4.1
  • xen-tools-domU-debuginfo >= 4.9.0_11-4.1
Patchnames:
openSUSE-2017-1023


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 xen Released
CaaS Platform 2.0 xen Released
SUSE Linux Enterprise Desktop 12 SP2 xen Released
SUSE Linux Enterprise Desktop 12 SP3 xen Released
SUSE Linux Enterprise SDK 11 SP4 xen Released
SUSE Linux Enterprise SDK 12 SP2 xen Released
SUSE Linux Enterprise SDK 12 SP3 xen Released
SUSE Linux Enterprise Server 11 SP3 LTSS xen Released
SUSE Linux Enterprise Server 11 SP4 xen Released
SUSE Linux Enterprise Server 12 GA LTSS xen Released
SUSE Linux Enterprise Server 12 SP1 LTSS xen Released
SUSE Linux Enterprise Server 12 SP2 xen Released
SUSE Linux Enterprise Server 12 SP3 xen Released