Upstream information

CVE-2017-12133 at MITRE

Description

Use-after-free vulnerability in the clntudp_call function in sunrpc/clnt_udp.c in the GNU C Library (aka glibc or libc6) before 2.26 allows remote attackers to have unspecified impact via vectors related to error path.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
CVSS v3 Scores
  SUSE
Base Score 3.7
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1081556 [NEW], 1089314, 980854 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • glibc >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-443
SUSE CaaS Platform ALL
  • glibc >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
Patchnames:
SUSE-CAASP-ALL-2018-443
SUSE Linux Enterprise Desktop 12 SP2
  • glibc >= 2.22-62.10.1
  • glibc-32bit >= 2.22-62.10.1
  • glibc-devel >= 2.22-62.10.1
  • glibc-devel-32bit >= 2.22-62.10.1
  • glibc-i18ndata >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
  • glibc-locale-32bit >= 2.22-62.10.1
  • nscd >= 2.22-62.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-443
SUSE Linux Enterprise Desktop 12 SP3
  • glibc >= 2.22-62.10.1
  • glibc-32bit >= 2.22-62.10.1
  • glibc-devel >= 2.22-62.10.1
  • glibc-devel-32bit >= 2.22-62.10.1
  • glibc-i18ndata >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
  • glibc-locale-32bit >= 2.22-62.10.1
  • nscd >= 2.22-62.10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-443
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-11.8
  • glibc-32bit >= 2.26-11.8
  • glibc-devel >= 2.26-11.8
  • glibc-extra >= 2.26-11.8
  • glibc-i18ndata >= 2.26-11.8
  • glibc-info >= 2.26-11.8
  • glibc-locale >= 2.26-11.8
  • glibc-locale-32bit >= 2.26-11.8
  • glibc-profile >= 2.26-11.8
  • nscd >= 2.26-11.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA glibc
SUSE Linux Enterprise Module for Development Tools 15
  • glibc-devel-32bit >= 2.26-11.8
  • glibc-devel-static >= 2.26-11.8
  • glibc-utils >= 2.26-11.8
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA glibc-devel-32bit
SUSE Linux Enterprise Server 11 SP4
  • glibc >= 2.11.3-17.110.9.2
  • glibc-32bit >= 2.11.3-17.110.9.2
  • glibc-devel >= 2.11.3-17.110.9.2
  • glibc-devel-32bit >= 2.11.3-17.110.9.2
  • glibc-html >= 2.11.3-17.110.9.2
  • glibc-i18ndata >= 2.11.3-17.110.9.2
  • glibc-info >= 2.11.3-17.110.9.2
  • glibc-locale >= 2.11.3-17.110.9.2
  • glibc-locale-32bit >= 2.11.3-17.110.9.2
  • glibc-locale-x86 >= 2.11.3-17.110.9.2
  • glibc-profile >= 2.11.3-17.110.9.2
  • glibc-profile-32bit >= 2.11.3-17.110.9.2
  • glibc-profile-x86 >= 2.11.3-17.110.9.2
  • glibc-x86 >= 2.11.3-17.110.9.2
  • nscd >= 2.11.3-17.110.9.2
Patchnames:
slessp4-glibc-13548
SUSE Linux Enterprise Server 12 SP2
  • glibc >= 2.22-62.10.1
  • glibc-32bit >= 2.22-62.10.1
  • glibc-devel >= 2.22-62.10.1
  • glibc-devel-32bit >= 2.22-62.10.1
  • glibc-html >= 2.22-62.10.1
  • glibc-i18ndata >= 2.22-62.10.1
  • glibc-info >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
  • glibc-locale-32bit >= 2.22-62.10.1
  • glibc-profile >= 2.22-62.10.1
  • glibc-profile-32bit >= 2.22-62.10.1
  • nscd >= 2.22-62.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-443
SUSE Linux Enterprise Server 12 SP3
  • glibc >= 2.22-62.10.1
  • glibc-32bit >= 2.22-62.10.1
  • glibc-devel >= 2.22-62.10.1
  • glibc-devel-32bit >= 2.22-62.10.1
  • glibc-html >= 2.22-62.10.1
  • glibc-i18ndata >= 2.22-62.10.1
  • glibc-info >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
  • glibc-locale-32bit >= 2.22-62.10.1
  • glibc-profile >= 2.22-62.10.1
  • glibc-profile-32bit >= 2.22-62.10.1
  • nscd >= 2.22-62.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-443
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • glibc >= 2.22-62.10.1
  • glibc-devel >= 2.22-62.10.1
  • glibc-html >= 2.22-62.10.1
  • glibc-i18ndata >= 2.22-62.10.1
  • glibc-info >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
  • glibc-profile >= 2.22-62.10.1
  • nscd >= 2.22-62.10.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-443
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • glibc >= 2.11.3-17.110.9.2
  • glibc-32bit >= 2.11.3-17.110.9.2
  • glibc-devel >= 2.11.3-17.110.9.2
  • glibc-devel-32bit >= 2.11.3-17.110.9.2
  • glibc-html >= 2.11.3-17.110.9.2
  • glibc-i18ndata >= 2.11.3-17.110.9.2
  • glibc-info >= 2.11.3-17.110.9.2
  • glibc-locale >= 2.11.3-17.110.9.2
  • glibc-locale-32bit >= 2.11.3-17.110.9.2
  • glibc-locale-x86 >= 2.11.3-17.110.9.2
  • glibc-profile >= 2.11.3-17.110.9.2
  • glibc-profile-32bit >= 2.11.3-17.110.9.2
  • glibc-profile-x86 >= 2.11.3-17.110.9.2
  • glibc-x86 >= 2.11.3-17.110.9.2
  • nscd >= 2.11.3-17.110.9.2
Patchnames:
slessp4-glibc-13548
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • glibc >= 2.22-62.10.1
  • glibc-32bit >= 2.22-62.10.1
  • glibc-devel >= 2.22-62.10.1
  • glibc-devel-32bit >= 2.22-62.10.1
  • glibc-html >= 2.22-62.10.1
  • glibc-i18ndata >= 2.22-62.10.1
  • glibc-info >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
  • glibc-locale-32bit >= 2.22-62.10.1
  • glibc-profile >= 2.22-62.10.1
  • glibc-profile-32bit >= 2.22-62.10.1
  • nscd >= 2.22-62.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-443
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • glibc >= 2.22-62.10.1
  • glibc-32bit >= 2.22-62.10.1
  • glibc-devel >= 2.22-62.10.1
  • glibc-devel-32bit >= 2.22-62.10.1
  • glibc-html >= 2.22-62.10.1
  • glibc-i18ndata >= 2.22-62.10.1
  • glibc-info >= 2.22-62.10.1
  • glibc-locale >= 2.22-62.10.1
  • glibc-locale-32bit >= 2.22-62.10.1
  • glibc-profile >= 2.22-62.10.1
  • glibc-profile-32bit >= 2.22-62.10.1
  • nscd >= 2.22-62.10.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-443
SUSE Linux Enterprise Software Development Kit 11 SP4
  • glibc >= 2.11.3-17.110.9.2
  • glibc-html >= 2.11.3-17.110.9.2
  • glibc-info >= 2.11.3-17.110.9.2
Patchnames:
sdksp4-glibc-13548
SUSE Linux Enterprise Software Development Kit 12 SP2
  • glibc >= 2.22-62.10.1
  • glibc-devel-static >= 2.22-62.10.1
  • glibc-info >= 2.22-62.10.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-443
SUSE Linux Enterprise Software Development Kit 12 SP3
  • glibc >= 2.22-62.10.1
  • glibc-devel-static >= 2.22-62.10.1
  • glibc-info >= 2.22-62.10.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-443
openSUSE Leap 15.0
  • glibc >= 2.26-lp150.10.13
  • glibc-32bit >= 2.26-lp150.10.13
  • glibc-extra >= 2.26-lp150.10.13
  • glibc-locale >= 2.26-lp150.10.13
  • glibc-locale-32bit >= 2.26-lp150.10.13
  • nscd >= 2.26-lp150.10.13
Patchnames:
openSUSE Leap 15.0 GA glibc
openSUSE Leap 42.3
  • glibc >= 2.22-16.3
  • glibc-32bit >= 2.22-16.3
  • glibc-debuginfo >= 2.22-16.3
  • glibc-debuginfo-32bit >= 2.22-16.3
  • glibc-debugsource >= 2.22-16.3
  • glibc-devel >= 2.22-16.3
  • glibc-devel-32bit >= 2.22-16.3
  • glibc-devel-debuginfo >= 2.22-16.3
  • glibc-devel-debuginfo-32bit >= 2.22-16.3
  • glibc-devel-static >= 2.22-16.3
  • glibc-devel-static-32bit >= 2.22-16.3
  • glibc-extra >= 2.22-16.3
  • glibc-extra-debuginfo >= 2.22-16.3
  • glibc-html >= 2.22-16.3
  • glibc-i18ndata >= 2.22-16.3
  • glibc-info >= 2.22-16.3
  • glibc-locale >= 2.22-16.3
  • glibc-locale-32bit >= 2.22-16.3
  • glibc-locale-debuginfo >= 2.22-16.3
  • glibc-locale-debuginfo-32bit >= 2.22-16.3
  • glibc-profile >= 2.22-16.3
  • glibc-profile-32bit >= 2.22-16.3
  • glibc-testsuite >= 2.22-16.3
  • glibc-utils >= 2.22-16.3
  • glibc-utils-32bit >= 2.22-16.3
  • glibc-utils-debuginfo >= 2.22-16.3
  • glibc-utils-debuginfo-32bit >= 2.22-16.3
  • glibc-utils-debugsource >= 2.22-16.3
  • nscd >= 2.22-16.3
  • nscd-debuginfo >= 2.22-16.3
Patchnames:
openSUSE-2018-250


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 glibc Released
CaaS Platform 2.0 glibc Released
OpenStack Cloud Magnum Orchestration 7.0 glibc Released
SUSE Linux Enterprise Desktop 12 SP2 glibc Released
SUSE Linux Enterprise Desktop 12 SP3 glibc Released
SUSE Linux Enterprise SDK 11 SP4 glibc Released
SUSE Linux Enterprise SDK 12 SP2 glibc Released
SUSE Linux Enterprise SDK 12 SP3 glibc Released
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Affected
SUSE Linux Enterprise Server 11 SP4 glibc Released
SUSE Linux Enterprise Server 12 SP2 glibc Released
SUSE Linux Enterprise Server 12 SP3 glibc Released