Upstream information

CVE-2017-11554 at MITRE

Description

There is a stack consumption vulnerability in the lex function in parser.hpp (as used in sassc) in LibSass 3.4.5. A crafted input will lead to a remote denial of service.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 1050148 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • libsass >= 3.3.2-2.3.1
  • libsass-3_3_2-0 >= 3.3.2-2.3.1
  • libsass-3_3_2-0-debuginfo >= 3.3.2-2.3.1
  • libsass-debugsource >= 3.3.2-2.3.1
  • libsass-devel >= 3.3.2-2.3.1
Patchnames:
openSUSE-2017-1250
openSUSE Leap 42.3
  • libsass >= 3.3.2-5.1
  • libsass-3_3_2-0 >= 3.3.2-5.1
  • libsass-3_3_2-0-debuginfo >= 3.3.2-5.1
  • libsass-debugsource >= 3.3.2-5.1
  • libsass-devel >= 3.3.2-5.1
Patchnames:
openSUSE-2017-1250