Upstream information

CVE-2017-11408 at MITRE

Description

In Wireshark 2.2.0 to 2.2.7 and 2.0.0 to 2.0.13, the AMQP dissector could crash. This was addressed in epan/dissectors/packet-amqp.c by checking for successful list dissection.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 1049255 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libwireshark8 >= 2.2.8-48.6.1
  • libwiretap6 >= 2.2.8-48.6.1
  • libwscodecs1 >= 2.2.8-48.6.1
  • libwsutil7 >= 2.2.8-48.6.1
  • wireshark >= 2.2.8-48.6.1
  • wireshark-gtk >= 2.2.8-48.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1248
SUSE Linux Enterprise Desktop 12 SP3
  • libwireshark8 >= 2.2.8-48.6.1
  • libwiretap6 >= 2.2.8-48.6.1
  • libwscodecs1 >= 2.2.8-48.6.1
  • libwsutil7 >= 2.2.8-48.6.1
  • wireshark >= 2.2.8-48.6.1
  • wireshark-gtk >= 2.2.8-48.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1248
SUSE Linux Enterprise Server 11 SP4
  • wireshark >= 2.0.14-40.7.1
  • wireshark-gtk >= 2.0.14-40.7.1
Patchnames:
slessp4-wireshark-13225
SUSE Linux Enterprise Server 12 SP2
  • libwireshark8 >= 2.2.8-48.6.1
  • libwiretap6 >= 2.2.8-48.6.1
  • libwscodecs1 >= 2.2.8-48.6.1
  • libwsutil7 >= 2.2.8-48.6.1
  • wireshark >= 2.2.8-48.6.1
  • wireshark-gtk >= 2.2.8-48.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1248
SUSE Linux Enterprise Server 12 SP3
  • libwireshark8 >= 2.2.8-48.6.1
  • libwiretap6 >= 2.2.8-48.6.1
  • libwscodecs1 >= 2.2.8-48.6.1
  • libwsutil7 >= 2.2.8-48.6.1
  • wireshark >= 2.2.8-48.6.1
  • wireshark-gtk >= 2.2.8-48.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1248
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libwireshark8 >= 2.2.8-48.6.1
  • libwiretap6 >= 2.2.8-48.6.1
  • libwscodecs1 >= 2.2.8-48.6.1
  • libwsutil7 >= 2.2.8-48.6.1
  • wireshark >= 2.2.8-48.6.1
  • wireshark-gtk >= 2.2.8-48.6.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1248
SUSE Linux Enterprise Software Development Kit 11 SP4
  • wireshark >= 2.0.14-40.7.1
  • wireshark-devel >= 2.0.14-40.7.1
  • wireshark-gtk >= 2.0.14-40.7.1
Patchnames:
sdksp4-wireshark-13225
SUSE Linux Enterprise Software Development Kit 12 SP2
  • wireshark >= 2.2.8-48.6.1
  • wireshark-devel >= 2.2.8-48.6.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1248
SUSE Linux Enterprise Software Development Kit 12 SP3
  • wireshark >= 2.2.8-48.6.1
  • wireshark-devel >= 2.2.8-48.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1248
openSUSE Leap 42.2
  • wireshark >= 2.2.8-14.9.1
  • wireshark-debuginfo >= 2.2.8-14.9.1
  • wireshark-debugsource >= 2.2.8-14.9.1
  • wireshark-devel >= 2.2.8-14.9.1
  • wireshark-ui-gtk >= 2.2.8-14.9.1
  • wireshark-ui-gtk-debuginfo >= 2.2.8-14.9.1
  • wireshark-ui-qt >= 2.2.8-14.9.1
  • wireshark-ui-qt-debuginfo >= 2.2.8-14.9.1
Patchnames:
openSUSE-2017-840
openSUSE Leap 42.3
  • wireshark >= 2.2.8-17.1
  • wireshark-debuginfo >= 2.2.8-17.1
  • wireshark-debugsource >= 2.2.8-17.1
  • wireshark-devel >= 2.2.8-17.1
  • wireshark-ui-gtk >= 2.2.8-17.1
  • wireshark-ui-gtk-debuginfo >= 2.2.8-17.1
  • wireshark-ui-qt >= 2.2.8-17.1
  • wireshark-ui-qt-debuginfo >= 2.2.8-17.1
Patchnames:
openSUSE-2017-840


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 wireshark Released
SUSE Linux Enterprise Desktop 12 SP3 wireshark Released
SUSE Linux Enterprise SDK 11 SP4 wireshark Released
SUSE Linux Enterprise SDK 12 SP2 wireshark Released
SUSE Linux Enterprise SDK 12 SP3 wireshark Released
SUSE Linux Enterprise Server 11 SP3 LTSS wireshark Affected
SUSE Linux Enterprise Server 11 SP4 wireshark Released
SUSE Linux Enterprise Server 12 GA LTSS wireshark Affected
SUSE Linux Enterprise Server 12 SP1 LTSS wireshark Affected
SUSE Linux Enterprise Server 12 SP2 wireshark Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI wireshark Released
SUSE Linux Enterprise Server 12 SP3 wireshark Released