Upstream information

CVE-2017-10916 at MITRE

Description

The vCPU context-switch implementation in Xen through 4.8.x improperly interacts with the Memory Protection Extensions (MPX) and Protection Key (PKU) features, which makes it easier for guest OS users to defeat ASLR and other protection mechanisms, aka XSA-220.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 3.3
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N AV:L/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network Local
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None Partial
CVSS v3 Scores
  SUSE
Base Score 5.7
Vector AV:L/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction None
Scope Changed
Confidentiality Impact Low
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1042923 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP1-LTSS
  • xen >= 4.5.5_12-22.18.1
  • xen-doc-html >= 4.5.5_12-22.18.1
  • xen-kmp-default >= 4.5.5_12_k3.12.74_60.64.45-22.18.1
  • xen-libs >= 4.5.5_12-22.18.1
  • xen-libs-32bit >= 4.5.5_12-22.18.1
  • xen-tools >= 4.5.5_12-22.18.1
  • xen-tools-domU >= 4.5.5_12-22.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1121
SUSE Linux Enterprise for SAP 12 SP1
  • xen >= 4.5.5_12-22.18.1
  • xen-doc-html >= 4.5.5_12-22.18.1
  • xen-kmp-default >= 4.5.5_12_k3.12.74_60.64.45-22.18.1
  • xen-libs >= 4.5.5_12-22.18.1
  • xen-libs-32bit >= 4.5.5_12-22.18.1
  • xen-tools >= 4.5.5_12-22.18.1
  • xen-tools-domU >= 4.5.5_12-22.18.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1121
SUSE OpenStack Cloud 6
  • xen >= 4.5.5_12-22.18.1
  • xen-doc-html >= 4.5.5_12-22.18.1
  • xen-kmp-default >= 4.5.5_12_k3.12.74_60.64.45-22.18.1
  • xen-libs >= 4.5.5_12-22.18.1
  • xen-libs-32bit >= 4.5.5_12-22.18.1
  • xen-tools >= 4.5.5_12-22.18.1
  • xen-tools-domU >= 4.5.5_12-22.18.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1121


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 xen Ignore
SUSE Linux Enterprise Desktop 12 SP2 xen Released
SUSE Linux Enterprise SDK 11 SP4 xen Not affected
SUSE Linux Enterprise SDK 12 SP1 xen Ignore
SUSE Linux Enterprise SDK 12 SP2 xen Released
SUSE Linux Enterprise Server 11 SP3 LTSS xen Not affected
SUSE Linux Enterprise Server 11 SP4 xen Not affected
SUSE Linux Enterprise Server 12 GA LTSS xen Not affected
SUSE Linux Enterprise Server 12 SP1 xen Ignore
SUSE Linux Enterprise Server 12 SP1 LTSS xen Released
SUSE Linux Enterprise Server 12 SP2 xen Released