Upstream information

CVE-2017-10365 at MITRE

Description

Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: InnoDB). Supported versions that are affected are 5.7.18 and earlier. Easily exploitable vulnerability allows high privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized update, insert or delete access to some of MySQL Server accessible data and unauthorized ability to cause a partial denial of service (partial DOS) of MySQL Server. CVSS 3.0 Base Score 3.8 (Integrity and Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5.5 4.7
Vector AV:N/AC:L/Au:S/C:N/I:P/A:P AV:N/AC:L/Au:M/C:N/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication Single Multiple
Confidentiality Impact None None
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 3.8
Vector AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:L
Access Vector Network
Access Complexity Low
Privileges Required High
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entries: 1064114 [RESOLVED / INVALID], 1064119 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15
  • libmysqld-devel >= 10.2.15-1.3
  • libmysqld19 >= 10.2.15-1.3
  • mariadb >= 10.2.15-1.3
  • mariadb-client >= 10.2.15-1.3
  • mariadb-errormessages >= 10.2.15-1.3
  • mariadb-tools >= 10.2.15-1.3
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libmysqld-devel
SUSE OpenStack Cloud 7
  • galera-3 >= 25.3.23-8.3
  • galera-3-wsrep-provider >= 25.3.23-8.3
  • libmariadb3 >= 3.0.3-1.3.3
  • mariadb >= 10.2.15-7.1
  • mariadb-client >= 10.2.15-7.1
  • mariadb-connector-c >= 3.0.3-1.3.3
  • mariadb-errormessages >= 10.2.15-7.1
  • mariadb-galera >= 10.2.15-7.1
  • mariadb-tools >= 10.2.15-7.1
  • ruby2.1-rubygem-mysql2 >= 0.4.10-7.2
  • rubygem-mysql2 >= 0.4.10-7.2
  • xtrabackup >= 2.4.10-5.3
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1253
openSUSE Leap 15.0
  • libmysqld19 >= 10.2.14-lp150.1.1
  • mariadb >= 10.2.14-lp150.1.1
  • mariadb-client >= 10.2.14-lp150.1.1
  • mariadb-errormessages >= 10.2.14-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libmysqld19


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Desktop 12 SP3 mariadb Not affected
SUSE Linux Enterprise SDK 11 SP4 mysql Ignore
SUSE Linux Enterprise SDK 12 SP2 mariadb Unsupported
SUSE Linux Enterprise SDK 12 SP3 mariadb Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS mysql Ignore
SUSE Linux Enterprise Server 11 SP4 mysql Not affected
SUSE Linux Enterprise Server 12 GA LTSS mariadb Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS mariadb Not affected
SUSE Linux Enterprise Server 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Server 12 SP3 mariadb Not affected
SUSE Linux Enterprise Workstation Extension 12 SP2 mariadb Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP3 mariadb Not affected
SUSE Openstack Cloud 7 mariadb Released