Upstream information

CVE-2017-1000422 at MITRE

Description

Gnome gdk-pixbuf 2.36.8 and older is vulnerable to several integer overflow in the gif_get_lzw function resulting in memory corruption and potential code execution

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1074462 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • gdk-pixbuf >= 2.34.0-19.11.1
  • gdk-pixbuf-lang >= 2.34.0-19.11.1
  • gdk-pixbuf-query-loaders >= 2.34.0-19.11.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-19.11.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-19.11.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-19.11.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-19.11.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1322
SUSE Linux Enterprise Server 12 SP3
  • gdk-pixbuf >= 2.34.0-19.11.1
  • gdk-pixbuf-lang >= 2.34.0-19.11.1
  • gdk-pixbuf-query-loaders >= 2.34.0-19.11.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-19.11.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-19.11.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-19.11.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1322
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • gdk-pixbuf >= 2.34.0-19.11.1
  • gdk-pixbuf-lang >= 2.34.0-19.11.1
  • gdk-pixbuf-query-loaders >= 2.34.0-19.11.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-19.11.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-19.11.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-19.11.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1322
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gdk-pixbuf >= 2.34.0-19.11.1
  • gdk-pixbuf-devel >= 2.34.0-19.11.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1322
openSUSE Leap 42.3
  • gdk-pixbuf >= 2.34.0-16.1
  • gdk-pixbuf-debugsource >= 2.34.0-16.1
  • gdk-pixbuf-devel >= 2.34.0-16.1
  • gdk-pixbuf-devel-32bit >= 2.34.0-16.1
  • gdk-pixbuf-devel-debuginfo >= 2.34.0-16.1
  • gdk-pixbuf-devel-debuginfo-32bit >= 2.34.0-16.1
  • gdk-pixbuf-lang >= 2.34.0-16.1
  • gdk-pixbuf-query-loaders >= 2.34.0-16.1
  • gdk-pixbuf-query-loaders-32bit >= 2.34.0-16.1
  • gdk-pixbuf-query-loaders-debuginfo >= 2.34.0-16.1
  • gdk-pixbuf-query-loaders-debuginfo-32bit >= 2.34.0-16.1
  • libgdk_pixbuf-2_0-0 >= 2.34.0-16.1
  • libgdk_pixbuf-2_0-0-32bit >= 2.34.0-16.1
  • libgdk_pixbuf-2_0-0-debuginfo >= 2.34.0-16.1
  • libgdk_pixbuf-2_0-0-debuginfo-32bit >= 2.34.0-16.1
  • typelib-1_0-GdkPixbuf-2_0 >= 2.34.0-16.1
Patchnames:
openSUSE-2018-741


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 gdk-pixbuf Unsupported
SUSE Linux Enterprise Desktop 12 SP3 gdk-pixbuf Released
SUSE Linux Enterprise SDK 11 SP4 gdk-pixbuf In progress
SUSE Linux Enterprise SDK 12 SP2 gdk-pixbuf Unsupported
SUSE Linux Enterprise SDK 12 SP3 gdk-pixbuf Released
SUSE Linux Enterprise Server 12 SP2 gdk-pixbuf Unsupported
SUSE Linux Enterprise Server 12 SP3 gdk-pixbuf Released