Upstream information

CVE-2017-1000382 at MITRE

Description

VIM version 8.0.1187 (and other versions most likely) ignores umask when creating a swap file ("[ORIGINAL_FILENAME].swp") resulting in files that may be world readable or otherwise accessible in ways not intended by the user running the vi binary.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  SUSE
Base Score 5.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1065958 [NEW], 1070955 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • vim >= 8.0.1568-3.20
  • vim-data >= 8.0.1568-3.20
  • vim-data-common >= 8.0.1568-3.20
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA vim
SUSE Linux Enterprise Module for Desktop Applications 15
  • gvim >= 8.0.1568-3.20
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA gvim
openSUSE Leap 15.0
  • vim >= 8.0.1568-lp150.3.1
  • vim-data >= 8.0.1568-lp150.3.1
  • vim-data-common >= 8.0.1568-lp150.3.1
Patchnames:
openSUSE Leap 15.0 GA vim


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 vim Affected
OpenStack Cloud Magnum Orchestration 7.0 vim Affected
SUSE Linux Enterprise Desktop 12 SP2 vim Affected
SUSE Linux Enterprise Desktop 12 SP3 vim Affected
SUSE Linux Enterprise Server 11 SP3 LTSS vim Affected
SUSE Linux Enterprise Server 11 SP4 vim Affected
SUSE Linux Enterprise Server 12 GA LTSS vim Affected
SUSE Linux Enterprise Server 12 SP1 LTSS vim Affected
SUSE Linux Enterprise Server 12 SP2 vim Affected
SUSE Linux Enterprise Server 12 SP3 vim Affected