Upstream information

CVE-2017-1000381 at MITRE

Description

The c-ares function `ares_parse_naptr_reply()`, which is used for parsing NAPTR responses, could be triggered to read memory outside of the given input buffer if the passed in DNS response packet was crafted in a particular way.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 6.4
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None Partial
CVSS v3 Scores
  SUSE
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1044946 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • nodejs-common >= 1.0-2.1
  • nodejs4 >= 4.8.4-15.5.1
  • nodejs6 >= 6.11.1-11.5.1
Patchnames:
SUSE-Storage-4-2017-1331
SUSE Linux Enterprise Desktop 12 SP2
  • libcares2 >= 1.9.1-8.1
  • libcares2-32bit >= 1.9.1-8.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1117
SUSE Linux Enterprise Module for Basesystem 15
  • c-ares-devel >= 1.14.0-1.17
  • libcares2 >= 1.14.0-1.17
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA c-ares-devel
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs-common >= 1.0-2.1
  • nodejs4 >= 4.8.4-15.5.1
  • nodejs4-devel >= 4.8.4-15.5.1
  • nodejs4-docs >= 4.8.4-15.5.1
  • nodejs6 >= 6.11.1-11.5.1
  • nodejs6-devel >= 6.11.1-11.5.1
  • nodejs6-docs >= 6.11.1-11.5.1
  • npm4 >= 4.8.4-15.5.1
  • npm6 >= 6.11.1-11.5.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2017-1331
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.1-1.19
  • nodejs8-devel >= 8.11.1-1.19
  • nodejs8-docs >= 8.11.1-1.19
  • npm8 >= 8.11.1-1.19
Patchnames:
SUSE Linux Enterprise Module for Web Scripting 15 GA nodejs8
SUSE Linux Enterprise Server 12 SP2
  • libcares2 >= 1.9.1-8.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1117
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libcares2 >= 1.9.1-8.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1117
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libcares2 >= 1.9.1-8.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1117
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libcares-devel >= 1.9.1-8.1
  • libcares2 >= 1.9.1-8.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1117
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libcares2 >= 1.9.1-8.1
  • libcares2-32bit >= 1.9.1-8.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-1117
SUSE OpenStack Cloud 7
  • nodejs-common >= 1.0-2.1
  • nodejs6 >= 6.11.1-11.5.1
Patchnames:
SUSE-OpenStack-Cloud-7-2017-1331
openSUSE Leap 15.0
  • libcares2 >= 1.14.0-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libcares2
openSUSE Leap 42.2
  • libcares-devel >= 1.9.1-8.3.1
  • libcares2 >= 1.9.1-8.3.1
  • libcares2-32bit >= 1.9.1-8.3.1
  • libcares2-debuginfo >= 1.9.1-8.3.1
  • libcares2-debuginfo-32bit >= 1.9.1-8.3.1
  • libcares2-debugsource >= 1.9.1-8.3.1
  • nodejs-common >= 1.0-2.1
  • nodejs4 >= 4.8.4-5.6.1
  • nodejs4-debuginfo >= 4.8.4-5.6.1
  • nodejs4-debugsource >= 4.8.4-5.6.1
  • nodejs4-devel >= 4.8.4-5.6.1
  • nodejs4-docs >= 4.8.4-5.6.1
  • npm4 >= 4.8.4-5.6.1
Patchnames:
openSUSE-2017-810
openSUSE-2017-948
openSUSE Leap 42.3
  • libcares2 >= 1.9.1-10.1
  • nodejs-common >= 1.0-2.1
  • nodejs4 >= 4.8.4-8.1
  • nodejs4-debuginfo >= 4.8.4-8.1
  • nodejs4-debugsource >= 4.8.4-8.1
  • nodejs4-devel >= 4.8.4-8.1
  • nodejs4-docs >= 4.8.4-8.1
  • nodejs6 >= 6.11.1-3.1
  • nodejs6-debuginfo >= 6.11.1-3.1
  • nodejs6-debugsource >= 6.11.1-3.1
  • nodejs6-devel >= 6.11.1-3.1
  • nodejs6-docs >= 6.11.1-3.1
  • npm4 >= 4.8.4-8.1
  • npm6 >= 6.11.1-3.1
Patchnames:
openSUSE Leap 42.3 GA libcares2
openSUSE-2017-948


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libcares2 Released
SUSE Linux Enterprise SDK 11 SP4 libcares2 Not affected
SUSE Linux Enterprise SDK 12 SP2 libcares2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS libcares2 Not affected
SUSE Linux Enterprise Server 11 SP4 libcares2 Not affected
SUSE Linux Enterprise Server 12 GA LTSS libcares2 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS libcares2 Affected
SUSE Linux Enterprise Server 12 SP2 libcares2 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI libcares2 Released
SUSE Linux Enterprise Workstation Extension 12 SP2 libcares2 Released