Upstream information

CVE-2017-1000369 at MITRE

Description

Exim supports the use of multiple "-p" command line arguments which are malloc()'ed and never free()'ed, used in conjunction with other issues allows attackers to cause arbitrary code execution. This affects exim version 4.89 and earlier. Please note that at this time upstream has released a patch (commit 65e061b76867a9ea7aeeb535341b790b90ae6c21), but it is not known if a new point release is available that addresses this issue at this time.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 1037551 [NEW], 1044692 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • exim >= 4.86.2-10.6.1
  • exim-debuginfo >= 4.86.2-10.6.1
  • exim-debugsource >= 4.86.2-10.6.1
  • eximon >= 4.86.2-10.6.1
  • eximon-debuginfo >= 4.86.2-10.6.1
  • eximstats-html >= 4.86.2-10.6.1
Patchnames:
openSUSE-2017-714
openSUSE-2017-980
openSUSE Leap 42.3
  • exim >= 4.86.2-14.1
  • exim-debuginfo >= 4.86.2-14.1
  • exim-debugsource >= 4.86.2-14.1
  • eximon >= 4.86.2-14.1
  • eximon-debuginfo >= 4.86.2-14.1
  • eximstats-html >= 4.86.2-14.1
Patchnames:
openSUSE-2017-980