Upstream information

CVE-2017-1000211 at MITRE

Description

Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in memory disclosure, because HTML_put_string() can append a chunk onto itself.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1068885 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP2
  • lynx >= 2.8.7-28.3.1
Patchnames:
SUSE-SLE-BSK-12-SP2-2017-1983
SUSE Linux Enterprise Build System Kit 12 SP3
  • lynx >= 2.8.7-28.3.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2017-1983
SUSE Linux Enterprise Software Development Kit 11 SP4
  • lynx >= 2.8.6-146.3.1
Patchnames:
sdksp4-lynx-13360
openSUSE Leap 42.2
  • lynx >= 2.8.7-8.3.1
  • lynx-debuginfo >= 2.8.7-8.3.1
  • lynx-debugsource >= 2.8.7-8.3.1
Patchnames:
openSUSE-2017-1332
openSUSE Leap 42.3
  • lynx >= 2.8.7-11.1
  • lynx-debuginfo >= 2.8.7-11.1
  • lynx-debugsource >= 2.8.7-11.1
Patchnames:
openSUSE-2017-1332


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 SP2 lynx Released
SUSE Linux Enterprise BSK 12 SP3 lynx Released
SUSE Linux Enterprise SDK 11 SP4 lynx Released