Upstream information

CVE-2017-1000117 at MITRE

Description

A malicious third-party can give a crafted "ssh://..." URL to an unsuspecting victim, and an attempt to visit the URL can result in any program that exists on the victim's machine being executed. Such a URL could be placed in the .gitmodules file of a malicious project, and an unsuspecting victim could be tricked into running "git clone --recurse-submodules" to trigger the vulnerability.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 5.1
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  SUSE
Base Score 8.5
Vector AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact High
Integrity Impact High
Availability Impact High

Note from the SUSE Security Team

The security fixes for this problem are in the 'git-core' sub-package.

SUSE Bugzilla entries: 1052481 [RESOLVED], 1052696 [RESOLVED / FIXED], 1052932 [RESOLVED], 1053364 [RESOLVED / FIXED], 1053600 [RESOLVED / FIXED], 1053919 [RESOLVED / FIXED], 1058214 [CONFIRMED], 1066430 [IN_PROGRESS], 1071709 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1429
SUSE CaaS Platform ALL
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
Patchnames:
SUSE-CAASP-ALL-2017-1429
SUSE Linux Enterprise Module for Basesystem 15
  • git-core >= 2.16.3-1.30
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA git-core
SUSE Linux Enterprise Module for Development Tools 15
  • git >= 2.16.3-1.30
  • git-arch >= 2.16.3-1.30
  • git-cvs >= 2.16.3-1.30
  • git-daemon >= 2.16.3-1.30
  • git-doc >= 2.16.3-1.30
  • git-email >= 2.16.3-1.30
  • git-gui >= 2.16.3-1.30
  • git-svn >= 2.16.3-1.30
  • git-web >= 2.16.3-1.30
  • gitk >= 2.16.3-1.30
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA git
SUSE Linux Enterprise Server 12 SP1-LTSS
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1429
SUSE Linux Enterprise Server 12 SP2
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1429
SUSE Linux Enterprise Server 12 SP3
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1429
SUSE Linux Enterprise Server 12-LTSS
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1429
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1429
SUSE Linux Enterprise Server for SAP Applications 12
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SAP-12-2017-1429
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1429
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1429
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1429
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1429
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1429
SUSE Linux Enterprise Software Development Kit 11 SP4
  • git >= 1.7.12.4-0.18.3.1
  • git-arch >= 1.7.12.4-0.18.3.1
  • git-core >= 1.7.12.4-0.18.3.1
  • git-cvs >= 1.7.12.4-0.18.3.1
  • git-daemon >= 1.7.12.4-0.18.3.1
  • git-email >= 1.7.12.4-0.18.3.1
  • git-gui >= 1.7.12.4-0.18.3.1
  • git-svn >= 1.7.12.4-0.18.3.1
  • git-web >= 1.7.12.4-0.18.3.1
  • gitk >= 1.7.12.4-0.18.3.1
Patchnames:
sdksp4-git-13235
SUSE Linux Enterprise Software Development Kit 12 SP2
  • git >= 2.12.3-27.5.1
  • git-arch >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-cvs >= 2.12.3-27.5.1
  • git-daemon >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
  • git-email >= 2.12.3-27.5.1
  • git-gui >= 2.12.3-27.5.1
  • git-svn >= 2.12.3-27.5.1
  • git-web >= 2.12.3-27.5.1
  • gitk >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1429
SUSE Linux Enterprise Software Development Kit 12 SP3
  • git >= 2.12.3-27.5.1
  • git-arch >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-cvs >= 2.12.3-27.5.1
  • git-daemon >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
  • git-email >= 2.12.3-27.5.1
  • git-gui >= 2.12.3-27.5.1
  • git-svn >= 2.12.3-27.5.1
  • git-web >= 2.12.3-27.5.1
  • gitk >= 2.12.3-27.5.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1429
SUSE OpenStack Cloud 6
  • git >= 2.12.3-27.5.1
  • git-core >= 2.12.3-27.5.1
  • git-doc >= 2.12.3-27.5.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1429
SUSE Studio Onsite 1.3
  • git >= 1.7.12.4-0.18.3.1
  • git-core >= 1.7.12.4-0.18.3.1
Patchnames:
slestso13-git-13235
openSUSE Leap 42.2
  • git >= 2.12.3-5.10.1
  • git-arch >= 2.12.3-5.10.1
  • git-core >= 2.12.3-5.10.1
  • git-core-debuginfo >= 2.12.3-5.10.1
  • git-credential-gnome-keyring >= 2.12.3-5.10.1
  • git-credential-gnome-keyring-debuginfo >= 2.12.3-5.10.1
  • git-cvs >= 2.12.3-5.10.1
  • git-daemon >= 2.12.3-5.10.1
  • git-daemon-debuginfo >= 2.12.3-5.10.1
  • git-debugsource >= 2.12.3-5.10.1
  • git-doc >= 2.12.3-5.10.1
  • git-email >= 2.12.3-5.10.1
  • git-gui >= 2.12.3-5.10.1
  • git-svn >= 2.12.3-5.10.1
  • git-svn-debuginfo >= 2.12.3-5.10.1
  • git-web >= 2.12.3-5.10.1
  • gitk >= 2.12.3-5.10.1
Patchnames:
openSUSE-2017-988
openSUSE Leap 42.3
  • git >= 2.13.5-3.1
  • git-arch >= 2.13.5-3.1
  • git-core >= 2.13.5-3.1
  • git-core-debuginfo >= 2.13.5-3.1
  • git-credential-gnome-keyring >= 2.13.5-3.1
  • git-credential-gnome-keyring-debuginfo >= 2.13.5-3.1
  • git-cvs >= 2.13.5-3.1
  • git-daemon >= 2.13.5-3.1
  • git-daemon-debuginfo >= 2.13.5-3.1
  • git-debugsource >= 2.13.5-3.1
  • git-doc >= 2.13.5-3.1
  • git-email >= 2.13.5-3.1
  • git-gui >= 2.13.5-3.1
  • git-svn >= 2.13.5-3.1
  • git-svn-debuginfo >= 2.13.5-3.1
  • git-web >= 2.13.5-3.1
  • gitk >= 2.13.5-3.1
Patchnames:
openSUSE-2017-939


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 git Released
CaaS Platform 2.0 git Released
OpenStack Cloud Magnum Orchestration 7.0 git Released
SUSE Linux Enterprise SDK 11 SP4 git Released
SUSE Linux Enterprise SDK 12 SP2 git Released
SUSE Linux Enterprise SDK 12 SP3 git Released
SUSE Linux Enterprise Server 12 GA LTSS git Released
SUSE Linux Enterprise Server 12 SP1 LTSS git Released
SUSE Linux Enterprise Server 12 SP2 git Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI git Released
SUSE Linux Enterprise Server 12 SP3 git Released
SUSE Studio Onsite 1.3 git Released