Upstream information

CVE-2017-1000100 at MITRE

Description

When doing a TFTP transfer and curl/libcurl is given a URL that contains a very long file name (longer than about 515 bytes), the file name is truncated to fit within the buffer boundaries, but the buffer size is still wrongly updated to use the untruncated length. This too large value is then used in the sendto() call, making curl attempt to send more data than what is actually put into the buffer. The endto() function will then read beyond the end of the heap based buffer. A malicious HTTP(S) server could redirect a vulnerable libcurl-using client to a crafted TFTP URL (if the client hasn't restricted which protocols it allows redirects to) and trick it to send private memory contents to a remote server over UDP. Limit curl's redirect protocols with --proto-redir and libcurl's with CURLOPT_REDIR_PROTOCOLS.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 1.5
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N AV:L/AC:M/Au:S/C:P/I:N/A:N
Access Vector Network Local
Access Complexity Medium Medium
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  SUSE
Base Score 3.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1051644 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1335
SUSE CaaS Platform ALL
  • caasp-container-manifests >= 0.0.0+git_r155_93e40ab-2.3.3
  • container-feeder >= 0.0.0+20170901.git_r55_17ecbd3-2.3.3
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
  • sles12-mariadb-docker-image >= 1.1.0-2.3.10
  • sles12-pause-docker-image >= 1.1.0-2.3.11
  • sles12-pv-recycler-node-docker-image >= 1.1.0-2.3.10
  • sles12-salt-api-docker-image >= 1.1.0-2.3.9
  • sles12-salt-master-docker-image >= 1.1.0-4.3.10
  • sles12-salt-minion-docker-image >= 1.1.0-2.3.8
  • sles12-velum-docker-image >= 1.1.0-4.3.9
Patchnames:
SUSE-CAASP-ALL-2017-1335
SUSE-CAASP-ALL-2017-1531
SUSE Linux Enterprise Desktop 12 SP2
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
  • libcurl4-32bit >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1335
SUSE Linux Enterprise Desktop 12 SP3
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
  • libcurl4-32bit >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1335
SUSE Linux Enterprise Module for Basesystem 15
  • curl >= 7.60.0-1.1
  • libcurl-devel >= 7.60.0-1.1
  • libcurl4 >= 7.60.0-1.1
  • libcurl4-32bit >= 7.60.0-1.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA curl
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
  • sles12sp2-docker-image >= 1.0.2-20180821
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE-SLE-Module-Containers-12-2018-1762
SUSE Linux Enterprise Server 11 SP4
  • curl >= 7.19.7-1.70.3.1
  • libcurl4 >= 7.19.7-1.70.3.1
  • libcurl4-32bit >= 7.19.7-1.70.3.1
  • libcurl4-x86 >= 7.19.7-1.70.3.1
Patchnames:
slessp4-curl-13256
SUSE Linux Enterprise Server 11-SECURITY
  • curl-openssl1 >= 7.19.7-1.70.3.1
  • libcurl4-openssl1 >= 7.19.7-1.70.3.1
  • libcurl4-openssl1-32bit >= 7.19.7-1.70.3.1
  • libcurl4-openssl1-x86 >= 7.19.7-1.70.3.1
Patchnames:
secsp3-curl-13256
SUSE Linux Enterprise Server 12 SP2
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
  • libcurl4-32bit >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1335
SUSE Linux Enterprise Server 12 SP3
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
  • libcurl4-32bit >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1335
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1335
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • curl >= 7.19.7-1.70.3.1
  • libcurl4 >= 7.19.7-1.70.3.1
  • libcurl4-32bit >= 7.19.7-1.70.3.1
  • libcurl4-x86 >= 7.19.7-1.70.3.1
Patchnames:
slessp4-curl-13256
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • curl-openssl1 >= 7.19.7-1.70.3.1
  • libcurl4-openssl1 >= 7.19.7-1.70.3.1
  • libcurl4-openssl1-32bit >= 7.19.7-1.70.3.1
  • libcurl4-openssl1-x86 >= 7.19.7-1.70.3.1
Patchnames:
secsp3-curl-13256
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
  • libcurl4-32bit >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1335
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • curl >= 7.37.0-37.3.1
  • libcurl4 >= 7.37.0-37.3.1
  • libcurl4-32bit >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1335
SUSE Linux Enterprise Software Development Kit 11 SP4
  • curl >= 7.19.7-1.70.3.1
  • libcurl-devel >= 7.19.7-1.70.3.1
Patchnames:
sdksp4-curl-13256
SUSE Linux Enterprise Software Development Kit 12 SP2
  • curl >= 7.37.0-37.3.1
  • libcurl-devel >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1335
SUSE Linux Enterprise Software Development Kit 12 SP3
  • curl >= 7.37.0-37.3.1
  • libcurl-devel >= 7.37.0-37.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1335
SUSE Studio Onsite 1.3
  • curl >= 7.19.7-1.20.53.3.1
  • libcurl-devel >= 7.19.7-1.20.53.3.1
Patchnames:
slestso13-curl-13265
openSUSE Leap 15.0
  • curl >= 7.59.0-lp150.1.1
  • libcurl4 >= 7.59.0-lp150.1.1
  • libcurl4-32bit >= 7.59.0-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA curl
openSUSE Leap 42.2
  • curl >= 7.37.0-16.6.1
  • curl-debuginfo >= 7.37.0-16.6.1
  • curl-debugsource >= 7.37.0-16.6.1
  • libcurl-devel >= 7.37.0-16.6.1
  • libcurl-devel-32bit >= 7.37.0-16.6.1
  • libcurl4 >= 7.37.0-16.6.1
  • libcurl4-32bit >= 7.37.0-16.6.1
  • libcurl4-debuginfo >= 7.37.0-16.6.1
  • libcurl4-debuginfo-32bit >= 7.37.0-16.6.1
Patchnames:
openSUSE-2017-951
openSUSE Leap 42.3
  • curl >= 7.37.0-20.1
  • curl-debuginfo >= 7.37.0-20.1
  • curl-debugsource >= 7.37.0-20.1
  • libcurl-devel >= 7.37.0-20.1
  • libcurl-devel-32bit >= 7.37.0-20.1
  • libcurl4 >= 7.37.0-20.1
  • libcurl4-32bit >= 7.37.0-20.1
  • libcurl4-debuginfo >= 7.37.0-20.1
  • libcurl4-debuginfo-32bit >= 7.37.0-20.1
Patchnames:
openSUSE-2017-951


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 curl Released
CaaS Platform 2.0 curl Released
OpenStack Cloud Magnum Orchestration 7.0 curl Released
SUSE Linux Enterprise Desktop 12 SP2 curl Released
SUSE Linux Enterprise Desktop 12 SP3 curl Released
SUSE Linux Enterprise SDK 11 SP4 curl Released
SUSE Linux Enterprise SDK 12 SP2 curl Released
SUSE Linux Enterprise SDK 12 SP3 curl Released
SUSE Linux Enterprise Server 11 SP3 LTSS curl Already fixed
SUSE Linux Enterprise Server 11 SP4 curl Released
SUSE Linux Enterprise Server 12 GA LTSS curl Affected
SUSE Linux Enterprise Server 12 SP1 LTSS curl Affected
SUSE Linux Enterprise Server 12 SP2 curl Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI curl Released
SUSE Linux Enterprise Server 12 SP3 curl Released
SUSE Studio Onsite 1.3 curl Released