Upstream information

CVE-2017-0379 at MITRE

Description

Libgcrypt before 1.8.1 does not properly consider Curve25519 side-channel attacks, which makes it easier for attackers to discover a secret key, related to cipher/ecc.c and mpi/ec.c.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 1.2
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N AV:L/AC:H/Au:N/C:P/I:N/A:N
Access Vector Network Local
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 3.7
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact None None
Availability Impact None None
SUSE Bugzilla entry: 1055837 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 libgcrypt Not affected
OpenStack Cloud Magnum Orchestration 7.0 libgcrypt Not affected
SUSE Linux Enterprise Desktop 12 SP2 libgcrypt Not affected
SUSE Linux Enterprise Desktop 12 SP3 libgcrypt Not affected
SUSE Linux Enterprise SDK 11 SP4 libgcrypt Not affected
SUSE Linux Enterprise SDK 12 SP2 libgcrypt Not affected
SUSE Linux Enterprise SDK 12 SP3 libgcrypt Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS libgcrypt Not affected
SUSE Linux Enterprise Server 11 SP4 libgcrypt Not affected
SUSE Linux Enterprise Server 12 GA LTSS libgcrypt Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS libgcrypt Not affected
SUSE Linux Enterprise Server 12 SP2 libgcrypt Not affected
SUSE Linux Enterprise Server 12 SP3 libgcrypt Not affected