Upstream information

CVE-2016-9941 at MITRE

Description

Heap-based buffer overflow in rfbproto.c in LibVNCClient in LibVNCServer before 0.9.11 allows remote servers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted FramebufferUpdate message containing a subrectangle outside of the client drawing area.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.8
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1017711 [NEW], 1019274 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • tigervnc >= 1.4.3-19.1
  • xorg-x11-Xvnc >= 1.4.3-19.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-263
SUSE Linux Enterprise Desktop 12 SP2
  • libXvnc1 >= 1.6.0-16.4
  • tigervnc >= 1.6.0-16.4
  • xorg-x11-Xvnc >= 1.6.0-16.4
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-335
SUSE Linux Enterprise Server 11 SP4
  • LibVNCServer >= 0.9.1-159.1
Patchnames:
slessp4-LibVNCServer-12932
SUSE Linux Enterprise Server 12 SP1
  • tigervnc >= 1.4.3-19.1
  • xorg-x11-Xvnc >= 1.4.3-19.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-263
SUSE Linux Enterprise Server 12 SP2
  • LibVNCServer >= 0.9.9-17.5.1
  • libXvnc1 >= 1.6.0-16.4
  • libvncclient0 >= 0.9.9-17.5.1
  • libvncserver0 >= 0.9.9-17.5.1
  • tigervnc >= 1.6.0-16.4
  • xorg-x11-Xvnc >= 1.6.0-16.4
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-335
SUSE-SLE-SERVER-12-SP2-2018-554
SUSE Linux Enterprise Server 12 SP3
  • LibVNCServer >= 0.9.9-17.5.1
  • libvncclient0 >= 0.9.9-17.5.1
  • libvncserver0 >= 0.9.9-17.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-554
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • LibVNCServer >= 0.9.9-17.5.1
  • libXvnc1 >= 1.6.0-16.4
  • libvncclient0 >= 0.9.9-17.5.1
  • libvncserver0 >= 0.9.9-17.5.1
  • tigervnc >= 1.6.0-16.4
  • xorg-x11-Xvnc >= 1.6.0-16.4
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-335
SUSE-SLE-RPI-12-SP2-2018-554
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • LibVNCServer >= 0.9.1-159.1
Patchnames:
slessp4-LibVNCServer-12932
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • tigervnc >= 1.4.3-19.1
  • xorg-x11-Xvnc >= 1.4.3-19.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-263
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • LibVNCServer >= 0.9.9-17.5.1
  • libXvnc1 >= 1.6.0-16.4
  • libvncclient0 >= 0.9.9-17.5.1
  • libvncserver0 >= 0.9.9-17.5.1
  • tigervnc >= 1.6.0-16.4
  • xorg-x11-Xvnc >= 1.6.0-16.4
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-335
SUSE-SLE-SERVER-12-SP2-2018-554
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • LibVNCServer >= 0.9.9-17.5.1
  • libvncclient0 >= 0.9.9-17.5.1
  • libvncserver0 >= 0.9.9-17.5.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-554
SUSE Linux Enterprise Software Development Kit 11 SP4
  • LibVNCServer >= 0.9.1-159.1
  • LibVNCServer-devel >= 0.9.1-159.1
Patchnames:
sdksp4-LibVNCServer-12932
SUSE Linux Enterprise Software Development Kit 12 SP2
  • LibVNCServer >= 0.9.9-17.5.1
  • LibVNCServer-devel >= 0.9.9-17.5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-554
SUSE Linux Enterprise Software Development Kit 12 SP3
  • LibVNCServer >= 0.9.9-17.5.1
  • LibVNCServer-devel >= 0.9.9-17.5.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-554
openSUSE Leap 42.3
  • LibVNCServer >= 0.9.9-16.3.1
  • LibVNCServer-debugsource >= 0.9.9-16.3.1
  • LibVNCServer-devel >= 0.9.9-16.3.1
  • libvncclient0 >= 0.9.9-16.3.1
  • libvncclient0-debuginfo >= 0.9.9-16.3.1
  • libvncserver0 >= 0.9.9-16.3.1
  • libvncserver0-debuginfo >= 0.9.9-16.3.1
  • linuxvnc >= 0.9.9-16.3.1
  • linuxvnc-debuginfo >= 0.9.9-16.3.1
Patchnames:
openSUSE-2018-326


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP4 LibVNCServer Released
SUSE Linux Enterprise SDK 12 SP1 LibVNCServer In progress
SUSE Linux Enterprise SDK 12 SP2 LibVNCServer Released
SUSE Linux Enterprise SDK 12 SP3 LibVNCServer Released
SUSE Linux Enterprise Server 11 SP4 LibVNCServer Released
SUSE Linux Enterprise Server 11 SP4 tightvnc Not affected
SUSE Linux Enterprise Server 12 SP1 LibVNCServer In progress
SUSE Linux Enterprise Server 12 SP2 LibVNCServer Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI LibVNCServer Released
SUSE Linux Enterprise Server 12 SP3 LibVNCServer Released