Upstream information

CVE-2016-9830 at MITRE

Description

The MagickRealloc function in memory.c in Graphicsmagick 1.3.25 allows remote attackers to cause a denial of service (crash) via large dimensions in a jpeg image.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 7.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1013640 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • GraphicsMagick >= 1.2.5-4.59.1
  • libGraphicsMagick2 >= 1.2.5-4.59.1
  • perl-GraphicsMagick >= 1.2.5-4.59.1
Patchnames:
sdksp4-GraphicsMagick-12958
SUSE Studio Onsite 1.3
  • GraphicsMagick >= 1.2.5-4.59.1
  • libGraphicsMagick2 >= 1.2.5-4.59.1
Patchnames:
slestso13-GraphicsMagick-12958
openSUSE Leap 42.1
  • GraphicsMagick >= 1.3.21-23.1
  • GraphicsMagick-debuginfo >= 1.3.21-23.1
  • GraphicsMagick-debugsource >= 1.3.21-23.1
  • GraphicsMagick-devel >= 1.3.21-23.1
  • libGraphicsMagick++-Q16-11 >= 1.3.21-23.1
  • libGraphicsMagick++-Q16-11-debuginfo >= 1.3.21-23.1
  • libGraphicsMagick++-devel >= 1.3.21-23.1
  • libGraphicsMagick-Q16-3 >= 1.3.21-23.1
  • libGraphicsMagick-Q16-3-debuginfo >= 1.3.21-23.1
  • libGraphicsMagick3-config >= 1.3.21-23.1
  • libGraphicsMagickWand-Q16-2 >= 1.3.21-23.1
  • libGraphicsMagickWand-Q16-2-debuginfo >= 1.3.21-23.1
  • perl-GraphicsMagick >= 1.3.21-23.1
  • perl-GraphicsMagick-debuginfo >= 1.3.21-23.1
Patchnames:
openSUSE-2016-1511
openSUSE Leap 42.2
  • GraphicsMagick >= 1.3.25-6.1
  • GraphicsMagick-debuginfo >= 1.3.25-6.1
  • GraphicsMagick-debugsource >= 1.3.25-6.1
  • GraphicsMagick-devel >= 1.3.25-6.1
  • libGraphicsMagick++-Q16-11 >= 1.3.21-23.1
  • libGraphicsMagick++-Q16-11-debuginfo >= 1.3.21-23.1
  • libGraphicsMagick++-Q16-12 >= 1.3.25-6.1
  • libGraphicsMagick++-Q16-12-debuginfo >= 1.3.25-6.1
  • libGraphicsMagick++-devel >= 1.3.25-6.1
  • libGraphicsMagick-Q16-3 >= 1.3.25-6.1
  • libGraphicsMagick-Q16-3-debuginfo >= 1.3.25-6.1
  • libGraphicsMagick3-config >= 1.3.25-6.1
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-6.1
  • libGraphicsMagickWand-Q16-2-debuginfo >= 1.3.25-6.1
  • perl-GraphicsMagick >= 1.3.25-6.1
  • perl-GraphicsMagick-debuginfo >= 1.3.25-6.1
Patchnames:
openSUSE-2016-1511
openSUSE Leap 42.3
  • GraphicsMagick-devel >= 1.3.25-15.2
  • libGraphicsMagick-Q16-3 >= 1.3.25-15.2
  • libGraphicsMagick3-config >= 1.3.25-15.2
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-15.2
Patchnames:
openSUSE Leap 42.3 GA GraphicsMagick-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP4 GraphicsMagick Released
SUSE Studio Onsite 1.3 GraphicsMagick Released