Upstream information

CVE-2016-9577 at MITRE

Description

A vulnerability was discovered in SPICE before 0.13.90 in the server's protocol handling. An authenticated attacker could send crafted messages to the SPICE server causing a heap overflow leading to a crash or possible code execution.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.5 10
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network Network
Access Complexity Low Low
Authentication Single None
Confidentiality Impact Partial Complete
Integrity Impact Partial Complete
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1023078 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libspice-server1 >= 0.12.5-7.1
  • spice >= 0.12.5-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-198
SUSE Linux Enterprise Desktop 12 SP2
  • libspice-server1 >= 0.12.7-8.1
  • spice >= 0.12.7-8.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-200
SUSE Linux Enterprise Desktop 12 SP3
  • libspice-server1 >= 0.12.8-1.17
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libspice-server1
SUSE Linux Enterprise Module for Server Applications 15
  • libspice-server-devel >= 0.14.0-2.32
  • libspice-server1 >= 0.14.0-2.32
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libspice-server-devel
SUSE Linux Enterprise Server 11 SP4
  • libspice-server1 >= 0.12.4-8.1
  • spice >= 0.12.4-8.1
Patchnames:
slessp4-spice-12970
SUSE Linux Enterprise Server 12 SP1
  • libspice-server1 >= 0.12.5-7.1
  • spice >= 0.12.5-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-198
SUSE Linux Enterprise Server 12 SP2
  • libspice-server1 >= 0.12.7-8.1
  • spice >= 0.12.7-8.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-200
SUSE Linux Enterprise Server 12 SP3
  • libspice-server1 >= 0.12.8-1.17
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libspice-server1
SUSE Linux Enterprise Server 12-LTSS
  • libspice-server1 >= 0.12.4-8.12.1
  • spice >= 0.12.4-8.12.1
Patchnames:
SUSE-SLE-SERVER-12-2017-199
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libspice-server1 >= 0.12.4-8.1
  • spice >= 0.12.4-8.1
Patchnames:
slessp4-spice-12970
SUSE Linux Enterprise Server for SAP Applications 12
  • libspice-server1 >= 0.12.4-8.12.1
  • spice >= 0.12.4-8.12.1
Patchnames:
SUSE-SLE-SAP-12-2017-199
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libspice-server1 >= 0.12.5-7.1
  • spice >= 0.12.5-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-198
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libspice-server1 >= 0.12.7-8.1
  • spice >= 0.12.7-8.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-200
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libspice-server1 >= 0.12.4-8.12.1
  • spice >= 0.12.4-8.12.1
Patchnames:
SUSE-SLE-SERVER-12-2017-199
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libspice-server-devel >= 0.12.4-8.1
  • spice >= 0.12.4-8.1
Patchnames:
sdksp4-spice-12970
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libspice-server-devel >= 0.12.5-7.1
  • spice >= 0.12.5-7.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-198
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libspice-server-devel >= 0.12.7-8.1
  • spice >= 0.12.7-8.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-200
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libspice-server-devel >= 0.12.8-1.17
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libspice-server-devel
openSUSE Leap 15.0
  • libspice-server1 >= 0.14.0-lp150.2.4
Patchnames:
openSUSE Leap 15.0 GA libspice-server1
openSUSE Leap 42.1
  • libspice-server-devel >= 0.12.5-11.1
  • libspice-server1 >= 0.12.5-11.1
  • libspice-server1-debuginfo >= 0.12.5-11.1
  • spice >= 0.12.5-11.1
  • spice-client >= 0.12.5-11.1
  • spice-client-debuginfo >= 0.12.5-11.1
  • spice-debugsource >= 0.12.5-11.1
Patchnames:
openSUSE-2017-227
openSUSE Leap 42.2
  • libspice-server-devel >= 0.12.7-3.1
  • libspice-server1 >= 0.12.7-3.1
  • libspice-server1-debuginfo >= 0.12.7-3.1
  • spice >= 0.12.7-3.1
  • spice-client >= 0.12.7-3.1
  • spice-debugsource >= 0.12.7-3.1
Patchnames:
openSUSE-2017-228
openSUSE Leap 42.3
  • libspice-server1 >= 0.12.8-1.4
Patchnames:
openSUSE Leap 42.3 GA libspice-server1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 spice Released
SUSE Linux Enterprise Desktop 12 SP2 spice Released
SUSE Linux Enterprise SDK 11 SP4 spice Released
SUSE Linux Enterprise SDK 12 SP1 spice Released
SUSE Linux Enterprise SDK 12 SP2 spice Released
SUSE Linux Enterprise Server 11 SP4 spice Released
SUSE Linux Enterprise Server 12 GA LTSS spice Released
SUSE Linux Enterprise Server 12 SP1 spice Released
SUSE Linux Enterprise Server 12 SP2 spice Released