Upstream information

CVE-2016-9447 at MITRE

Description

The ROM mappings in the NSF decoder in gstreamer 0.10.x allow remote attackers to cause a denial of service (out-of-bounds read or write) and possibly execute arbitrary code via a crafted NSF music file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 4.4
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1010514 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gstreamer-0_10-plugins-bad >= 0.10.23-19.3.4
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-19.3.4
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-19.3.4
  • libgstbasecamerabinsrc-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstbasevideo-0_10-23 >= 0.10.23-19.3.4
  • libgstbasevideo-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstcodecparsers-0_10-23 >= 0.10.23-19.3.4
  • libgstphotography-0_10-23 >= 0.10.23-19.3.4
  • libgstphotography-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstsignalprocessor-0_10-23 >= 0.10.23-19.3.4
  • libgstsignalprocessor-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstvdp-0_10-23 >= 0.10.23-19.3.4
  • libgstvdp-0_10-23-32bit >= 0.10.23-19.3.4
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-14
SUSE Linux Enterprise Desktop 12 SP2
  • gstreamer-0_10-plugins-bad >= 0.10.23-22.5
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-22.5
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-22.5
  • libgstbasecamerabinsrc-0_10-23-32bit >= 0.10.23-22.5
  • libgstbasevideo-0_10-23 >= 0.10.23-22.5
  • libgstbasevideo-0_10-23-32bit >= 0.10.23-22.5
  • libgstcodecparsers-0_10-23 >= 0.10.23-22.5
  • libgstphotography-0_10-23 >= 0.10.23-22.5
  • libgstphotography-0_10-23-32bit >= 0.10.23-22.5
  • libgstsignalprocessor-0_10-23 >= 0.10.23-22.5
  • libgstsignalprocessor-0_10-23-32bit >= 0.10.23-22.5
  • libgstvdp-0_10-23 >= 0.10.23-22.5
  • libgstvdp-0_10-23-32bit >= 0.10.23-22.5
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-13
SUSE Linux Enterprise Desktop 12 SP3
  • gstreamer-0_10-plugins-bad >= 0.10.23-25.1
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-25.1
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-25.1
  • libgstbasecamerabinsrc-0_10-23-32bit >= 0.10.23-25.1
  • libgstbasevideo-0_10-23 >= 0.10.23-25.1
  • libgstbasevideo-0_10-23-32bit >= 0.10.23-25.1
  • libgstcodecparsers-0_10-23 >= 0.10.23-25.1
  • libgstphotography-0_10-23 >= 0.10.23-25.1
  • libgstphotography-0_10-23-32bit >= 0.10.23-25.1
  • libgstsignalprocessor-0_10-23 >= 0.10.23-25.1
  • libgstsignalprocessor-0_10-23-32bit >= 0.10.23-25.1
  • libgstvdp-0_10-23 >= 0.10.23-25.1
  • libgstvdp-0_10-23-32bit >= 0.10.23-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gstreamer-0_10-plugins-bad
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gstreamer-0_10-plugins-bad >= 0.10.23-19.3.4
  • gstreamer-0_10-plugins-bad-devel >= 0.10.23-19.3.4
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-19.3.4
  • libgstbasevideo-0_10-23 >= 0.10.23-19.3.4
  • libgstcodecparsers-0_10-23 >= 0.10.23-19.3.4
  • libgstphotography-0_10-23 >= 0.10.23-19.3.4
  • libgstsignalprocessor-0_10-23 >= 0.10.23-19.3.4
  • libgstvdp-0_10-23 >= 0.10.23-19.3.4
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-14
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gstreamer-0_10-plugins-bad >= 0.10.23-22.5
  • gstreamer-0_10-plugins-bad-devel >= 0.10.23-22.5
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-22.5
  • libgstbasevideo-0_10-23 >= 0.10.23-22.5
  • libgstcodecparsers-0_10-23 >= 0.10.23-22.5
  • libgstphotography-0_10-23 >= 0.10.23-22.5
  • libgstsignalprocessor-0_10-23 >= 0.10.23-22.5
  • libgstvdp-0_10-23 >= 0.10.23-22.5
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-13
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gstreamer-0_10-plugins-bad-devel >= 0.10.23-25.1
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-25.1
  • libgstbasevideo-0_10-23 >= 0.10.23-25.1
  • libgstcodecparsers-0_10-23 >= 0.10.23-25.1
  • libgstphotography-0_10-23 >= 0.10.23-25.1
  • libgstsignalprocessor-0_10-23 >= 0.10.23-25.1
  • libgstvdp-0_10-23 >= 0.10.23-25.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gstreamer-0_10-plugins-bad-devel
SUSE Linux Enterprise Workstation Extension 12 SP1
  • gstreamer-0_10-plugins-bad >= 0.10.23-19.3.4
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-19.3.4
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-19.3.4
  • libgstbasecamerabinsrc-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstbasevideo-0_10-23 >= 0.10.23-19.3.4
  • libgstbasevideo-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstcodecparsers-0_10-23 >= 0.10.23-19.3.4
  • libgstphotography-0_10-23 >= 0.10.23-19.3.4
  • libgstphotography-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstsignalprocessor-0_10-23 >= 0.10.23-19.3.4
  • libgstsignalprocessor-0_10-23-32bit >= 0.10.23-19.3.4
  • libgstvdp-0_10-23 >= 0.10.23-19.3.4
  • libgstvdp-0_10-23-32bit >= 0.10.23-19.3.4
Patchnames:
SUSE-SLE-WE-12-SP1-2017-14
SUSE Linux Enterprise Workstation Extension 12 SP2
  • gstreamer-0_10-plugins-bad >= 0.10.23-22.5
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-22.5
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-22.5
  • libgstbasecamerabinsrc-0_10-23-32bit >= 0.10.23-22.5
  • libgstbasevideo-0_10-23 >= 0.10.23-22.5
  • libgstbasevideo-0_10-23-32bit >= 0.10.23-22.5
  • libgstcodecparsers-0_10-23 >= 0.10.23-22.5
  • libgstphotography-0_10-23 >= 0.10.23-22.5
  • libgstphotography-0_10-23-32bit >= 0.10.23-22.5
  • libgstsignalprocessor-0_10-23 >= 0.10.23-22.5
  • libgstsignalprocessor-0_10-23-32bit >= 0.10.23-22.5
  • libgstvdp-0_10-23 >= 0.10.23-22.5
  • libgstvdp-0_10-23-32bit >= 0.10.23-22.5
Patchnames:
SUSE-SLE-WE-12-SP2-2017-13
SUSE Linux Enterprise Workstation Extension 12 SP3
  • gstreamer-0_10-plugins-bad >= 0.10.23-25.1
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-25.1
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-25.1
  • libgstbasecamerabinsrc-0_10-23-32bit >= 0.10.23-25.1
  • libgstbasevideo-0_10-23 >= 0.10.23-25.1
  • libgstbasevideo-0_10-23-32bit >= 0.10.23-25.1
  • libgstcodecparsers-0_10-23 >= 0.10.23-25.1
  • libgstphotography-0_10-23 >= 0.10.23-25.1
  • libgstphotography-0_10-23-32bit >= 0.10.23-25.1
  • libgstsignalprocessor-0_10-23 >= 0.10.23-25.1
  • libgstsignalprocessor-0_10-23-32bit >= 0.10.23-25.1
  • libgstvdp-0_10-23 >= 0.10.23-25.1
  • libgstvdp-0_10-23-32bit >= 0.10.23-25.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA gstreamer-0_10-plugins-bad
openSUSE Leap 42.2
  • gstreamer-0_10-plugins-bad >= 0.10.23-24.1
  • gstreamer-0_10-plugins-bad-32bit >= 0.10.23-24.1
  • gstreamer-0_10-plugins-bad-debuginfo >= 0.10.23-24.1
  • gstreamer-0_10-plugins-bad-debuginfo-32bit >= 0.10.23-24.1
  • gstreamer-0_10-plugins-bad-debugsource >= 0.10.23-24.1
  • gstreamer-0_10-plugins-bad-devel >= 0.10.23-24.1
  • gstreamer-0_10-plugins-bad-doc >= 0.10.23-24.1
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-24.1
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-24.1
  • libgstbasecamerabinsrc-0_10-23-32bit >= 0.10.23-24.1
  • libgstbasecamerabinsrc-0_10-23-debuginfo >= 0.10.23-24.1
  • libgstbasecamerabinsrc-0_10-23-debuginfo-32bit >= 0.10.23-24.1
  • libgstbasevideo-0_10-23 >= 0.10.23-24.1
  • libgstbasevideo-0_10-23-32bit >= 0.10.23-24.1
  • libgstbasevideo-0_10-23-debuginfo >= 0.10.23-24.1
  • libgstbasevideo-0_10-23-debuginfo-32bit >= 0.10.23-24.1
  • libgstcodecparsers-0_10-23 >= 0.10.23-24.1
  • libgstcodecparsers-0_10-23-32bit >= 0.10.23-24.1
  • libgstcodecparsers-0_10-23-debuginfo >= 0.10.23-24.1
  • libgstcodecparsers-0_10-23-debuginfo-32bit >= 0.10.23-24.1
  • libgstphotography-0_10-23 >= 0.10.23-24.1
  • libgstphotography-0_10-23-32bit >= 0.10.23-24.1
  • libgstphotography-0_10-23-debuginfo >= 0.10.23-24.1
  • libgstphotography-0_10-23-debuginfo-32bit >= 0.10.23-24.1
  • libgstsignalprocessor-0_10-23 >= 0.10.23-24.1
  • libgstsignalprocessor-0_10-23-32bit >= 0.10.23-24.1
  • libgstsignalprocessor-0_10-23-debuginfo >= 0.10.23-24.1
  • libgstsignalprocessor-0_10-23-debuginfo-32bit >= 0.10.23-24.1
  • libgstvdp-0_10-23 >= 0.10.23-24.1
  • libgstvdp-0_10-23-32bit >= 0.10.23-24.1
  • libgstvdp-0_10-23-debuginfo >= 0.10.23-24.1
  • libgstvdp-0_10-23-debuginfo-32bit >= 0.10.23-24.1
Patchnames:
openSUSE-2017-64
openSUSE Leap 42.3
  • gstreamer-0_10-plugins-bad >= 0.10.23-30.23
  • gstreamer-0_10-plugins-bad-lang >= 0.10.23-30.23
  • libgstbasecamerabinsrc-0_10-23 >= 0.10.23-30.23
  • libgstbasevideo-0_10-23 >= 0.10.23-30.23
  • libgstcodecparsers-0_10-23 >= 0.10.23-30.23
  • libgstphotography-0_10-23 >= 0.10.23-30.23
  • libgstsignalprocessor-0_10-23 >= 0.10.23-30.23
  • libgstvdp-0_10-23 >= 0.10.23-30.23
Patchnames:
openSUSE Leap 42.3 GA gstreamer-0_10-plugins-bad


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 gstreamer-0_10-plugins-bad Released
SUSE Linux Enterprise Desktop 12 SP2 gstreamer-0_10-plugins-bad Released
SUSE Linux Enterprise SDK 12 SP1 gstreamer-0_10-plugins-bad Released
SUSE Linux Enterprise SDK 12 SP2 gstreamer-0_10-plugins-bad Released
SUSE Linux Enterprise Workstation Extension 12 SP1 gstreamer-0_10-plugins-bad Released
SUSE Linux Enterprise Workstation Extension 12 SP2 gstreamer-0_10-plugins-bad Released