Upstream information

CVE-2016-9427 at MITRE

Description

Integer overflow vulnerability in bdwgc before 2016-09-27 allows attackers to cause client of bdwgc denial of service (heap buffer overflow crash) and possibly execute arbitrary code via huge allocation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 4.3
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1011276 [RESOLVED / FIXED], 1011293 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gc >= 7.2d-5.1
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1775
SUSE Linux Enterprise Desktop 12 SP2
  • gc >= 7.2d-5.1
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1775
SUSE Linux Enterprise Desktop 12 SP3
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libgc1
SUSE Linux Enterprise Server 12 SP1
  • gc >= 7.2d-5.1
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1775
SUSE Linux Enterprise Server 12 SP2
  • gc >= 7.2d-5.1
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1775
SUSE Linux Enterprise Server 12 SP3
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libgc1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gc >= 7.2d-5.1
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1775
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gc >= 7.2d-5.1
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1775
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gc >= 7.2d-5.1
  • libgc1 >= 7.2d-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1775
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gc >= 7.2d-5.1
  • gc-devel >= 7.2d-5.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1775
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gc >= 7.2d-5.1
  • gc-devel >= 7.2d-5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1775
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gc-devel >= 7.2d-5.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gc-devel
openSUSE Leap 42.1
  • gc >= 7.2d-7.1
  • gc-debugsource >= 7.2d-7.1
  • gc-devel >= 7.2d-7.1
  • libgc1 >= 7.2d-7.1
  • libgc1-debuginfo >= 7.2d-7.1
Patchnames:
openSUSE-2016-1479
openSUSE Leap 42.2
  • gc >= 7.2d-8.1
  • gc-debugsource >= 7.2d-8.1
  • gc-devel >= 7.2d-8.1
  • libgc1 >= 7.2d-8.1
  • libgc1-debuginfo >= 7.2d-8.1
Patchnames:
openSUSE-2016-1479
openSUSE Leap 42.3
  • libgc1 >= 7.2d-11.3
Patchnames:
openSUSE Leap 42.3 GA libgc1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 gc Released
SUSE Linux Enterprise Desktop 12 SP2 gc Released
SUSE Linux Enterprise SDK 12 SP1 gc Released
SUSE Linux Enterprise SDK 12 SP2 gc Released
SUSE Linux Enterprise Server 12 SP1 gc Released
SUSE Linux Enterprise Server 12 SP2 gc Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI gc Released