Upstream information

CVE-2016-9015 at MITRE

Description

Versions 1.17 and 1.18 of the Python urllib3 library suffer from a vulnerability that can cause them, in certain configurations, to not correctly validate TLS certificates. This places users of the library with those configurations at risk of man-in-the-middle and information leakage attacks. This vulnerability affects users using versions 1.17 and 1.18 of the urllib3 library, who are using the optional PyOpenSSL support for TLS instead of the regular standard library TLS backend, and who are using OpenSSL 1.1.0 via PyOpenSSL. This is an extremely uncommon configuration, so the security impact of this vulnerability is low.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.6 2.6
Vector AV:N/AC:H/Au:N/C:P/I:N/A:N AV:N/AC:H/Au:N/C:P/I:N/A:N
Access Vector Network Network
Access Complexity High High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 3.7
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1023502 [NEW], 1024540 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • python2-urllib3 >= 1.22-4.26
  • python3-urllib3 >= 1.22-4.26
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA python2-urllib3
openSUSE Leap 15.0
  • python3-urllib3 >= 1.22-lp150.4.1
Patchnames:
openSUSE Leap 15.0 GA python3-urllib3
openSUSE Tumbleweed
  • python3-urllib3 >= 1.18.1-1.2
Patchnames:
openSUSE Tumbleweed GA python3-urllib3

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Module for Public Cloud 12
  • python-Babel >= 2.5.3-4.3.1
  • python-mock >= 2.0.0-3.3.1
  • python-pbr >= 3.1.1-3.3.1
  • python3-Babel >= 2.5.3-4.3.1
  • python3-mock >= 2.0.0-3.3.1
  • python3-pbr >= 3.1.1-3.3.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 python-urllib3 In progress
CaaS Platform 3.0 python-urllib3 In progress
OpenStack Cloud Magnum Orchestration 7.0 python-urllib3 In progress
SUSE Linux Enterprise Module for Public Cloud 12 python-urllib3 In progress
SUSE Manager Server 3.1 python-urllib3 In progress
SUSE Manager Server 3.2 python-urllib3 In progress
SUSE Openstack Cloud 6 python-urllib3 Not affected
SUSE Storage 4 python-urllib3 In progress
SUSE Storage 5 python-urllib3 In progress