Upstream information

CVE-2016-8618 at MITRE

Description

The libcurl API function called `curl_maprintf()` before version 7.51.0 can be tricked into doing a double-free due to an unsafe `size_t` multiplication, on systems using 32 bit `size_t` variables.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  SUSE
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1005637 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • curl >= 7.37.0-31.1
  • libcurl4 >= 7.37.0-31.1
  • libcurl4-32bit >= 7.37.0-31.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1591
SUSE Linux Enterprise Desktop 12 SP3
  • curl >= 7.37.0-36.1
  • libcurl4 >= 7.37.0-36.1
  • libcurl4-32bit >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA curl
SUSE Linux Enterprise Module for Basesystem 15
  • curl >= 7.60.0-1.1
  • libcurl-devel >= 7.60.0-1.1
  • libcurl4 >= 7.60.0-1.1
  • libcurl4-32bit >= 7.60.0-1.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA curl
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE Linux Enterprise Server 11 SP4
  • curl >= 7.19.7-1.64.1
  • libcurl4 >= 7.19.7-1.64.1
  • libcurl4-32bit >= 7.19.7-1.64.1
  • libcurl4-x86 >= 7.19.7-1.64.1
Patchnames:
slessp4-curl-12831
SUSE Linux Enterprise Server 11-SECURITY
  • curl-openssl1 >= 7.19.7-1.64.1
  • libcurl4-openssl1 >= 7.19.7-1.64.1
  • libcurl4-openssl1-32bit >= 7.19.7-1.64.1
  • libcurl4-openssl1-x86 >= 7.19.7-1.64.1
Patchnames:
secsp3-curl-12831
SUSE Linux Enterprise Server 12 SP1
  • curl >= 7.37.0-31.1
  • libcurl4 >= 7.37.0-31.1
  • libcurl4-32bit >= 7.37.0-31.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1591
SUSE Linux Enterprise Server 12 SP3
  • curl >= 7.37.0-36.1
  • libcurl4 >= 7.37.0-36.1
  • libcurl4-32bit >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA curl
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • curl >= 7.19.7-1.64.1
  • libcurl4 >= 7.19.7-1.64.1
  • libcurl4-32bit >= 7.19.7-1.64.1
  • libcurl4-x86 >= 7.19.7-1.64.1
Patchnames:
slessp4-curl-12831
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • curl-openssl1 >= 7.19.7-1.64.1
  • libcurl4-openssl1 >= 7.19.7-1.64.1
  • libcurl4-openssl1-32bit >= 7.19.7-1.64.1
  • libcurl4-openssl1-x86 >= 7.19.7-1.64.1
Patchnames:
secsp3-curl-12831
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • curl >= 7.37.0-31.1
  • libcurl4 >= 7.37.0-31.1
  • libcurl4-32bit >= 7.37.0-31.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1591
SUSE Linux Enterprise Software Development Kit 11 SP4
  • curl >= 7.19.7-1.64.1
  • libcurl-devel >= 7.19.7-1.64.1
Patchnames:
sdksp4-curl-12831
SUSE Linux Enterprise Software Development Kit 12 SP1
  • curl >= 7.37.0-31.1
  • libcurl-devel >= 7.37.0-31.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1591
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcurl-devel >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libcurl-devel
SUSE Studio Onsite 1.3
  • curl >= 7.19.7-1.20.47.2
  • libcurl-devel >= 7.19.7-1.20.47.2
Patchnames:
slestso13-curl-12827
openSUSE Leap 15.0
  • curl >= 7.59.0-lp150.1.1
  • libcurl4 >= 7.59.0-lp150.1.1
  • libcurl4-32bit >= 7.59.0-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA curl
openSUSE Leap 42.1
  • curl >= 7.37.0-16.1
  • curl-debuginfo >= 7.37.0-16.1
  • curl-debugsource >= 7.37.0-16.1
  • libcurl-devel >= 7.37.0-16.1
  • libcurl-devel-32bit >= 7.37.0-16.1
  • libcurl4 >= 7.37.0-16.1
  • libcurl4-32bit >= 7.37.0-16.1
  • libcurl4-debuginfo >= 7.37.0-16.1
  • libcurl4-debuginfo-32bit >= 7.37.0-16.1
Patchnames:
openSUSE-2016-1280
openSUSE Leap 42.2
  • curl >= 7.37.0-15.1
  • libcurl-devel >= 7.37.0-15.1
  • libcurl4 >= 7.37.0-15.1
Patchnames:
openSUSE Leap 42.2 GA curl
openSUSE Leap 42.3
  • curl >= 7.37.0-18.5
  • libcurl-devel >= 7.37.0-18.5
  • libcurl4 >= 7.37.0-18.5
Patchnames:
openSUSE Leap 42.3 GA curl
openSUSE Tumbleweed
  • curl >= 7.51.0-1.1
  • libcurl-devel >= 7.51.0-1.1
  • libcurl-devel-32bit >= 7.51.0-1.1
  • libcurl4 >= 7.51.0-1.1
  • libcurl4-32bit >= 7.51.0-1.1
Patchnames:
openSUSE Tumbleweed GA curl


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 curl Released
SUSE Linux Enterprise Desktop 12 SP2 curl Unsupported
SUSE Linux Enterprise SDK 11 SP4 curl Released
SUSE Linux Enterprise SDK 12 GA curl Ignore
SUSE Linux Enterprise SDK 12 SP1 curl Released
SUSE Linux Enterprise SDK 12 SP2 curl Unsupported
SUSE Linux Enterprise Server 11 SP4 curl Released
SUSE Linux Enterprise Server 12 SP1 curl Released
SUSE Linux Enterprise Server 12 SP2 curl Unsupported
SUSE Studio Onsite 1.3 curl Released