Upstream information

CVE-2016-8602 at MITRE

Description

The .sethalftone5 function in psi/zht2.c in Ghostscript before 9.21 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted Postscript document that calls .sethalftone5 with an empty operand stack.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1001951 [RESOLVED / FIXED], 1004237 [RESOLVED / FIXED], 1036453 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP1
  • ghostscript-mini >= 9.15-14.1
  • ghostscript-mini-devel >= 9.15-14.1
Patchnames:
SUSE-SLE-BSK-12-SP1-2016-1557
SUSE Linux Enterprise Desktop 12 SP1
  • ghostscript >= 9.15-14.1
  • ghostscript-x11 >= 9.15-14.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1557
SUSE Linux Enterprise Desktop 12 SP3
  • ghostscript >= 9.15-22.1
  • ghostscript-x11 >= 9.15-22.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA ghostscript
SUSE Linux Enterprise Module for Basesystem 15
  • ghostscript >= 9.23-1.16
  • ghostscript-devel >= 9.23-1.16
  • ghostscript-x11 >= 9.23-1.16
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA ghostscript
SUSE Linux Enterprise Server 11 SP4
  • ghostscript-fonts-other >= 8.62-32.41.1
  • ghostscript-fonts-rus >= 8.62-32.41.1
  • ghostscript-fonts-std >= 8.62-32.41.1
  • ghostscript-library >= 8.62-32.41.1
  • ghostscript-omni >= 8.62-32.41.1
  • ghostscript-x11 >= 8.62-32.41.1
  • libgimpprint >= 4.2.7-32.41.1
Patchnames:
slessp4-ghostscript-12834
SUSE Linux Enterprise Server 12 SP1
  • ghostscript >= 9.15-14.1
  • ghostscript-x11 >= 9.15-14.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1557
SUSE Linux Enterprise Server 12 SP3
  • ghostscript >= 9.15-22.1
  • ghostscript-x11 >= 9.15-22.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ghostscript
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • ghostscript-fonts-other >= 8.62-32.41.1
  • ghostscript-fonts-rus >= 8.62-32.41.1
  • ghostscript-fonts-std >= 8.62-32.41.1
  • ghostscript-library >= 8.62-32.41.1
  • ghostscript-omni >= 8.62-32.41.1
  • ghostscript-x11 >= 8.62-32.41.1
  • libgimpprint >= 4.2.7-32.41.1
Patchnames:
slessp4-ghostscript-12834
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • ghostscript >= 9.15-14.1
  • ghostscript-x11 >= 9.15-14.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1557
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ghostscript-devel >= 8.62-32.41.1
  • ghostscript-ijs-devel >= 8.62-32.41.1
  • ghostscript-library >= 8.62-32.41.1
  • libgimpprint-devel >= 4.2.7-32.41.1
Patchnames:
sdksp4-ghostscript-12834
SUSE Linux Enterprise Software Development Kit 12 SP1
  • ghostscript >= 9.15-14.1
  • ghostscript-devel >= 9.15-14.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1557
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ghostscript-devel >= 9.15-22.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA ghostscript-devel
openSUSE Leap 15.0
  • ghostscript >= 9.23-lp150.1.1
  • ghostscript-x11 >= 9.23-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA ghostscript
openSUSE Leap 42.1
  • ghostscript >= 9.15-11.1
  • ghostscript-debuginfo >= 9.15-11.1
  • ghostscript-debugsource >= 9.15-11.1
  • ghostscript-devel >= 9.15-11.1
  • ghostscript-mini >= 9.15-11.1
  • ghostscript-mini-debuginfo >= 9.15-11.1
  • ghostscript-mini-debugsource >= 9.15-11.1
  • ghostscript-mini-devel >= 9.15-11.1
  • ghostscript-x11 >= 9.15-11.1
  • ghostscript-x11-debuginfo >= 9.15-11.1
Patchnames:
openSUSE-2016-1258
openSUSE Leap 42.2
  • ghostscript >= 9.15-10.1
  • ghostscript-devel >= 9.15-10.1
  • ghostscript-x11 >= 9.15-10.1
Patchnames:
openSUSE Leap 42.2 GA ghostscript
openSUSE Leap 42.3
  • ghostscript >= 9.15-13.14
  • ghostscript-devel >= 9.15-13.14
  • ghostscript-x11 >= 9.15-13.14
Patchnames:
openSUSE Leap 42.3 GA ghostscript
openSUSE Tumbleweed
  • ghostscript >= 9.20-2.1
  • ghostscript-devel >= 9.20-2.1
  • ghostscript-x11 >= 9.20-2.1
Patchnames:
openSUSE Tumbleweed GA ghostscript


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 ghostscript Released
SUSE Linux Enterprise SDK 11 SP4 ghostscript-library Released
SUSE Linux Enterprise SDK 12 GA ghostscript Affected
SUSE Linux Enterprise SDK 12 SP1 ghostscript Released
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Released
SUSE Linux Enterprise Server 12 SP1 ghostscript Released