Upstream information

CVE-2016-7995 at MITRE

Description

Memory leak in the ehci_process_itd function in hw/usb/hcd-ehci.c in QEMU (aka Quick Emulator) allows local guest OS administrators to cause a denial of service (memory consumption) via a large number of crafted buffer page select (PG) indexes.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:N/I:N/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6
Vector AV:L/AC:L/PR:H/UI:N/S:C/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required High
User Interaction None
Scope Changed
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entries: 1003612 [RESOLVED / FIXED], 1003870 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-kmp-default >= 4.5.5_02_k3.12.67_60.64.18-22.3.1
  • xen-libs >= 4.5.5_02-22.3.1
  • xen-libs-32bit >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1795
SUSE Linux Enterprise Desktop 12 SP2
  • qemu >= 2.6.2-31.2
  • qemu-block-curl >= 2.6.2-31.2
  • qemu-ipxe >= 1.0.0-31.2
  • qemu-kvm >= 2.6.2-31.2
  • qemu-seabios >= 1.9.1-31.2
  • qemu-sgabios >= 8-31.2
  • qemu-tools >= 2.6.2-31.2
  • qemu-vgabios >= 1.9.1-31.2
  • qemu-x86 >= 2.6.2-31.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1682
SUSE Linux Enterprise Desktop 12 SP3
  • qemu >= 2.9.0-5.10
  • qemu-block-curl >= 2.9.0-5.10
  • qemu-ipxe >= 1.0.0-5.10
  • qemu-kvm >= 2.9.0-5.10
  • qemu-seabios >= 1.10.2-5.10
  • qemu-sgabios >= 8-5.10
  • qemu-tools >= 2.9.0-5.10
  • qemu-vgabios >= 1.10.2-5.10
  • qemu-x86 >= 2.9.0-5.10
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA qemu
SUSE Linux Enterprise Module for Basesystem 15
  • qemu-tools >= 2.11.1-7.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA qemu-tools
SUSE Linux Enterprise Module for Server Applications 15
  • qemu >= 2.11.1-7.5
  • qemu-block-curl >= 2.11.1-7.5
  • qemu-block-iscsi >= 2.11.1-7.5
  • qemu-block-rbd >= 2.11.1-7.5
  • qemu-block-ssh >= 2.11.1-7.5
  • qemu-guest-agent >= 2.11.1-7.5
  • qemu-ipxe >= 1.0.0-7.5
  • qemu-kvm >= 2.11.1-7.5
  • qemu-lang >= 2.11.1-7.5
  • qemu-seabios >= 1.11.0-7.5
  • qemu-sgabios >= 8-7.5
  • qemu-vgabios >= 1.11.0-7.5
  • qemu-x86 >= 2.11.1-7.5
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA qemu
SUSE Linux Enterprise Server 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-doc-html >= 4.5.5_02-22.3.1
  • xen-kmp-default >= 4.5.5_02_k3.12.67_60.64.18-22.3.1
  • xen-libs >= 4.5.5_02-22.3.1
  • xen-libs-32bit >= 4.5.5_02-22.3.1
  • xen-tools >= 4.5.5_02-22.3.1
  • xen-tools-domU >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1795
SUSE Linux Enterprise Server 12 SP2
  • qemu >= 2.6.2-31.2
  • qemu-arm >= 2.6.2-31.2
  • qemu-block-curl >= 2.6.2-31.2
  • qemu-block-rbd >= 2.6.2-31.2
  • qemu-block-ssh >= 2.6.2-31.2
  • qemu-guest-agent >= 2.6.2-31.2
  • qemu-ipxe >= 1.0.0-31.2
  • qemu-kvm >= 2.6.2-31.2
  • qemu-lang >= 2.6.2-31.2
  • qemu-ppc >= 2.6.2-31.2
  • qemu-s390 >= 2.6.2-31.2
  • qemu-seabios >= 1.9.1-31.2
  • qemu-sgabios >= 8-31.2
  • qemu-tools >= 2.6.2-31.2
  • qemu-vgabios >= 1.9.1-31.2
  • qemu-x86 >= 2.6.2-31.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1682
SUSE Linux Enterprise Server 12 SP3
  • qemu >= 2.9.0-5.10
  • qemu-arm >= 2.9.0-5.10
  • qemu-block-curl >= 2.9.0-5.10
  • qemu-block-rbd >= 2.9.0-5.10
  • qemu-block-ssh >= 2.9.0-5.10
  • qemu-guest-agent >= 2.9.0-5.10
  • qemu-ipxe >= 1.0.0-5.10
  • qemu-kvm >= 2.9.0-5.10
  • qemu-lang >= 2.9.0-5.10
  • qemu-ppc >= 2.9.0-5.10
  • qemu-s390 >= 2.9.0-5.10
  • qemu-seabios >= 1.10.2-5.10
  • qemu-sgabios >= 8-5.10
  • qemu-tools >= 2.9.0-5.10
  • qemu-vgabios >= 1.10.2-5.10
  • qemu-x86 >= 2.9.0-5.10
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA qemu
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • qemu >= 2.6.2-31.2
  • qemu-arm >= 2.6.2-31.2
  • qemu-block-curl >= 2.6.2-31.2
  • qemu-block-rbd >= 2.6.2-31.2
  • qemu-block-ssh >= 2.6.2-31.2
  • qemu-guest-agent >= 2.6.2-31.2
  • qemu-ipxe >= 1.0.0-31.2
  • qemu-lang >= 2.6.2-31.2
  • qemu-tools >= 2.6.2-31.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1682
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-doc-html >= 4.5.5_02-22.3.1
  • xen-kmp-default >= 4.5.5_02_k3.12.67_60.64.18-22.3.1
  • xen-libs >= 4.5.5_02-22.3.1
  • xen-libs-32bit >= 4.5.5_02-22.3.1
  • xen-tools >= 4.5.5_02-22.3.1
  • xen-tools-domU >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1795
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • qemu >= 2.6.2-31.2
  • qemu-arm >= 2.6.2-31.2
  • qemu-block-curl >= 2.6.2-31.2
  • qemu-block-rbd >= 2.6.2-31.2
  • qemu-block-ssh >= 2.6.2-31.2
  • qemu-guest-agent >= 2.6.2-31.2
  • qemu-ipxe >= 1.0.0-31.2
  • qemu-kvm >= 2.6.2-31.2
  • qemu-lang >= 2.6.2-31.2
  • qemu-ppc >= 2.6.2-31.2
  • qemu-s390 >= 2.6.2-31.2
  • qemu-seabios >= 1.9.1-31.2
  • qemu-sgabios >= 8-31.2
  • qemu-tools >= 2.6.2-31.2
  • qemu-vgabios >= 1.9.1-31.2
  • qemu-x86 >= 2.6.2-31.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1682
SUSE Linux Enterprise Software Development Kit 12 SP1
  • xen >= 4.5.5_02-22.3.1
  • xen-devel >= 4.5.5_02-22.3.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1795
openSUSE Leap 15.0
  • qemu >= 2.11.1-lp150.6.7
  • qemu-block-curl >= 2.11.1-lp150.6.7
  • qemu-block-rbd >= 2.11.1-lp150.6.7
  • qemu-block-ssh >= 2.11.1-lp150.6.7
  • qemu-guest-agent >= 2.11.1-lp150.6.7
  • qemu-ipxe >= 1.0.0-lp150.6.7
  • qemu-ksm >= 2.11.1-lp150.6.7
  • qemu-seabios >= 1.11.0-lp150.6.7
  • qemu-sgabios >= 8-lp150.6.7
  • qemu-tools >= 2.11.1-lp150.6.7
  • qemu-vgabios >= 1.11.0-lp150.6.7
  • qemu-x86 >= 2.11.1-lp150.6.7
Patchnames:
openSUSE Leap 15.0 GA qemu
openSUSE Leap 42.1
  • xen >= 4.5.5_06-18.1
  • xen-debugsource >= 4.5.5_06-18.1
  • xen-devel >= 4.5.5_06-18.1
  • xen-doc-html >= 4.5.5_06-18.1
  • xen-kmp-default >= 4.5.5_06_k4.1.36_41-18.1
  • xen-kmp-default-debuginfo >= 4.5.5_06_k4.1.36_41-18.1
  • xen-libs >= 4.5.5_06-18.1
  • xen-libs-32bit >= 4.5.5_06-18.1
  • xen-libs-debuginfo >= 4.5.5_06-18.1
  • xen-libs-debuginfo-32bit >= 4.5.5_06-18.1
  • xen-tools >= 4.5.5_06-18.1
  • xen-tools-debuginfo >= 4.5.5_06-18.1
  • xen-tools-domU >= 4.5.5_06-18.1
  • xen-tools-domU-debuginfo >= 4.5.5_06-18.1
Patchnames:
openSUSE-2017-4
openSUSE Leap 42.2
  • qemu >= 2.6.2-23.1
  • qemu-arm >= 2.6.2-23.1
  • qemu-arm-debuginfo >= 2.6.2-23.1
  • qemu-block-curl >= 2.6.2-23.1
  • qemu-block-curl-debuginfo >= 2.6.2-23.1
  • qemu-block-dmg >= 2.6.2-23.1
  • qemu-block-dmg-debuginfo >= 2.6.2-23.1
  • qemu-block-iscsi >= 2.6.2-23.1
  • qemu-block-iscsi-debuginfo >= 2.6.2-23.1
  • qemu-block-rbd >= 2.6.2-23.1
  • qemu-block-rbd-debuginfo >= 2.6.2-23.1
  • qemu-block-ssh >= 2.6.2-23.1
  • qemu-block-ssh-debuginfo >= 2.6.2-23.1
  • qemu-debugsource >= 2.6.2-23.1
  • qemu-extra >= 2.6.2-23.1
  • qemu-extra-debuginfo >= 2.6.2-23.1
  • qemu-guest-agent >= 2.6.2-23.1
  • qemu-guest-agent-debuginfo >= 2.6.2-23.1
  • qemu-ipxe >= 1.0.0-23.1
  • qemu-kvm >= 2.6.2-23.1
  • qemu-lang >= 2.6.2-23.1
  • qemu-linux-user >= 2.6.2-23.1
  • qemu-linux-user-debuginfo >= 2.6.2-23.1
  • qemu-linux-user-debugsource >= 2.6.2-23.1
  • qemu-ppc >= 2.6.2-23.1
  • qemu-ppc-debuginfo >= 2.6.2-23.1
  • qemu-s390 >= 2.6.2-23.1
  • qemu-s390-debuginfo >= 2.6.2-23.1
  • qemu-seabios >= 1.9.1-23.1
  • qemu-sgabios >= 8-23.1
  • qemu-testsuite >= 2.6.2-23.1
  • qemu-tools >= 2.6.2-23.1
  • qemu-tools-debuginfo >= 2.6.2-23.1
  • qemu-vgabios >= 1.9.1-23.1
  • qemu-x86 >= 2.6.2-23.1
  • qemu-x86-debuginfo >= 2.6.2-23.1
Patchnames:
openSUSE-2016-1504
openSUSE Leap 42.3
  • qemu >= 2.9.0-30.1
  • qemu-arm >= 2.9.0-30.1
  • qemu-block-curl >= 2.9.0-30.1
  • qemu-block-dmg >= 2.9.0-30.1
  • qemu-block-iscsi >= 2.9.0-30.1
  • qemu-block-rbd >= 2.9.0-30.1
  • qemu-block-ssh >= 2.9.0-30.1
  • qemu-extra >= 2.9.0-30.1
  • qemu-ipxe >= 1.0.0-30.1
  • qemu-ksm >= 2.9.0-30.1
  • qemu-kvm >= 2.9.0-30.1
  • qemu-lang >= 2.9.0-30.1
  • qemu-ppc >= 2.9.0-30.1
  • qemu-s390 >= 2.9.0-30.1
  • qemu-seabios >= 1.10.2-30.1
  • qemu-sgabios >= 8-30.1
  • qemu-tools >= 2.9.0-30.1
  • qemu-vgabios >= 1.10.2-30.1
  • qemu-x86 >= 2.9.0-30.1
Patchnames:
openSUSE Leap 42.3 GA qemu


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 qemu Released
SUSE Linux Enterprise Server 12 SP2 qemu Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI qemu Released