Upstream information

CVE-2016-7914 at MITRE

Description

The assoc_array_insert_into_terminal_node function in lib/assoc_array.c in the Linux kernel before 4.5.3 does not check whether a slot is a leaf, which allows local users to obtain sensitive information from kernel memory or cause a denial of service (invalid pointer dereference and out-of-bounds read) via an application that uses associative-array data structures, as demonstrated by the keyutils test suite.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.1 5.4
Vector AV:N/AC:M/Au:N/C:C/I:N/A:N AV:L/AC:M/Au:N/C:P/I:N/A:C
Access Vector Network Local
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Complete Partial
Integrity Impact None None
Availability Impact None Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1010475 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP1
  • kernel-zfcpdump >= 3.12.69-60.64.29.1
Patchnames:
SUSE-SLE-BSK-12-SP1-2017-238
SUSE Linux Enterprise Desktop 12 SP1
  • kernel-default >= 3.12.69-60.64.29.1
  • kernel-default-devel >= 3.12.69-60.64.29.1
  • kernel-default-extra >= 3.12.69-60.64.29.1
  • kernel-devel >= 3.12.69-60.64.29.1
  • kernel-macros >= 3.12.69-60.64.29.1
  • kernel-source >= 3.12.69-60.64.29.1
  • kernel-syms >= 3.12.69-60.64.29.1
  • kernel-xen >= 3.12.69-60.64.29.1
  • kernel-xen-devel >= 3.12.69-60.64.29.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-238
SUSE Linux Enterprise Live Patching 12
  • kgraft-patch-3_12_69-60_64_29-default >= 1-4.1
  • kgraft-patch-3_12_69-60_64_29-xen >= 1-4.1
  • kgraft-patch-SLE12-SP1_Update_12 >= 1-4.1
Patchnames:
SUSE-SLE-Live-Patching-12-2017-238
SUSE Linux Enterprise Module for Public Cloud 12
  • kernel-ec2 >= 3.12.61-52.66.1
  • kernel-ec2-devel >= 3.12.61-52.66.1
  • kernel-ec2-extra >= 3.12.61-52.66.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2017-238
SUSE-SLE-Module-Public-Cloud-12-2017-247
SUSE Linux Enterprise Real Time Extension 12 SP1
  • kernel-compute >= 3.12.69-60.30.1
  • kernel-compute-base >= 3.12.69-60.30.1
  • kernel-compute-devel >= 3.12.69-60.30.1
  • kernel-compute_debug >= 3.12.69-60.30.1
  • kernel-compute_debug-devel >= 3.12.69-60.30.1
  • kernel-devel-rt >= 3.12.69-60.30.1
  • kernel-rt >= 3.12.69-60.30.1
  • kernel-rt-base >= 3.12.69-60.30.1
  • kernel-rt-devel >= 3.12.69-60.30.1
  • kernel-rt_debug >= 3.12.69-60.30.1
  • kernel-rt_debug-devel >= 3.12.69-60.30.1
  • kernel-source-rt >= 3.12.69-60.30.1
  • kernel-syms-rt >= 3.12.69-60.30.1
Patchnames:
SUSE-SLE-RT-12-SP1-2017-202
SUSE Linux Enterprise Server 12 SP1
  • kernel-default >= 3.12.69-60.64.29.1
  • kernel-default-base >= 3.12.69-60.64.29.1
  • kernel-default-devel >= 3.12.69-60.64.29.1
  • kernel-default-man >= 3.12.69-60.64.29.1
  • kernel-devel >= 3.12.69-60.64.29.1
  • kernel-macros >= 3.12.69-60.64.29.1
  • kernel-source >= 3.12.69-60.64.29.1
  • kernel-syms >= 3.12.69-60.64.29.1
  • kernel-xen >= 3.12.69-60.64.29.1
  • kernel-xen-base >= 3.12.69-60.64.29.1
  • kernel-xen-devel >= 3.12.69-60.64.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-238
SUSE Linux Enterprise Server 12-LTSS
  • kernel-default >= 3.12.61-52.66.1
  • kernel-default-base >= 3.12.61-52.66.1
  • kernel-default-devel >= 3.12.61-52.66.1
  • kernel-default-man >= 3.12.61-52.66.1
  • kernel-devel >= 3.12.61-52.66.1
  • kernel-macros >= 3.12.61-52.66.1
  • kernel-source >= 3.12.61-52.66.1
  • kernel-syms >= 3.12.61-52.66.1
  • kernel-xen >= 3.12.61-52.66.1
  • kernel-xen-base >= 3.12.61-52.66.1
  • kernel-xen-devel >= 3.12.61-52.66.1
  • kgraft-patch-3_12_61-52_66-default >= 1-2.1
  • kgraft-patch-3_12_61-52_66-xen >= 1-2.1
  • kgraft-patch-SLE12_Update_19 >= 1-2.1
Patchnames:
SUSE-SLE-SERVER-12-2017-247
SUSE Linux Enterprise Server for SAP Applications 12
  • kernel-default >= 3.12.61-52.66.1
  • kernel-default-base >= 3.12.61-52.66.1
  • kernel-default-devel >= 3.12.61-52.66.1
  • kernel-devel >= 3.12.61-52.66.1
  • kernel-macros >= 3.12.61-52.66.1
  • kernel-source >= 3.12.61-52.66.1
  • kernel-syms >= 3.12.61-52.66.1
  • kernel-xen >= 3.12.61-52.66.1
  • kernel-xen-base >= 3.12.61-52.66.1
  • kernel-xen-devel >= 3.12.61-52.66.1
  • kgraft-patch-3_12_61-52_66-default >= 1-2.1
  • kgraft-patch-3_12_61-52_66-xen >= 1-2.1
  • kgraft-patch-SLE12_Update_19 >= 1-2.1
Patchnames:
SUSE-SLE-SAP-12-2017-247
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • kernel-default >= 3.12.69-60.64.29.1
  • kernel-default-base >= 3.12.69-60.64.29.1
  • kernel-default-devel >= 3.12.69-60.64.29.1
  • kernel-default-man >= 3.12.69-60.64.29.1
  • kernel-devel >= 3.12.69-60.64.29.1
  • kernel-macros >= 3.12.69-60.64.29.1
  • kernel-source >= 3.12.69-60.64.29.1
  • kernel-syms >= 3.12.69-60.64.29.1
  • kernel-xen >= 3.12.69-60.64.29.1
  • kernel-xen-base >= 3.12.69-60.64.29.1
  • kernel-xen-devel >= 3.12.69-60.64.29.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-238
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • kernel-default >= 3.12.61-52.66.1
  • kernel-default-base >= 3.12.61-52.66.1
  • kernel-default-devel >= 3.12.61-52.66.1
  • kernel-default-man >= 3.12.61-52.66.1
  • kernel-devel >= 3.12.61-52.66.1
  • kernel-macros >= 3.12.61-52.66.1
  • kernel-source >= 3.12.61-52.66.1
  • kernel-syms >= 3.12.61-52.66.1
  • kernel-xen >= 3.12.61-52.66.1
  • kernel-xen-base >= 3.12.61-52.66.1
  • kernel-xen-devel >= 3.12.61-52.66.1
  • kgraft-patch-3_12_61-52_66-default >= 1-2.1
  • kgraft-patch-3_12_61-52_66-xen >= 1-2.1
  • kgraft-patch-SLE12_Update_19 >= 1-2.1
Patchnames:
SUSE-SLE-SERVER-12-2017-247
SUSE Linux Enterprise Software Development Kit 12 SP1
  • kernel-docs >= 3.12.69-60.64.29.3
  • kernel-obs-build >= 3.12.69-60.64.29.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-238
SUSE Linux Enterprise Workstation Extension 12 SP1
  • kernel-default >= 3.12.69-60.64.29.1
  • kernel-default-extra >= 3.12.69-60.64.29.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-238


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 kernel-source Released
SUSE Linux Enterprise Desktop 12 SP2 kernel-source Affected
SUSE Linux Enterprise Server 11 SP4 kernel-source Affected
SUSE Linux Enterprise Server 12 GA LTSS kernel-source Released
SUSE Linux Enterprise Server 12 SP1 kernel-source Released
SUSE Linux Enterprise Server 12 SP2 kernel-source Affected