Upstream information

CVE-2016-7567 at MITRE

Description

Buffer overflow in the SLPFoldWhiteSpace function in common/slp_compare.c in OpenSLP 2.0 allows remote attackers to have unspecified impact via a crafted string.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.8
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1001600 [RESOLVED / FIXED], 1074356 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • openslp >= 2.0.0-17.1
  • openslp-32bit >= 2.0.0-17.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1565
SUSE Linux Enterprise Desktop 12 SP2
  • openslp >= 2.0.0-18.2.1
  • openslp-32bit >= 2.0.0-18.2.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-68
SUSE Linux Enterprise Desktop 12 SP3
  • openslp >= 2.0.0-17.1
  • openslp-32bit >= 2.0.0-17.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA openslp
SUSE Linux Enterprise Module for Basesystem 15
  • openslp >= 2.0.0-4.13
  • openslp-32bit >= 2.0.0-4.13
  • openslp-devel >= 2.0.0-4.13
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA openslp
SUSE Linux Enterprise Module for Server Applications 15
  • openslp-server >= 2.0.0-4.13
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA openslp-server
SUSE Linux Enterprise Server 12 SP1
  • openslp >= 2.0.0-17.1
  • openslp-32bit >= 2.0.0-17.1
  • openslp-server >= 2.0.0-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1565
SUSE Linux Enterprise Server 12 SP2
  • openslp >= 2.0.0-18.2.1
  • openslp-32bit >= 2.0.0-18.2.1
  • openslp-server >= 2.0.0-18.2.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-68
SUSE Linux Enterprise Server 12 SP3
  • openslp >= 2.0.0-17.1
  • openslp-32bit >= 2.0.0-17.1
  • openslp-server >= 2.0.0-17.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA openslp
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • openslp >= 2.0.0-18.2.1
  • openslp-server >= 2.0.0-18.2.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-68
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • openslp >= 2.0.0-17.1
  • openslp-32bit >= 2.0.0-17.1
  • openslp-server >= 2.0.0-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1565
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • openslp >= 2.0.0-18.2.1
  • openslp-32bit >= 2.0.0-18.2.1
  • openslp-server >= 2.0.0-18.2.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-68
SUSE Linux Enterprise Software Development Kit 12 SP1
  • openslp >= 2.0.0-17.1
  • openslp-devel >= 2.0.0-17.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1565
SUSE Linux Enterprise Software Development Kit 12 SP2
  • openslp >= 2.0.0-18.2.1
  • openslp-devel >= 2.0.0-18.2.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-68
SUSE Linux Enterprise Software Development Kit 12 SP3
  • openslp-devel >= 2.0.0-17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA openslp-devel
openSUSE Leap 15.0
  • openslp >= 2.0.0-lp150.4.1
  • openslp-32bit >= 2.0.0-lp150.4.1
Patchnames:
openSUSE Leap 15.0 GA openslp
openSUSE Leap 42.1
  • openslp >= 2.0.0-17.1
  • openslp-32bit >= 2.0.0-17.1
  • openslp-debuginfo >= 2.0.0-17.1
  • openslp-debuginfo-32bit >= 2.0.0-17.1
  • openslp-debugsource >= 2.0.0-17.1
  • openslp-devel >= 2.0.0-17.1
  • openslp-server >= 2.0.0-17.1
  • openslp-server-debuginfo >= 2.0.0-17.1
Patchnames:
openSUSE-2016-1262
openSUSE Leap 42.2
  • openslp >= 2.0.0-15.1
  • openslp-devel >= 2.0.0-15.1
  • openslp-server >= 2.0.0-15.1
Patchnames:
openSUSE Leap 42.2 GA openslp
openSUSE Leap 42.3
  • openslp >= 2.0.0-17.3
  • openslp-devel >= 2.0.0-17.3
  • openslp-server >= 2.0.0-17.3
Patchnames:
openSUSE Leap 42.3 GA openslp
openSUSE Tumbleweed
  • openslp >= 2.0.0-8.1
  • openslp-32bit >= 2.0.0-8.1
  • openslp-devel >= 2.0.0-8.1
  • openslp-server >= 2.0.0-8.1
Patchnames:
openSUSE Tumbleweed GA openslp


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA openslp Released
SUSE Linux Enterprise Desktop 12 SP1 openslp Released
SUSE Linux Enterprise Desktop 12 SP2 openslp Released
SUSE Linux Enterprise SDK 11 SP4 openslp Not affected
SUSE Linux Enterprise SDK 12 GA openslp Released
SUSE Linux Enterprise SDK 12 SP1 openslp Released
SUSE Linux Enterprise SDK 12 SP2 openslp Released
SUSE Linux Enterprise Server 10 SP4 LTSS openslp Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS openslp Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS openslp Not affected
SUSE Linux Enterprise Server 11 SP4 openslp Not affected
SUSE Linux Enterprise Server 12 GA openslp Released
SUSE Linux Enterprise Server 12 GA LTSS openslp Released
SUSE Linux Enterprise Server 12 SP1 openslp Released
SUSE Linux Enterprise Server 12 SP2 openslp Released