Upstream information

CVE-2016-7553 at MITRE

Description

The buf.pl script before 2.20 in Irssi before 0.8.20 uses weak permissions for the scrollbuffer dump file created between upgrades, which might allow local users to obtain sensitive information from private chat conversations by reading the file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
CVSS v3 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1001215

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Package Hub for SUSE Linux Enterprise 12
  • irssi >= 0.8.20-9.1
  • irssi-debuginfo >= 0.8.20-9.1
  • irssi-debugsource >= 0.8.20-9.1
  • irssi-devel >= 0.8.20-9.1
Patchnames:
5661
openSUSE Leap 42.1
  • irssi >= 0.8.20-6.1
  • irssi-debuginfo >= 0.8.20-6.1
  • irssi-debugsource >= 0.8.20-6.1
  • irssi-devel >= 0.8.20-6.1
Patchnames:
5661
openSUSE Leap 42.2
  • irssi >= 0.8.20-7.1
Patchnames:
openSUSE Leap 42.2 GA irssi
openSUSE Leap 42.3
  • irssi >= 1.0.4-15.1
Patchnames:
openSUSE Leap 42.3 GA irssi
openSUSE Tumbleweed
  • irssi >= 0.8.20-3.1
  • irssi-devel >= 0.8.20-3.1
Patchnames:
openSUSE Tumbleweed GA irssi