Upstream information

CVE-2016-7444 at MITRE

Description

The gnutls_ocsp_resp_check_crt function in lib/x509/ocsp.c in GnuTLS before 3.4.15 and 3.5.x before 3.5.4 does not verify the serial length of an OCSP response, which might allow remote attackers to bypass an intended certificate validation mechanism via vectors involving trailing bytes left by gnutls_malloc.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact None
CVSSv3 Version 3
SUSE Bugzilla entry: 999646 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gnutls >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-177
SUSE Linux Enterprise Desktop 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-177
SUSE Linux Enterprise Desktop 12 SP3
  • gnutls >= 3.3.27-1.10
  • libgnutls28 >= 3.3.27-1.10
  • libgnutls28-32bit >= 3.3.27-1.10
SUSE Linux Enterprise Desktop 12 SP4
  • gnutls >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • gnutls >= 3.3.27-3.3.1
  • libgnutls-openssl27 >= 3.3.27-3.3.1
  • libgnutls28 >= 3.3.27-3.3.1
  • libgnutls28-32bit >= 3.3.27-3.3.1
SUSE Linux Enterprise Server 12 SP1
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gnutls >= 3.2.15-16.1
  • libgnutls-openssl27 >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-177
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls-openssl27 >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-177
SUSE Linux Enterprise Server 12 SP3
  • gnutls >= 3.3.27-1.10
  • libgnutls-openssl27 >= 3.3.27-1.10
  • libgnutls28 >= 3.3.27-1.10
  • libgnutls28-32bit >= 3.3.27-1.10
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls-openssl27 >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-177
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gnutls >= 3.2.15-16.1
  • libgnutls-devel >= 3.2.15-16.1
  • libgnutls-openssl-devel >= 3.2.15-16.1
  • libgnutlsxx-devel >= 3.2.15-16.1
  • libgnutlsxx28 >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-177
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls-devel >= 3.2.15-16.1
  • libgnutls-openssl-devel >= 3.2.15-16.1
  • libgnutlsxx-devel >= 3.2.15-16.1
  • libgnutlsxx28 >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-177
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgnutls-devel >= 3.3.27-1.10
  • libgnutls-openssl-devel >= 3.3.27-1.10
  • libgnutlsxx-devel >= 3.3.27-1.10
  • libgnutlsxx28 >= 3.3.27-1.10
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libgnutls-devel >= 3.3.27-3.3.1
  • libgnutls-openssl-devel >= 3.3.27-3.3.1
  • libgnutlsxx-devel >= 3.3.27-3.3.1
  • libgnutlsxx28 >= 3.3.27-3.3.1
openSUSE Leap 42.1
  • gnutls >= 3.2.15-8.1
  • gnutls-debuginfo >= 3.2.15-8.1
  • gnutls-debugsource >= 3.2.15-8.1
  • libgnutls-devel >= 3.2.15-8.1
  • libgnutls-devel-32bit >= 3.2.15-8.1
  • libgnutls-openssl-devel >= 3.2.15-8.1
  • libgnutls-openssl27 >= 3.2.15-8.1
  • libgnutls-openssl27-debuginfo >= 3.2.15-8.1
  • libgnutls28 >= 3.2.15-8.1
  • libgnutls28-32bit >= 3.2.15-8.1
  • libgnutls28-debuginfo >= 3.2.15-8.1
  • libgnutls28-debuginfo-32bit >= 3.2.15-8.1
  • libgnutlsxx-devel >= 3.2.15-8.1
  • libgnutlsxx28 >= 3.2.15-8.1
  • libgnutlsxx28-debuginfo >= 3.2.15-8.1
Patchnames:
openSUSE-2017-207
openSUSE Leap 42.2
  • gnutls >= 3.2.15-9.1
  • gnutls-debuginfo >= 3.2.15-9.1
  • gnutls-debugsource >= 3.2.15-9.1
  • libgnutls-devel >= 3.2.15-9.1
  • libgnutls-devel-32bit >= 3.2.15-9.1
  • libgnutls-openssl-devel >= 3.2.15-9.1
  • libgnutls-openssl27 >= 3.2.15-9.1
  • libgnutls-openssl27-debuginfo >= 3.2.15-9.1
  • libgnutls28 >= 3.2.15-9.1
  • libgnutls28-32bit >= 3.2.15-9.1
  • libgnutls28-debuginfo >= 3.2.15-9.1
  • libgnutls28-debuginfo-32bit >= 3.2.15-9.1
  • libgnutlsxx-devel >= 3.2.15-9.1
  • libgnutlsxx28 >= 3.2.15-9.1
  • libgnutlsxx28-debuginfo >= 3.2.15-9.1
Patchnames:
openSUSE-2017-207
openSUSE Leap 42.3
  • gnutls >= 3.3.27-1.5
  • libgnutls-devel >= 3.3.27-1.5
  • libgnutls-openssl27 >= 3.3.27-1.5
  • libgnutls28 >= 3.3.27-1.5
  • libgnutls28-32bit >= 3.3.27-1.5
Patchnames:
openSUSE Leap 42.3 GA gnutls


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLES_LTSS-10-SP4 gnutls Ignore
SUSE Linux Enterprise Desktop 12 SP1 gnutls Released
SUSE Linux Enterprise Desktop 12 SP2 gnutls Released
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Ignore
SUSE Linux Enterprise Server 11 SP1 gnutls Ignore
SUSE Linux Enterprise Server 11 SP2 LTSS gnutls Ignore
SUSE Linux Enterprise Server 11 SP3 gnutls Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Ignore
SUSE Linux Enterprise Server 11 SP4 gnutls Ignore
SUSE Linux Enterprise Server 12 LTSS gnutls Ignore
SUSE Linux Enterprise Server 12 SP1 gnutls Released
SUSE Linux Enterprise Server 12 SP2 gnutls Released
SUSE Linux Enterprise Server for the Raspberry Pi gnutls Released
SUSE Linux Enterprise Software Development Kit 11 SP4 gnutls Ignore
SUSE Linux Enterprise Software Development Kit 12 gnutls Ignore
SUSE Linux Enterprise Software Development Kit 12 SP1 gnutls Released