Upstream information

CVE-2016-6513 at MITRE

Description

epan/dissectors/packet-wbxml.c in the WBXML dissector in Wireshark 2.x before 2.0.5 does not restrict the recursion depth, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 991022 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libwireshark9 >= 2.4.6-1.31
  • libwiretap7 >= 2.4.6-1.31
  • libwscodecs1 >= 2.4.6-1.31
  • libwsutil8 >= 2.4.6-1.31
  • wireshark >= 2.4.6-1.31
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libwireshark9
SUSE Linux Enterprise Module for Desktop Applications 15
  • wireshark-devel >= 2.4.6-1.31
  • wireshark-ui-qt >= 2.4.6-1.31
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA wireshark-devel
openSUSE Leap 42.2
  • wireshark >= 2.2.1-1.1
  • wireshark-ui-gtk >= 2.2.1-1.1
Patchnames:
openSUSE Leap 42.2 GA wireshark
openSUSE Leap 42.3
  • wireshark >= 2.2.7-15.1
  • wireshark-ui-gtk >= 2.2.7-15.1
Patchnames:
openSUSE Leap 42.3 GA wireshark
openSUSE Tumbleweed
  • wireshark >= 2.2.2-1.1
  • wireshark-devel >= 2.2.2-1.1
  • wireshark-ui-gtk >= 2.2.2-1.1
  • wireshark-ui-qt >= 2.2.2-1.1
Patchnames:
openSUSE Tumbleweed GA wireshark


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA wireshark Not affected
SUSE Linux Enterprise Desktop 12 SP1 wireshark Not affected
SUSE Linux Enterprise SDK 11 SP4 wireshark Not affected
SUSE Linux Enterprise SDK 12 GA wireshark Not affected
SUSE Linux Enterprise SDK 12 SP1 wireshark Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS wireshark Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS wireshark Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS wireshark Not affected
SUSE Linux Enterprise Server 11 SP4 wireshark Not affected
SUSE Linux Enterprise Server 12 GA wireshark Not affected
SUSE Linux Enterprise Server 12 SP1 wireshark Not affected