Upstream information

CVE-2016-6308 at MITRE

Description

statem/statem_dtls.c in the DTLS implementation in OpenSSL 1.1.0 before 1.1.0a allocates memory before checking for an excessive length, which might allow remote attackers to cause a denial of service (memory consumption) via crafted DTLS messages.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.1 2.6
Vector AV:N/AC:M/Au:N/C:N/I:N/A:C AV:N/AC:H/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Complete Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

Note from the SUSE Security Team

This issue affects only openssl 1.1.0, older versions are not affected.

SUSE Bugzilla entries: 999665 [RESOLVED / FIXED], 999670 [RESOLVED / FIXED]

SUSE Security Advisories:
  • TID7016794, published Sa 3. Mär 12:01:59 CET 2018


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 compat-openssl098 Unsupported
SUSE Linux Enterprise Desktop 12 SP1 openssl Not affected
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Not affected
SUSE Linux Enterprise SDK 11 SP4 openssl Not affected
SUSE Linux Enterprise SDK 12 GA openssl Not affected
SUSE Linux Enterprise SDK 12 SP1 openssl Not affected
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS compat-openssl097g Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 12 GA LTSS openssl Not affected
SUSE Linux Enterprise Server 12 SP1 openssl Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 compat-openssl098 Not affected
SUSE Studio Onsite 1.3 openssl Not affected