Upstream information

CVE-2016-6254 at MITRE

Description

Heap-based buffer overflow in the parse_packet function in network.c in collectd before 5.4.3 and 5.x before 5.5.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via a crafted network packet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 4.3
Vector AV:N/AC:L/Au:N/C:N/I:P/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 990853 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Lifecycle Management Server 1.3
  • collectd >= 4.9.4-0.25.1
  • libcollectdclient-devel >= 4.9.4-0.25.1
  • libcollectdclient0 >= 4.9.4-0.25.1
Patchnames:
sleslms13-collectd-12720
SUSE WebYast 1.3
  • collectd >= 4.9.4-0.25.1
  • libcollectdclient-devel >= 4.9.4-0.25.1
  • libcollectdclient0 >= 4.9.4-0.25.1
Patchnames:
slewyst13-collectd-12720
openSUSE Tumbleweed
  • collectd >= 5.5.2-1.4
  • collectd-plugin-dbi >= 5.5.2-1.4
  • collectd-plugin-ipmi >= 5.5.2-1.4
  • collectd-plugin-java >= 5.5.2-1.4
  • collectd-plugin-memcachec >= 5.5.2-1.4
  • collectd-plugin-mysql >= 5.5.2-1.4
  • collectd-plugin-notify-desktop >= 5.5.2-1.4
  • collectd-plugin-pinba >= 5.5.2-1.4
  • collectd-plugin-postgresql >= 5.5.2-1.4
  • collectd-plugin-python >= 5.5.2-1.4
  • collectd-plugin-smart >= 5.5.2-1.4
  • collectd-plugin-snmp >= 5.5.2-1.4
  • collectd-plugin-virt >= 5.5.2-1.4
  • collectd-plugins-all >= 5.5.2-1.4
  • collectd-spamassassin >= 5.5.2-1.4
  • collectd-web >= 5.5.2-1.4
  • collectd-web-js >= 5.5.2-1.4
  • libcollectdclient-devel >= 5.5.2-1.4
  • libcollectdclient1 >= 5.5.2-1.4
Patchnames:
openSUSE Tumbleweed GA collectd


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Lifecycle Management Server 1.3 collectd Released
WebYaST 1.3 collectd Released