Upstream information

CVE-2016-6224 at MITRE

Description

ecryptfs-setup-swap in eCryptfs does not prevent the unencrypted swap partition from activating during boot when using GPT partitioning on a (1) NVMe or (2) MMC drive, which allows local users to obtain sensitive information via unspecified vectors. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-8946.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.1 4
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N AV:L/AC:H/Au:N/C:C/I:N/A:N
Access Vector Local Local
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Complete
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 3.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 989121 [RESOLVED / FIXED], 989122 [CONFIRMED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • ecryptfs-utils >= 103-8.3.1
  • ecryptfs-utils-32bit >= 103-8.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-234
SUSE Linux Enterprise Desktop 12 SP3
  • ecryptfs-utils >= 103-8.3.1
  • ecryptfs-utils-32bit >= 103-8.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-234
SUSE Linux Enterprise Server 12 SP2
  • ecryptfs-utils >= 103-8.3.1
  • ecryptfs-utils-32bit >= 103-8.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-234
SUSE Linux Enterprise Server 12 SP3
  • ecryptfs-utils >= 103-8.3.1
  • ecryptfs-utils-32bit >= 103-8.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-234
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ecryptfs-utils >= 103-8.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-234
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • ecryptfs-utils >= 103-8.3.1
  • ecryptfs-utils-32bit >= 103-8.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-234
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ecryptfs-utils >= 103-8.3.1
  • ecryptfs-utils-32bit >= 103-8.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-234
openSUSE Leap 42.3
  • ecryptfs-utils >= 103-7.1
  • ecryptfs-utils-32bit >= 103-7.1
  • ecryptfs-utils-debuginfo >= 103-7.1
  • ecryptfs-utils-debuginfo-32bit >= 103-7.1
  • ecryptfs-utils-debugsource >= 103-7.1
Patchnames:
openSUSE-2018-126


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA ecryptfs-utils Not affected
SUSE Linux Enterprise Desktop 12 SP1 ecryptfs-utils Unsupported
SUSE Linux Enterprise Desktop 12 SP2 ecryptfs-utils Released
SUSE Linux Enterprise Desktop 12 SP3 ecryptfs-utils Released
SUSE Linux Enterprise Server 11 SP2 LTSS ecryptfs-utils Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS ecryptfs-utils Not affected
SUSE Linux Enterprise Server 11 SP4 ecryptfs-utils Not affected
SUSE Linux Enterprise Server 12 GA ecryptfs-utils Not affected
SUSE Linux Enterprise Server 12 SP1 ecryptfs-utils Unsupported
SUSE Linux Enterprise Server 12 SP2 ecryptfs-utils Released
SUSE Linux Enterprise Server 12 SP3 ecryptfs-utils Released