Upstream information

CVE-2016-6153 at MITRE

Description

os_unix.c in SQLite before 3.13.0 improperly implements the temporary directory search algorithm, which might allow local users to obtain sensitive information, cause a denial of service (application crash), or have unspecified other impact by leveraging use of the current working directory for temporary files.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.6 3.3
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:N/C:P/I:P/A:N
Access Vector Local Local
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.9
Vector AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 987394 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libsqlite3-0 >= 3.8.10.2-3.1
  • libsqlite3-0-32bit >= 3.8.10.2-3.1
  • sqlite3 >= 3.8.10.2-3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1141
SUSE Linux Enterprise Desktop 12 SP2
  • libsqlite3-0 >= 3.8.10.2-3.1
  • libsqlite3-0-32bit >= 3.8.10.2-3.1
  • sqlite3 >= 3.8.10.2-3.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libsqlite3-0
SUSE Linux Enterprise Desktop 12 SP3
  • libsqlite3-0 >= 3.8.10.2-8.1
  • libsqlite3-0-32bit >= 3.8.10.2-8.1
  • sqlite3 >= 3.8.10.2-8.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libsqlite3-0
SUSE Linux Enterprise Server 11 SP4
  • libsqlite3-0 >= 3.7.6.3-1.4.6.1
  • libsqlite3-0-32bit >= 3.7.6.3-1.4.6.1
  • libsqlite3-0-x86 >= 3.7.6.3-1.4.6.1
  • sqlite3 >= 3.7.6.3-1.4.6.1
Patchnames:
slessp4-sqlite3-12687
SUSE Linux Enterprise Server 12 SP1
  • libsqlite3-0 >= 3.8.10.2-3.1
  • libsqlite3-0-32bit >= 3.8.10.2-3.1
  • sqlite3 >= 3.8.10.2-3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1141
SUSE Linux Enterprise Server 12 SP2
  • libsqlite3-0 >= 3.8.10.2-3.1
  • libsqlite3-0-32bit >= 3.8.10.2-3.1
  • sqlite3 >= 3.8.10.2-3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libsqlite3-0
SUSE Linux Enterprise Server 12 SP3
  • libsqlite3-0 >= 3.8.10.2-8.1
  • libsqlite3-0-32bit >= 3.8.10.2-8.1
  • sqlite3 >= 3.8.10.2-8.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libsqlite3-0
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libsqlite3-0 >= 3.8.10.2-3.1
  • sqlite3 >= 3.8.10.2-3.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libsqlite3-0
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libsqlite3-0 >= 3.7.6.3-1.4.6.1
  • libsqlite3-0-32bit >= 3.7.6.3-1.4.6.1
  • libsqlite3-0-x86 >= 3.7.6.3-1.4.6.1
  • sqlite3 >= 3.7.6.3-1.4.6.1
Patchnames:
slessp4-sqlite3-12687
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libsqlite3-0 >= 3.8.10.2-3.1
  • libsqlite3-0-32bit >= 3.8.10.2-3.1
  • sqlite3 >= 3.8.10.2-3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1141
SUSE Linux Enterprise Software Development Kit 11 SP4
  • sqlite3 >= 3.7.6.3-1.4.6.1
  • sqlite3-devel >= 3.7.6.3-1.4.6.1
Patchnames:
sdksp4-sqlite3-12687
SUSE Linux Enterprise Software Development Kit 12 SP1
  • sqlite3 >= 3.8.10.2-3.1
  • sqlite3-devel >= 3.8.10.2-3.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1141
SUSE Linux Enterprise Software Development Kit 12 SP2
  • sqlite3-devel >= 3.8.10.2-3.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA sqlite3-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • sqlite3-devel >= 3.8.10.2-8.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA sqlite3-devel
SUSE Studio Onsite 1.3
  • sqlite3 >= 3.7.6.3-1.4.6.1
  • sqlite3-devel >= 3.7.6.3-1.4.6.1
Patchnames:
slestso13-sqlite3-12687
openSUSE Leap 42.1
  • libsqlite3-0 >= 3.8.10.2-7.1
  • libsqlite3-0-32bit >= 3.8.10.2-7.1
  • libsqlite3-0-debuginfo >= 3.8.10.2-7.1
  • libsqlite3-0-debuginfo-32bit >= 3.8.10.2-7.1
  • sqlite3 >= 3.8.10.2-7.1
  • sqlite3-debuginfo >= 3.8.10.2-7.1
  • sqlite3-debugsource >= 3.8.10.2-7.1
  • sqlite3-devel >= 3.8.10.2-7.1
  • sqlite3-doc >= 3.8.10.2-7.1
Patchnames:
openSUSE-2016-970
openSUSE Leap 42.2
  • libsqlite3-0 >= 3.8.10.2-7.9
  • libsqlite3-0-32bit >= 3.8.10.2-7.9
  • sqlite3 >= 3.8.10.2-7.9
  • sqlite3-devel >= 3.8.10.2-7.9
  • sqlite3-doc >= 3.8.10.2-7.9
Patchnames:
openSUSE Leap 42.2 GA libsqlite3-0
openSUSE Leap 42.3
  • libsqlite3-0 >= 3.8.10.2-10.2
  • libsqlite3-0-32bit >= 3.8.10.2-10.2
  • sqlite3 >= 3.8.10.2-10.2
  • sqlite3-devel >= 3.8.10.2-10.2
  • sqlite3-doc >= 3.8.10.2-10.2
Patchnames:
openSUSE Leap 42.3 GA libsqlite3-0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 sqlite3 Released
SUSE Linux Enterprise Desktop 11 SP3 sqlite3 Released
SUSE Linux Enterprise Desktop 11 SP4 sqlite3 Released
SUSE Linux Enterprise Desktop 12 GA sqlite3 Released
SUSE Linux Enterprise Desktop 12 SP1 sqlite3 Released
SUSE Linux Enterprise Desktop 12 SP2 sqlite3 Released
SUSE Linux Enterprise High Availability 12 GA sqlite2 Affected
SUSE Linux Enterprise High Availability 12 SP1 sqlite2 Affected
SUSE Linux Enterprise High Availability Extension 11 SP4 sqlite2 Ignore
SUSE Linux Enterprise SDK 11 SP2 sqlite3 Released
SUSE Linux Enterprise SDK 11 SP3 sqlite3 Released
SUSE Linux Enterprise SDK 11 SP4 sqlite2 Ignore
SUSE Linux Enterprise SDK 11 SP4 sqlite3 Released
SUSE Linux Enterprise SDK 12 GA sqlite2 Affected
SUSE Linux Enterprise SDK 12 GA sqlite3 Released
SUSE Linux Enterprise SDK 12 SP1 sqlite2 Unsupported
SUSE Linux Enterprise SDK 12 SP1 sqlite3 Released
SUSE Linux Enterprise SDK 12 SP2 sqlite3 Released
SUSE Linux Enterprise Server 10 SP4 LTSS sqlite Ignore
SUSE Linux Enterprise Server 10 SP4 LTSS sqlite2 Ignore
SUSE Linux Enterprise Server 11 SP2 sqlite3 Released
SUSE Linux Enterprise Server 11 SP2 LTSS sqlite3 Released
SUSE Linux Enterprise Server 11 SP3 sqlite3 Released
SUSE Linux Enterprise Server 11 SP3 LTSS sqlite3 Released
SUSE Linux Enterprise Server 11 SP4 sqlite3 Released
SUSE Linux Enterprise Server 12 GA sqlite3 Released
SUSE Linux Enterprise Server 12 GA LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 SP1 sqlite3 Released
SUSE Linux Enterprise Server 12 SP2 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 sqlite3 Released
SUSE Linux Enterprise Server for VMWare 11 SP2 sqlite3 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 sqlite3 Released
SUSE Studio Onsite 1.3 sqlite3 Released