Upstream information

CVE-2016-5699 at MITRE

Description

CRLF injection vulnerability in the HTTPConnection.putheader function in urllib2 and urllib in CPython (aka Python) before 2.7.10 and 3.x before 3.4.4 allows remote attackers to inject arbitrary HTTP headers via CRLF sequences in a URL.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact None None
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
SUSE Bugzilla entries: 985348 [RESOLVED / FIXED], 985351 [RESOLVED / INVALID], 986630 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libpython2_7-1_0 >= 2.7.9-24.2
  • libpython2_7-1_0-32bit >= 2.7.9-24.2
  • libpython3_4m1_0 >= 3.4.5-17.1
  • python >= 2.7.9-24.1
  • python-base >= 2.7.9-24.2
  • python-curses >= 2.7.9-24.1
  • python-devel >= 2.7.9-24.2
  • python-tk >= 2.7.9-24.1
  • python-xml >= 2.7.9-24.2
  • python3 >= 3.4.5-17.1
  • python3-base >= 3.4.5-17.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1245
SUSE-SLE-DESKTOP-12-SP1-2016-1558
SUSE Linux Enterprise Desktop 12 SP2
  • libpython2_7-1_0 >= 2.7.9-24.2
  • libpython2_7-1_0-32bit >= 2.7.9-24.2
  • libpython3_4m1_0 >= 3.4.5-19.1
  • python-base >= 2.7.9-24.2
  • python-devel >= 2.7.9-24.2
  • python-xml >= 2.7.9-24.2
  • python3 >= 3.4.5-19.1
  • python3-base >= 3.4.5-19.1
  • python3-curses >= 3.4.5-19.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libpython2_7-1_0
SUSE-SLE-DESKTOP-12-SP2-2016-1676
SUSE Linux Enterprise Desktop 12 SP3
  • libpython2_7-1_0 >= 2.7.13-27.1
  • libpython2_7-1_0-32bit >= 2.7.13-27.1
  • libpython3_4m1_0 >= 3.4.6-24.1
  • python >= 2.7.13-27.1
  • python-base >= 2.7.13-27.1
  • python-curses >= 2.7.13-27.1
  • python-devel >= 2.7.13-27.1
  • python-tk >= 2.7.13-27.1
  • python-xml >= 2.7.13-27.1
  • python3 >= 3.4.6-24.1
  • python3-base >= 3.4.6-24.1
  • python3-curses >= 3.4.6-24.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libpython2_7-1_0
SUSE Linux Enterprise Desktop 12 SP3 GA libpython3_4m1_0
SUSE Linux Enterprise Desktop 12 SP3 GA python
SUSE Linux Enterprise Desktop 12 SP3 GA python3
SUSE Linux Enterprise Module for Basesystem 15
  • libpython2_7-1_0 >= 2.7.14-5.21
  • python >= 2.7.14-5.19
  • python-base >= 2.7.14-5.21
  • python-curses >= 2.7.14-5.19
  • python-devel >= 2.7.14-5.21
  • python-gdbm >= 2.7.14-5.19
  • python-xml >= 2.7.14-5.21
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpython2_7-1_0
SUSE Linux Enterprise Module for Basesystem 15 GA python
SUSE Linux Enterprise Module for Desktop Applications 15
  • python-tk >= 2.7.14-5.19
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA python-tk
SUSE Linux Enterprise Module for Web Scripting 12
  • libpython3_4m1_0 >= 3.4.5-17.1
  • python3 >= 3.4.5-17.1
  • python3-base >= 3.4.5-17.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2016-1558
SUSE Linux Enterprise Server 11 SP4
  • libpython2_6-1_0 >= 2.6.9-39.1
  • libpython2_6-1_0-32bit >= 2.6.9-39.1
  • libpython2_6-1_0-x86 >= 2.6.9-39.1
  • python >= 2.6.9-39.1
  • python-32bit >= 2.6.9-39.1
  • python-base >= 2.6.9-39.1
  • python-base-32bit >= 2.6.9-39.1
  • python-base-x86 >= 2.6.9-39.1
  • python-curses >= 2.6.9-39.1
  • python-demo >= 2.6.9-39.1
  • python-doc >= 2.6-8.39.1
  • python-doc-pdf >= 2.6-8.39.1
  • python-gdbm >= 2.6.9-39.1
  • python-idle >= 2.6.9-39.1
  • python-tk >= 2.6.9-39.1
  • python-x86 >= 2.6.9-39.1
  • python-xml >= 2.6.9-39.1
Patchnames:
slessp4-python-12735
SUSE Linux Enterprise Server 12 SP1
  • libpython2_7-1_0 >= 2.7.9-24.2
  • libpython2_7-1_0-32bit >= 2.7.9-24.2
  • libpython3_4m1_0 >= 3.4.5-17.1
  • python >= 2.7.9-24.1
  • python-32bit >= 2.7.9-24.1
  • python-base >= 2.7.9-24.2
  • python-base-32bit >= 2.7.9-24.2
  • python-curses >= 2.7.9-24.1
  • python-demo >= 2.7.9-24.1
  • python-doc >= 2.7.9-24.4
  • python-doc-pdf >= 2.7.9-24.4
  • python-gdbm >= 2.7.9-24.1
  • python-idle >= 2.7.9-24.1
  • python-tk >= 2.7.9-24.1
  • python-xml >= 2.7.9-24.2
  • python3 >= 3.4.5-17.1
  • python3-base >= 3.4.5-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1245
SUSE-SLE-SERVER-12-SP1-2016-1558
SUSE Linux Enterprise Server 12 SP2
  • libpython2_7-1_0 >= 2.7.9-24.2
  • libpython2_7-1_0-32bit >= 2.7.9-24.2
  • libpython3_4m1_0 >= 3.4.5-19.1
  • python-base >= 2.7.9-24.2
  • python-base-32bit >= 2.7.9-24.2
  • python-xml >= 2.7.9-24.2
  • python3 >= 3.4.5-19.1
  • python3-base >= 3.4.5-19.1
  • python3-curses >= 3.4.5-19.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libpython2_7-1_0
SUSE-SLE-SERVER-12-SP2-2016-1676
SUSE Linux Enterprise Server 12 SP3
  • libpython2_7-1_0 >= 2.7.13-27.1
  • libpython2_7-1_0-32bit >= 2.7.13-27.1
  • libpython3_4m1_0 >= 3.4.6-24.1
  • python >= 2.7.13-27.1
  • python-32bit >= 2.7.13-27.1
  • python-base >= 2.7.13-27.1
  • python-base-32bit >= 2.7.13-27.1
  • python-curses >= 2.7.13-27.1
  • python-demo >= 2.7.13-27.1
  • python-doc >= 2.7.13-27.1
  • python-doc-pdf >= 2.7.13-27.1
  • python-gdbm >= 2.7.13-27.1
  • python-idle >= 2.7.13-27.1
  • python-tk >= 2.7.13-27.1
  • python-xml >= 2.7.13-27.1
  • python3 >= 3.4.6-24.1
  • python3-base >= 3.4.6-24.1
  • python3-curses >= 3.4.6-24.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libpython2_7-1_0
SUSE Linux Enterprise Server 12 SP3 GA libpython3_4m1_0
SUSE Linux Enterprise Server 12 SP3 GA python
SUSE Linux Enterprise Server 12 SP3 GA python-doc
SUSE Linux Enterprise Server 12 SP3 GA python3
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpython2_7-1_0 >= 2.7.9-24.2
  • libpython3_4m1_0 >= 3.4.5-19.1
  • python-base >= 2.7.9-24.2
  • python-xml >= 2.7.9-24.2
  • python3 >= 3.4.5-19.1
  • python3-base >= 3.4.5-19.1
  • python3-curses >= 3.4.5-19.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpython2_7-1_0
SUSE-SLE-RPI-12-SP2-2016-1676
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libpython2_6-1_0 >= 2.6.9-39.1
  • libpython2_6-1_0-32bit >= 2.6.9-39.1
  • libpython2_6-1_0-x86 >= 2.6.9-39.1
  • python >= 2.6.9-39.1
  • python-32bit >= 2.6.9-39.1
  • python-base >= 2.6.9-39.1
  • python-base-32bit >= 2.6.9-39.1
  • python-base-x86 >= 2.6.9-39.1
  • python-curses >= 2.6.9-39.1
  • python-demo >= 2.6.9-39.1
  • python-doc >= 2.6-8.39.1
  • python-doc-pdf >= 2.6-8.39.1
  • python-gdbm >= 2.6.9-39.1
  • python-idle >= 2.6.9-39.1
  • python-tk >= 2.6.9-39.1
  • python-x86 >= 2.6.9-39.1
  • python-xml >= 2.6.9-39.1
Patchnames:
slessp4-python-12735
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libpython2_7-1_0 >= 2.7.9-24.2
  • libpython2_7-1_0-32bit >= 2.7.9-24.2
  • libpython3_4m1_0 >= 3.4.5-17.1
  • python >= 2.7.9-24.1
  • python-32bit >= 2.7.9-24.1
  • python-base >= 2.7.9-24.2
  • python-base-32bit >= 2.7.9-24.2
  • python-curses >= 2.7.9-24.1
  • python-demo >= 2.7.9-24.1
  • python-doc >= 2.7.9-24.4
  • python-doc-pdf >= 2.7.9-24.4
  • python-gdbm >= 2.7.9-24.1
  • python-idle >= 2.7.9-24.1
  • python-tk >= 2.7.9-24.1
  • python-xml >= 2.7.9-24.2
  • python3 >= 3.4.5-17.1
  • python3-base >= 3.4.5-17.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1245
SUSE-SLE-SERVER-12-SP1-2016-1558
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libpython3_4m1_0 >= 3.4.5-19.1
  • python3 >= 3.4.5-19.1
  • python3-base >= 3.4.5-19.1
  • python3-curses >= 3.4.5-19.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1676
SUSE Linux Enterprise Software Development Kit 11 SP4
  • python >= 2.6.9-39.1
  • python-32bit >= 2.6.9-39.1
  • python-base >= 2.6.9-39.1
  • python-demo >= 2.6.9-39.1
  • python-devel >= 2.6.9-39.1
  • python-doc >= 2.6-8.39.1
  • python-doc-pdf >= 2.6-8.39.1
  • python-gdbm >= 2.6.9-39.1
  • python-idle >= 2.6.9-39.1
  • python-tk >= 2.6.9-39.1
Patchnames:
sdksp4-python-12735
SUSE Linux Enterprise Software Development Kit 12 SP1
  • python-base >= 2.7.9-24.2
  • python-devel >= 2.7.9-24.2
  • python3-base >= 3.4.5-17.1
  • python3-devel >= 3.4.5-17.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1245
SUSE-SLE-SDK-12-SP1-2016-1558
SUSE Linux Enterprise Software Development Kit 12 SP2
  • python-devel >= 2.7.9-24.2
  • python3-base >= 3.4.5-19.1
  • python3-devel >= 3.4.5-19.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA python-devel
SUSE-SLE-SDK-12-SP2-2016-1676
SUSE Linux Enterprise Software Development Kit 12 SP3
  • python-devel >= 2.7.13-27.1
  • python3-devel >= 3.4.6-24.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA python-devel
SUSE Linux Enterprise Software Development Kit 12 SP3 GA python3-devel
SUSE Linux Enterprise Workstation Extension 12 SP1
  • python-base >= 2.7.9-24.2
  • python-devel >= 2.7.9-24.2
Patchnames:
SUSE-SLE-WE-12-SP1-2016-1245
SUSE Linux Enterprise Workstation Extension 12 SP2
  • python-devel >= 2.7.9-24.2
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA python-devel
SUSE Linux Enterprise Workstation Extension 12 SP3
  • python-devel >= 2.7.13-27.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA python-devel
openSUSE Leap 15.0
  • libpython2_7-1_0 >= 2.7.14-lp150.5.14
  • python >= 2.7.14-lp150.5.4
  • python-base >= 2.7.14-lp150.5.14
  • python-curses >= 2.7.14-lp150.5.4
  • python-xml >= 2.7.14-lp150.5.14
Patchnames:
openSUSE Leap 15.0 GA libpython2_7-1_0
openSUSE Leap 15.0 GA python
openSUSE Leap 42.1
  • libpython2_7-1_0 >= 2.7.12-23.1
  • libpython2_7-1_0-32bit >= 2.7.12-23.1
  • libpython2_7-1_0-debuginfo >= 2.7.12-23.1
  • libpython2_7-1_0-debuginfo-32bit >= 2.7.12-23.1
  • libpython3_4m1_0 >= 3.4.5-8.1
  • libpython3_4m1_0-32bit >= 3.4.5-8.1
  • libpython3_4m1_0-debuginfo >= 3.4.5-8.1
  • libpython3_4m1_0-debuginfo-32bit >= 3.4.5-8.1
  • python >= 2.7.12-23.1
  • python-32bit >= 2.7.12-23.1
  • python-base >= 2.7.12-23.1
  • python-base-32bit >= 2.7.12-23.1
  • python-base-debuginfo >= 2.7.12-23.1
  • python-base-debuginfo-32bit >= 2.7.12-23.1
  • python-base-debugsource >= 2.7.12-23.1
  • python-curses >= 2.7.12-23.1
  • python-curses-debuginfo >= 2.7.12-23.1
  • python-debuginfo >= 2.7.12-23.1
  • python-debuginfo-32bit >= 2.7.12-23.1
  • python-debugsource >= 2.7.12-23.1
  • python-demo >= 2.7.12-23.1
  • python-devel >= 2.7.12-23.1
  • python-doc >= 2.7.12-23.1
  • python-doc-pdf >= 2.7.12-23.1
  • python-gdbm >= 2.7.12-23.1
  • python-gdbm-debuginfo >= 2.7.12-23.1
  • python-idle >= 2.7.12-23.1
  • python-tk >= 2.7.12-23.1
  • python-tk-debuginfo >= 2.7.12-23.1
  • python-xml >= 2.7.12-23.1
  • python-xml-debuginfo >= 2.7.12-23.1
  • python3 >= 3.4.5-8.1
  • python3-32bit >= 3.4.5-8.1
  • python3-base >= 3.4.5-8.1
  • python3-base-32bit >= 3.4.5-8.1
  • python3-base-debuginfo >= 3.4.5-8.1
  • python3-base-debuginfo-32bit >= 3.4.5-8.1
  • python3-base-debugsource >= 3.4.5-8.1
  • python3-curses >= 3.4.5-8.1
  • python3-curses-debuginfo >= 3.4.5-8.1
  • python3-dbm >= 3.4.5-8.1
  • python3-dbm-debuginfo >= 3.4.5-8.1
  • python3-debuginfo >= 3.4.5-8.1
  • python3-debuginfo-32bit >= 3.4.5-8.1
  • python3-debugsource >= 3.4.5-8.1
  • python3-devel >= 3.4.5-8.1
  • python3-devel-debuginfo >= 3.4.5-8.1
  • python3-doc >= 3.4.5-8.1
  • python3-doc-pdf >= 3.4.5-8.1
  • python3-idle >= 3.4.5-8.1
  • python3-testsuite >= 3.4.5-8.1
  • python3-testsuite-debuginfo >= 3.4.5-8.1
  • python3-tk >= 3.4.5-8.1
  • python3-tk-debuginfo >= 3.4.5-8.1
  • python3-tools >= 3.4.5-8.1
Patchnames:
openSUSE-2016-906
openSUSE-2016-997
openSUSE Leap 42.2
  • libpython2_7-1_0 >= 2.7.12-24.1
  • libpython2_7-1_0-32bit >= 2.7.12-24.1
  • libpython3_4m1_0 >= 3.4.5-9.1
  • python >= 2.7.12-24.1
  • python-base >= 2.7.12-24.1
  • python-curses >= 2.7.12-24.1
  • python-devel >= 2.7.12-24.1
  • python-doc >= 2.7.12-24.1
  • python-gdbm >= 2.7.12-24.1
  • python-xml >= 2.7.12-24.1
  • python3 >= 3.4.5-9.1
  • python3-base >= 3.4.5-9.1
  • python3-curses >= 3.4.5-9.1
  • python3-dbm >= 3.4.5-9.1
  • python3-devel >= 3.4.5-9.1
  • python3-doc >= 3.4.5-9.1
  • python3-tk >= 3.4.5-9.1
Patchnames:
openSUSE Leap 42.2 GA libpython2_7-1_0
openSUSE Leap 42.2 GA libpython3_4m1_0
openSUSE Leap 42.2 GA python
openSUSE Leap 42.2 GA python-doc
openSUSE Leap 42.2 GA python3
openSUSE Leap 42.2 GA python3-doc
openSUSE Leap 42.3
  • libpython2_7-1_0 >= 2.7.13-26.1
  • libpython2_7-1_0-32bit >= 2.7.13-26.1
  • libpython3_4m1_0 >= 3.4.6-11.1
  • python >= 2.7.13-26.1
  • python-base >= 2.7.13-26.1
  • python-curses >= 2.7.13-26.1
  • python-devel >= 2.7.13-26.1
  • python-doc >= 2.7.13-26.1
  • python-gdbm >= 2.7.13-26.1
  • python-xml >= 2.7.13-26.1
  • python3 >= 3.4.6-11.1
  • python3-base >= 3.4.6-11.1
  • python3-curses >= 3.4.6-11.1
  • python3-dbm >= 3.4.6-11.1
  • python3-devel >= 3.4.6-11.1
  • python3-doc >= 3.4.6-11.1
  • python3-tk >= 3.4.6-11.1
Patchnames:
openSUSE Leap 42.3 GA libpython2_7-1_0
openSUSE Leap 42.3 GA libpython3_4m1_0
openSUSE Leap 42.3 GA python
openSUSE Leap 42.3 GA python-doc
openSUSE Leap 42.3 GA python3
openSUSE Leap 42.3 GA python3-doc
openSUSE Tumbleweed
  • libpython2_7-1_0 >= 2.7.12-1.4
  • libpython2_7-1_0-32bit >= 2.7.12-1.4
  • python >= 2.7.12-1.5
  • python-32bit >= 2.7.12-1.5
  • python-base >= 2.7.12-1.4
  • python-base-32bit >= 2.7.12-1.4
  • python-curses >= 2.7.12-1.5
  • python-demo >= 2.7.12-1.5
  • python-devel >= 2.7.12-1.4
  • python-doc >= 2.7.12-1.3
  • python-doc-pdf >= 2.7.12-1.3
  • python-gdbm >= 2.7.12-1.5
  • python-idle >= 2.7.12-1.5
  • python-tk >= 2.7.12-1.5
  • python-xml >= 2.7.12-1.4
Patchnames:
openSUSE Tumbleweed GA libpython2_7-1_0
openSUSE Tumbleweed GA python
openSUSE Tumbleweed GA python-doc


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 python Released
SUSE Linux Enterprise Desktop 11 SP3 python Released
SUSE Linux Enterprise Desktop 11 SP4 python Released
SUSE Linux Enterprise Desktop 12 GA python Released
SUSE Linux Enterprise Desktop 12 GA python3 Released
SUSE Linux Enterprise Desktop 12 SP1 python Released
SUSE Linux Enterprise Desktop 12 SP1 python3 Released
SUSE Linux Enterprise Desktop 12 SP2 python Released
SUSE Linux Enterprise Desktop 12 SP2 python3 Released
SUSE Linux Enterprise Module for Web and Scripting 12 python3 Released
SUSE Linux Enterprise SDK 11 SP2 python Released
SUSE Linux Enterprise SDK 11 SP3 python Released
SUSE Linux Enterprise SDK 11 SP4 python Released
SUSE Linux Enterprise Server 11 SP1 LTSS python Released
SUSE Linux Enterprise Server 11 SP2 python Released
SUSE Linux Enterprise Server 11 SP2 LTSS python Released
SUSE Linux Enterprise Server 11 SP3 python Released
SUSE Linux Enterprise Server 11 SP3 LTSS python Released
SUSE Linux Enterprise Server 11 SP4 python Released
SUSE Linux Enterprise Server 12 GA python Released
SUSE Linux Enterprise Server 12 GA python3 Released
SUSE Linux Enterprise Server 12 GA LTSS python In progress
SUSE Linux Enterprise Server 12 GA LTSS python3 Released
SUSE Linux Enterprise Server 12 SP1 python Released
SUSE Linux Enterprise Server 12 SP1 python3 Released
SUSE Linux Enterprise Server 12 SP2 python Released
SUSE Linux Enterprise Server 12 SP2 python3 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI python3 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 python Released
SUSE Linux Enterprise Server for VMWare 11 SP2 python Released
SUSE Linux Enterprise Server for VMWare 11 SP3 python Released