Upstream information

CVE-2016-5417 at MITRE

Description

Memory leak in the __res_vinit function in the IPv6 name server management code in libresolv in GNU C Library (aka glibc or libc6) before 2.24 allows remote attackers to cause a denial of service (memory consumption) by leveraging partial initialization of internal resolver data structures.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 991670 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-11.8
  • glibc-32bit >= 2.26-11.8
  • glibc-devel >= 2.26-11.8
  • glibc-extra >= 2.26-11.8
  • glibc-i18ndata >= 2.26-11.8
  • glibc-info >= 2.26-11.8
  • glibc-locale >= 2.26-11.8
  • glibc-locale-32bit >= 2.26-11.8
  • glibc-profile >= 2.26-11.8
  • nscd >= 2.26-11.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA glibc
SUSE Linux Enterprise Module for Development Tools 15
  • glibc-devel-32bit >= 2.26-11.8
  • glibc-devel-static >= 2.26-11.8
  • glibc-utils >= 2.26-11.8
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA glibc-devel-32bit
openSUSE Leap 15.0
  • glibc >= 2.26-lp150.10.13
  • glibc-32bit >= 2.26-lp150.10.13
  • glibc-extra >= 2.26-lp150.10.13
  • glibc-locale >= 2.26-lp150.10.13
  • glibc-locale-32bit >= 2.26-lp150.10.13
  • nscd >= 2.26-lp150.10.13
Patchnames:
openSUSE Leap 15.0 GA glibc
openSUSE Tumbleweed
  • glibc >= 2.24-2.3
  • glibc-32bit >= 2.24-2.3
  • glibc-devel >= 2.24-2.3
  • glibc-devel-32bit >= 2.24-2.3
  • glibc-devel-static >= 2.24-2.3
  • glibc-devel-static-32bit >= 2.24-2.3
  • glibc-extra >= 2.24-2.3
  • glibc-html >= 2.24-2.3
  • glibc-i18ndata >= 2.24-2.3
  • glibc-info >= 2.24-2.3
  • glibc-locale >= 2.24-2.3
  • glibc-locale-32bit >= 2.24-2.3
  • glibc-obsolete >= 2.24-2.3
  • glibc-profile >= 2.24-2.3
  • glibc-profile-32bit >= 2.24-2.3
  • glibc-utils >= 2.24-2.3
  • glibc-utils-32bit >= 2.24-2.3
  • nscd >= 2.24-2.3
Patchnames:
openSUSE Tumbleweed GA glibc


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 glibc Not affected
SUSE Linux Enterprise SDK 11 SP4 glibc Not affected
SUSE Linux Enterprise SDK 12 GA glibc Not affected
SUSE Linux Enterprise SDK 12 SP1 glibc Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP4 glibc Not affected
SUSE Linux Enterprise Server 12 GA LTSS glibc Not affected
SUSE Linux Enterprise Server 12 SP1 glibc Not affected