Upstream information

CVE-2016-5407 at MITRE

Description

The (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXv before 1.0.11 allow remote X servers to trigger out-of-bounds memory access operations via vectors involving length specifications in received data.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5.1
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low High
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1003017 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libX11 >= 1.6.2-6.2
  • libX11-6 >= 1.6.2-6.2
  • libX11-6-32bit >= 1.6.2-6.2
  • libX11-data >= 1.6.2-6.2
  • libX11-xcb1 >= 1.6.2-6.2
  • libX11-xcb1-32bit >= 1.6.2-6.2
  • libXfixes >= 5.0.1-5.2
  • libXfixes3 >= 5.0.1-5.2
  • libXfixes3-32bit >= 5.0.1-5.2
  • libXi >= 1.7.4-12.2
  • libXi6 >= 1.7.4-12.2
  • libXi6-32bit >= 1.7.4-12.2
  • libXrandr >= 1.4.2-5.2
  • libXrandr2 >= 1.4.2-5.2
  • libXrandr2-32bit >= 1.4.2-5.2
  • libXrender >= 0.9.8-5.2
  • libXrender1 >= 0.9.8-5.2
  • libXrender1-32bit >= 0.9.8-5.2
  • libXtst >= 1.2.2-5.2
  • libXtst6 >= 1.2.2-5.2
  • libXtst6-32bit >= 1.2.2-5.2
  • libXv >= 1.0.10-5.2
  • libXv1 >= 1.0.10-5.2
  • libXv1-32bit >= 1.0.10-5.2
  • libXvMC >= 1.0.8-5.2
  • libXvMC1 >= 1.0.8-5.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1464
SUSE Linux Enterprise Desktop 12 SP2
  • libX11 >= 1.6.2-8.1
  • libX11-6 >= 1.6.2-8.1
  • libX11-6-32bit >= 1.6.2-8.1
  • libX11-data >= 1.6.2-8.1
  • libX11-xcb1 >= 1.6.2-8.1
  • libX11-xcb1-32bit >= 1.6.2-8.1
  • libXfixes >= 5.0.1-7.1
  • libXfixes3 >= 5.0.1-7.1
  • libXfixes3-32bit >= 5.0.1-7.1
  • libXi >= 1.7.4-14.1
  • libXi6 >= 1.7.4-14.1
  • libXi6-32bit >= 1.7.4-14.1
  • libXrender >= 0.9.8-7.1
  • libXrender1 >= 0.9.8-7.1
  • libXrender1-32bit >= 0.9.8-7.1
  • libXtst >= 1.2.2-7.1
  • libXtst6 >= 1.2.2-7.1
  • libXtst6-32bit >= 1.2.2-7.1
  • libXv >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
  • libXvMC >= 1.0.8-7.1
  • libXvMC1 >= 1.0.8-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1668
SUSE Linux Enterprise Desktop 12 SP3
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libXv1
SUSE Linux Enterprise Module for Basesystem 15
  • libXv-devel >= 1.0.11-1.23
  • libXv1 >= 1.0.11-1.23
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libXv-devel
SUSE Linux Enterprise Server 11 SP4
  • xorg-x11-libXv >= 7.4-1.20.1
  • xorg-x11-libXv-32bit >= 7.4-1.20.1
  • xorg-x11-libXv-x86 >= 7.4-1.20.1
Patchnames:
slessp4-xorg-x11-libXv-12884
SUSE Linux Enterprise Server 12 SP1
  • libX11 >= 1.6.2-6.2
  • libX11-6 >= 1.6.2-6.2
  • libX11-6-32bit >= 1.6.2-6.2
  • libX11-data >= 1.6.2-6.2
  • libX11-xcb1 >= 1.6.2-6.2
  • libX11-xcb1-32bit >= 1.6.2-6.2
  • libXfixes >= 5.0.1-5.2
  • libXfixes3 >= 5.0.1-5.2
  • libXfixes3-32bit >= 5.0.1-5.2
  • libXi >= 1.7.4-12.2
  • libXi6 >= 1.7.4-12.2
  • libXi6-32bit >= 1.7.4-12.2
  • libXrandr >= 1.4.2-5.2
  • libXrandr2 >= 1.4.2-5.2
  • libXrandr2-32bit >= 1.4.2-5.2
  • libXrender >= 0.9.8-5.2
  • libXrender1 >= 0.9.8-5.2
  • libXrender1-32bit >= 0.9.8-5.2
  • libXtst >= 1.2.2-5.2
  • libXtst6 >= 1.2.2-5.2
  • libXtst6-32bit >= 1.2.2-5.2
  • libXv >= 1.0.10-5.2
  • libXv1 >= 1.0.10-5.2
  • libXv1-32bit >= 1.0.10-5.2
  • libXvMC >= 1.0.8-5.2
  • libXvMC1 >= 1.0.8-5.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1464
SUSE Linux Enterprise Server 12 SP2
  • libX11 >= 1.6.2-8.1
  • libX11-6 >= 1.6.2-8.1
  • libX11-6-32bit >= 1.6.2-8.1
  • libX11-data >= 1.6.2-8.1
  • libX11-xcb1 >= 1.6.2-8.1
  • libX11-xcb1-32bit >= 1.6.2-8.1
  • libXfixes >= 5.0.1-7.1
  • libXfixes3 >= 5.0.1-7.1
  • libXfixes3-32bit >= 5.0.1-7.1
  • libXi >= 1.7.4-14.1
  • libXi6 >= 1.7.4-14.1
  • libXi6-32bit >= 1.7.4-14.1
  • libXrender >= 0.9.8-7.1
  • libXrender1 >= 0.9.8-7.1
  • libXrender1-32bit >= 0.9.8-7.1
  • libXtst >= 1.2.2-7.1
  • libXtst6 >= 1.2.2-7.1
  • libXtst6-32bit >= 1.2.2-7.1
  • libXv >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
  • libXvMC >= 1.0.8-7.1
  • libXvMC1 >= 1.0.8-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1668
SUSE Linux Enterprise Server 12 SP3
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libXv1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libX11 >= 1.6.2-8.1
  • libX11-6 >= 1.6.2-8.1
  • libX11-data >= 1.6.2-8.1
  • libX11-xcb1 >= 1.6.2-8.1
  • libXfixes >= 5.0.1-7.1
  • libXfixes3 >= 5.0.1-7.1
  • libXi >= 1.7.4-14.1
  • libXi6 >= 1.7.4-14.1
  • libXrender >= 0.9.8-7.1
  • libXrender1 >= 0.9.8-7.1
  • libXtst >= 1.2.2-7.1
  • libXtst6 >= 1.2.2-7.1
  • libXv >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXvMC >= 1.0.8-7.1
  • libXvMC1 >= 1.0.8-7.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1668
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xorg-x11-libXv >= 7.4-1.20.1
  • xorg-x11-libXv-32bit >= 7.4-1.20.1
  • xorg-x11-libXv-x86 >= 7.4-1.20.1
Patchnames:
slessp4-xorg-x11-libXv-12884
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libX11 >= 1.6.2-6.2
  • libX11-6 >= 1.6.2-6.2
  • libX11-6-32bit >= 1.6.2-6.2
  • libX11-data >= 1.6.2-6.2
  • libX11-xcb1 >= 1.6.2-6.2
  • libX11-xcb1-32bit >= 1.6.2-6.2
  • libXfixes >= 5.0.1-5.2
  • libXfixes3 >= 5.0.1-5.2
  • libXfixes3-32bit >= 5.0.1-5.2
  • libXi >= 1.7.4-12.2
  • libXi6 >= 1.7.4-12.2
  • libXi6-32bit >= 1.7.4-12.2
  • libXrandr >= 1.4.2-5.2
  • libXrandr2 >= 1.4.2-5.2
  • libXrandr2-32bit >= 1.4.2-5.2
  • libXrender >= 0.9.8-5.2
  • libXrender1 >= 0.9.8-5.2
  • libXrender1-32bit >= 0.9.8-5.2
  • libXtst >= 1.2.2-5.2
  • libXtst6 >= 1.2.2-5.2
  • libXtst6-32bit >= 1.2.2-5.2
  • libXv >= 1.0.10-5.2
  • libXv1 >= 1.0.10-5.2
  • libXv1-32bit >= 1.0.10-5.2
  • libXvMC >= 1.0.8-5.2
  • libXvMC1 >= 1.0.8-5.2
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1464
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libX11 >= 1.6.2-8.1
  • libX11-6 >= 1.6.2-8.1
  • libX11-6-32bit >= 1.6.2-8.1
  • libX11-data >= 1.6.2-8.1
  • libX11-xcb1 >= 1.6.2-8.1
  • libX11-xcb1-32bit >= 1.6.2-8.1
  • libXfixes >= 5.0.1-7.1
  • libXfixes3 >= 5.0.1-7.1
  • libXfixes3-32bit >= 5.0.1-7.1
  • libXi >= 1.7.4-14.1
  • libXi6 >= 1.7.4-14.1
  • libXi6-32bit >= 1.7.4-14.1
  • libXrender >= 0.9.8-7.1
  • libXrender1 >= 0.9.8-7.1
  • libXrender1-32bit >= 0.9.8-7.1
  • libXtst >= 1.2.2-7.1
  • libXtst6 >= 1.2.2-7.1
  • libXtst6-32bit >= 1.2.2-7.1
  • libXv >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
  • libXvMC >= 1.0.8-7.1
  • libXvMC1 >= 1.0.8-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1668
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-libXv >= 7.4-1.20.1
  • xorg-x11-libXv-devel >= 7.4-1.20.1
  • xorg-x11-libXv-devel-32bit >= 7.4-1.20.1
Patchnames:
sdksp4-xorg-x11-libXv-12884
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libX11 >= 1.6.2-6.2
  • libX11-devel >= 1.6.2-6.2
  • libXfixes >= 5.0.1-5.2
  • libXfixes-devel >= 5.0.1-5.2
  • libXi >= 1.7.4-12.2
  • libXi-devel >= 1.7.4-12.2
  • libXrandr >= 1.4.2-5.2
  • libXrandr-devel >= 1.4.2-5.2
  • libXrender >= 0.9.8-5.2
  • libXrender-devel >= 0.9.8-5.2
  • libXtst >= 1.2.2-5.2
  • libXtst-devel >= 1.2.2-5.2
  • libXv >= 1.0.10-5.2
  • libXv-devel >= 1.0.10-5.2
  • libXvMC >= 1.0.8-5.2
  • libXvMC-devel >= 1.0.8-5.2
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1464
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libX11 >= 1.6.2-8.1
  • libX11-devel >= 1.6.2-8.1
  • libXfixes >= 5.0.1-7.1
  • libXfixes-devel >= 5.0.1-7.1
  • libXi >= 1.7.4-14.1
  • libXi-devel >= 1.7.4-14.1
  • libXrender >= 0.9.8-7.1
  • libXrender-devel >= 0.9.8-7.1
  • libXtst >= 1.2.2-7.1
  • libXtst-devel >= 1.2.2-7.1
  • libXv >= 1.0.10-7.1
  • libXv-devel >= 1.0.10-7.1
  • libXvMC >= 1.0.8-7.1
  • libXvMC-devel >= 1.0.8-7.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1668
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libXv-devel >= 1.0.10-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libXv-devel
openSUSE Leap 15.0
  • libXv1 >= 1.0.11-lp150.1.7
Patchnames:
openSUSE Leap 15.0 GA libXv1
openSUSE Leap 42.1
  • libX11 >= 1.6.3-6.1
  • libX11-6 >= 1.6.3-6.1
  • libX11-6-32bit >= 1.6.3-6.1
  • libX11-6-debuginfo >= 1.6.3-6.1
  • libX11-6-debuginfo-32bit >= 1.6.3-6.1
  • libX11-data >= 1.6.3-6.1
  • libX11-debugsource >= 1.6.3-6.1
  • libX11-devel >= 1.6.3-6.1
  • libX11-devel-32bit >= 1.6.3-6.1
  • libX11-xcb1 >= 1.6.3-6.1
  • libX11-xcb1-32bit >= 1.6.3-6.1
  • libX11-xcb1-debuginfo >= 1.6.3-6.1
  • libX11-xcb1-debuginfo-32bit >= 1.6.3-6.1
  • libXfixes >= 5.0.1-7.1
  • libXfixes-debugsource >= 5.0.1-7.1
  • libXfixes-devel >= 5.0.1-7.1
  • libXfixes-devel-32bit >= 5.0.1-7.1
  • libXfixes3 >= 5.0.1-7.1
  • libXfixes3-32bit >= 5.0.1-7.1
  • libXfixes3-debuginfo >= 5.0.1-7.1
  • libXfixes3-debuginfo-32bit >= 5.0.1-7.1
  • libXi >= 1.7.5-3.1
  • libXi-debugsource >= 1.7.5-3.1
  • libXi-devel >= 1.7.5-3.1
  • libXi-devel-32bit >= 1.7.5-3.1
  • libXi6 >= 1.7.5-3.1
  • libXi6-32bit >= 1.7.5-3.1
  • libXi6-debuginfo >= 1.7.5-3.1
  • libXi6-debuginfo-32bit >= 1.7.5-3.1
  • libXrandr >= 1.5.0-3.1
  • libXrandr-debugsource >= 1.5.0-3.1
  • libXrandr-devel >= 1.5.0-3.1
  • libXrandr-devel-32bit >= 1.5.0-3.1
  • libXrandr2 >= 1.5.0-3.1
  • libXrandr2-32bit >= 1.5.0-3.1
  • libXrandr2-debuginfo >= 1.5.0-3.1
  • libXrandr2-debuginfo-32bit >= 1.5.0-3.1
  • libXrender >= 0.9.9-3.1
  • libXrender-debugsource >= 0.9.9-3.1
  • libXrender-devel >= 0.9.9-3.1
  • libXrender-devel-32bit >= 0.9.9-3.1
  • libXrender1 >= 0.9.9-3.1
  • libXrender1-32bit >= 0.9.9-3.1
  • libXrender1-debuginfo >= 0.9.9-3.1
  • libXrender1-debuginfo-32bit >= 0.9.9-3.1
  • libXtst >= 1.2.2-7.1
  • libXtst-debugsource >= 1.2.2-7.1
  • libXtst-devel >= 1.2.2-7.1
  • libXtst-devel-32bit >= 1.2.2-7.1
  • libXtst6 >= 1.2.2-7.1
  • libXtst6-32bit >= 1.2.2-7.1
  • libXtst6-debuginfo >= 1.2.2-7.1
  • libXtst6-debuginfo-32bit >= 1.2.2-7.1
  • libXv >= 1.0.10-7.1
  • libXv-debugsource >= 1.0.10-7.1
  • libXv-devel >= 1.0.10-7.1
  • libXv-devel-32bit >= 1.0.10-7.1
  • libXv1 >= 1.0.10-7.1
  • libXv1-32bit >= 1.0.10-7.1
  • libXv1-debuginfo >= 1.0.10-7.1
  • libXv1-debuginfo-32bit >= 1.0.10-7.1
  • libXvMC >= 1.0.9-3.1
  • libXvMC-debugsource >= 1.0.9-3.1
  • libXvMC-devel >= 1.0.9-3.1
  • libXvMC-devel-32bit >= 1.0.9-3.1
  • libXvMC1 >= 1.0.9-3.1
  • libXvMC1-32bit >= 1.0.9-3.1
  • libXvMC1-debuginfo >= 1.0.9-3.1
  • libXvMC1-debuginfo-32bit >= 1.0.9-3.1
Patchnames:
openSUSE-2016-1214
openSUSE Leap 42.2
  • libXv-devel >= 1.0.10-8.1
  • libXv1 >= 1.0.10-8.1
  • libXv1-32bit >= 1.0.10-8.1
Patchnames:
openSUSE Leap 42.2 GA libXv-devel
openSUSE Leap 42.3
  • libXv-devel >= 1.0.10-10.3
  • libXv1 >= 1.0.10-10.3
  • libXv1-32bit >= 1.0.10-10.3
Patchnames:
openSUSE Leap 42.3 GA libXv-devel
openSUSE Tumbleweed
  • libXv-devel >= 1.0.11-1.1
  • libXv-devel-32bit >= 1.0.11-1.1
  • libXv1 >= 1.0.11-1.1
  • libXv1-32bit >= 1.0.11-1.1
Patchnames:
openSUSE Tumbleweed GA libXv-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA libXv Released
SUSE Linux Enterprise Desktop 12 SP1 libXv Released
SUSE Linux Enterprise Desktop 12 SP2 libXv Released
SUSE Linux Enterprise SDK 11 SP4 xorg-x11-libXv Released
SUSE Linux Enterprise SDK 12 GA libXv Released
SUSE Linux Enterprise SDK 12 SP1 libXv Released
SUSE Linux Enterprise SDK 12 SP2 libXv Released
SUSE Linux Enterprise Server 11 SP2 LTSS xorg-x11-libXv Affected
SUSE Linux Enterprise Server 11 SP3 LTSS xorg-x11-libXv Affected
SUSE Linux Enterprise Server 11 SP4 xorg-x11-libXv Released
SUSE Linux Enterprise Server 12 GA libXv Released
SUSE Linux Enterprise Server 12 GA LTSS libXv Released
SUSE Linux Enterprise Server 12 SP1 libXv Released
SUSE Linux Enterprise Server 12 SP2 libXv Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI libXv Released