Upstream information

CVE-2016-5325 at MITRE

Description

CRLF injection vulnerability in the ServerResponse#writeHead function in Node.js 0.10.x before 0.10.47, 0.12.x before 0.12.16, 4.x before 4.6.0, and 6.x before 6.7.0 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the reason argument.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 4
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N AV:N/AC:H/Au:N/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.1
Vector AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Changed
Confidentiality Impact Low
Integrity Impact Low
Availability Impact None
SUSE Bugzilla entries: 985201 [RESOLVED / FIXED], 985202 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.6.0-8.1
  • nodejs4-devel >= 4.6.0-8.1
  • nodejs4-docs >= 4.6.0-8.1
  • npm4 >= 4.6.0-8.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2016-1439
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.1-1.19
  • nodejs8-devel >= 8.11.1-1.19
  • nodejs8-docs >= 8.11.1-1.19
  • npm8 >= 8.11.1-1.19
Patchnames:
SUSE Linux Enterprise Module for Web Scripting 15 GA nodejs8
openSUSE Leap 42.1
  • nodejs >= 4.6.0-33.1
  • nodejs-debuginfo >= 4.6.0-33.1
  • nodejs-debugsource >= 4.6.0-33.1
  • nodejs-devel >= 4.6.0-33.1
  • nodejs-docs >= 4.6.0-33.1
  • npm >= 4.6.0-33.1
Patchnames:
openSUSE-2016-1172
openSUSE Tumbleweed
  • nodejs4 >= 4.7.0-1.1
  • nodejs4-devel >= 4.7.0-1.1
  • nodejs4-docs >= 4.7.0-1.1
  • npm4 >= 4.7.0-1.1
Patchnames:
openSUSE Tumbleweed GA nodejs4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Already fixed
SUSE Storage 4 nodejs4 Already fixed
SUSE Studio Onsite 1.3 nodejs Ignore