Upstream information

CVE-2016-5180 at MITRE

Description

Heap-based buffer overflow in the ares_create_query function in c-ares 1.x before 1.12.0 allows remote attackers to cause a denial of service (out-of-bounds write) or possibly execute arbitrary code via a hostname with an escaped trailing dot.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1007728 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • libcares2 >= 1.9.1-5.1
  • libcares2-32bit >= 1.9.1-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1924
SUSE Linux Enterprise Desktop 12 SP2
  • libcares2 >= 1.9.1-5.1
  • libcares2-32bit >= 1.9.1-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2016-1924
SUSE Linux Enterprise Desktop 12 SP3
  • libcares2 >= 1.9.1-5.1
  • libcares2-32bit >= 1.9.1-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libcares2
SUSE Linux Enterprise Module for Basesystem 15
  • c-ares-devel >= 1.14.0-1.17
  • libcares2 >= 1.14.0-1.17
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA c-ares-devel
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.6.1-11.1
  • nodejs4-devel >= 4.6.1-11.1
  • nodejs4-docs >= 4.6.1-11.1
  • npm4 >= 4.6.1-11.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2016-1694
SUSE Linux Enterprise Server 11 SP4
  • libcares2 >= 1.7.4-7.9.1
Patchnames:
slessp4-libcares2-12921
SUSE Linux Enterprise Server 12 SP1
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1924
SUSE Linux Enterprise Server 12 SP2
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1924
SUSE Linux Enterprise Server 12 SP3
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libcares2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2016-1924
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libcares2 >= 1.7.4-7.9.1
Patchnames:
slessp4-libcares2-12921
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1924
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2016-1924
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libcares-devel >= 1.7.4-7.9.1
  • libcares2 >= 1.7.4-7.9.1
Patchnames:
sdksp4-libcares2-12921
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libcares-devel >= 1.9.1-5.1
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1924
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libcares-devel >= 1.9.1-5.1
  • libcares2 >= 1.9.1-5.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2016-1924
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcares-devel >= 1.9.1-5.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libcares-devel
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libcares2 >= 1.9.1-5.1
  • libcares2-32bit >= 1.9.1-5.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-1924
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libcares2 >= 1.9.1-5.1
  • libcares2-32bit >= 1.9.1-5.1
Patchnames:
SUSE-SLE-WE-12-SP2-2016-1924
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libcares2-32bit >= 1.9.1-5.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libcares2-32bit
openSUSE Leap 15.0
  • libcares2 >= 1.14.0-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libcares2
openSUSE Leap 42.1
  • libcares-devel >= 1.9.1-5.1
  • libcares2 >= 1.9.1-5.1
  • libcares2-32bit >= 1.9.1-5.1
  • libcares2-debuginfo >= 1.9.1-5.1
  • libcares2-debuginfo-32bit >= 1.9.1-5.1
  • libcares2-debugsource >= 1.9.1-5.1
  • nodejs >= 4.6.1-36.1
  • nodejs-debuginfo >= 4.6.1-36.1
  • nodejs-debugsource >= 4.6.1-36.1
  • nodejs-devel >= 4.6.1-36.1
  • nodejs-docs >= 4.6.1-36.1
  • npm >= 4.6.1-36.1
Patchnames:
openSUSE-2016-1277
openSUSE-2017-58
openSUSE Leap 42.2
  • libcares-devel >= 1.9.1-6.1
  • libcares2 >= 1.9.1-6.1
  • libcares2-32bit >= 1.9.1-6.1
  • libcares2-debuginfo >= 1.9.1-6.1
  • libcares2-debuginfo-32bit >= 1.9.1-6.1
  • libcares2-debugsource >= 1.9.1-6.1
  • nodejs4 >= 4.6.1-3.1
  • nodejs4-debuginfo >= 4.6.1-3.1
  • nodejs4-debugsource >= 4.6.1-3.1
  • nodejs4-devel >= 4.6.1-3.1
  • nodejs4-docs >= 4.6.1-3.1
  • npm4 >= 4.6.1-3.1
Patchnames:
openSUSE-2016-1403
openSUSE-2017-58
openSUSE Leap 42.3
  • libcares2 >= 1.9.1-10.1
Patchnames:
openSUSE Leap 42.3 GA libcares2
openSUSE Tumbleweed
  • libcares-devel >= 1.12.0-1.1
  • libcares2 >= 1.12.0-1.1
  • libcares2-32bit >= 1.12.0-1.1
  • nodejs4 >= 4.7.0-1.1
  • nodejs4-devel >= 4.7.0-1.1
  • nodejs4-docs >= 4.7.0-1.1
  • npm4 >= 4.7.0-1.1
Patchnames:
openSUSE Tumbleweed GA libcares-devel
openSUSE Tumbleweed GA nodejs4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 libcares2 Released
SUSE Linux Enterprise Desktop 12 SP2 libcares2 Released
SUSE Linux Enterprise Module for Web and Scripting 12 nodejs4 Released
SUSE Linux Enterprise SDK 11 SP4 libcares2 Released
SUSE Linux Enterprise SDK 12 SP1 libcares2 Released
SUSE Linux Enterprise SDK 12 SP2 libcares2 Released
SUSE Linux Enterprise Server 11 SP2 LTSS libcares2 Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS libcares2 Ignore
SUSE Linux Enterprise Server 11 SP4 libcares2 Released
SUSE Linux Enterprise Server 12 GA LTSS libcares2 Affected
SUSE Linux Enterprise Server 12 SP1 libcares2 Released
SUSE Linux Enterprise Server 12 SP2 libcares2 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI libcares2 Released
SUSE Linux Enterprise Workstation Extension 12 SP1 libcares2 Released
SUSE Linux Enterprise Workstation Extension 12 SP2 libcares2 Released
SUSE Storage 4 nodejs4 Already fixed
SUSE Studio Onsite 1.3 nodejs Ignore