Upstream information

CVE-2016-5131 at MITRE

Description

Use-after-free vulnerability in libxml2 through 2.9.4, as used in Google Chrome before 52.0.2743.82, allows remote attackers to cause a denial of service or possibly have unspecified other impact via vectors related to the XPointer range-to function.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction Required Required
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
SUSE Bugzilla entries: 1014873 [RESOLVED / FIXED], 1069433 [RESOLVED / DUPLICATE], 1078813 [RESOLVED / FIXED], 989901 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-276
SUSE CaaS Platform ALL
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
Patchnames:
SUSE-CAASP-ALL-2018-276
SUSE Linux Enterprise Desktop 12 SP2
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-2-32bit >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
  • python-libxml2 >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-276
SUSE Linux Enterprise Desktop 12 SP3
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-2-32bit >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
  • python-libxml2 >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-276
SUSE Linux Enterprise High Availability 15
  • ruby2.5-rubygem-nokogiri >= 1.8.2-1.16
Patchnames:
SUSE Linux Enterprise High Availability 15 GA ruby2.5-rubygem-nokogiri
SUSE Linux Enterprise Server 11 SP4
  • libxml2 >= 2.7.6-0.77.10.1
  • libxml2-32bit >= 2.7.6-0.77.10.1
  • libxml2-doc >= 2.7.6-0.77.10.1
  • libxml2-python >= 2.7.6-0.77.10.1
  • libxml2-x86 >= 2.7.6-0.77.10.1
Patchnames:
slessp4-libxml2-13458
SUSE Linux Enterprise Server 12 SP2
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-2-32bit >= 2.9.4-46.12.1
  • libxml2-doc >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
  • python-libxml2 >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-276
SUSE Linux Enterprise Server 12 SP3
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-2-32bit >= 2.9.4-46.12.1
  • libxml2-doc >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
  • python-libxml2 >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-276
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-doc >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
  • python-libxml2 >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-276
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libxml2 >= 2.7.6-0.77.10.1
  • libxml2-32bit >= 2.7.6-0.77.10.1
  • libxml2-doc >= 2.7.6-0.77.10.1
  • libxml2-python >= 2.7.6-0.77.10.1
  • libxml2-x86 >= 2.7.6-0.77.10.1
Patchnames:
slessp4-libxml2-13458
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-2-32bit >= 2.9.4-46.12.1
  • libxml2-doc >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
  • python-libxml2 >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-276
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-2 >= 2.9.4-46.12.1
  • libxml2-2-32bit >= 2.9.4-46.12.1
  • libxml2-doc >= 2.9.4-46.12.1
  • libxml2-tools >= 2.9.4-46.12.1
  • python-libxml2 >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-276
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxml2 >= 2.7.6-0.77.10.1
  • libxml2-devel >= 2.7.6-0.77.10.1
  • libxml2-devel-32bit >= 2.7.6-0.77.10.1
Patchnames:
sdksp4-libxml2-13458
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-devel >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-276
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libxml2 >= 2.9.4-46.12.1
  • libxml2-devel >= 2.9.4-46.12.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-276
SUSE Package Hub for SUSE Linux Enterprise 12
  • chromedriver >= 52.0.2743.82-89.1
  • chromedriver-debuginfo >= 52.0.2743.82-89.1
  • chromium >= 52.0.2743.82-89.1
  • chromium-debuginfo >= 52.0.2743.82-89.1
  • chromium-debugsource >= 52.0.2743.82-89.1
  • chromium-desktop-gnome >= 52.0.2743.82-89.1
  • chromium-desktop-kde >= 52.0.2743.82-89.1
  • chromium-ffmpegsumo >= 52.0.2743.82-89.1
  • chromium-ffmpegsumo-debuginfo >= 52.0.2743.82-89.1
Patchnames:
openSUSE-2016-900
openSUSE 13.1
  • chromedriver >= 52.0.2743.82-150.1
  • chromedriver-debuginfo >= 52.0.2743.82-150.1
  • chromium >= 52.0.2743.82-150.1
  • chromium-debuginfo >= 52.0.2743.82-150.1
  • chromium-debugsource >= 52.0.2743.82-150.1
  • chromium-desktop-gnome >= 52.0.2743.82-150.1
  • chromium-desktop-kde >= 52.0.2743.82-150.1
  • chromium-ffmpegsumo >= 52.0.2743.82-150.1
  • chromium-ffmpegsumo-debuginfo >= 52.0.2743.82-150.1
Patchnames:
2016-919
openSUSE Leap 15.0
  • chromium >= 66.0.3359.170-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA chromium
openSUSE Leap 42.1
  • chromedriver >= 52.0.2743.82-61.1
  • chromium >= 52.0.2743.82-61.1
  • chromium-desktop-gnome >= 52.0.2743.82-61.1
  • chromium-desktop-kde >= 52.0.2743.82-61.1
  • chromium-ffmpegsumo >= 52.0.2743.82-61.1
Patchnames:
openSUSE-2016-900
openSUSE Leap 42.3
  • libxml2 >= 2.9.4-15.1
  • libxml2-2 >= 2.9.4-15.1
  • libxml2-2-32bit >= 2.9.4-15.1
  • libxml2-2-debuginfo >= 2.9.4-15.1
  • libxml2-2-debuginfo-32bit >= 2.9.4-15.1
  • libxml2-debugsource >= 2.9.4-15.1
  • libxml2-devel >= 2.9.4-15.1
  • libxml2-devel-32bit >= 2.9.4-15.1
  • libxml2-doc >= 2.9.4-15.1
  • libxml2-tools >= 2.9.4-15.1
  • libxml2-tools-debuginfo >= 2.9.4-15.1
  • python-libxml2 >= 2.9.4-15.1
  • python-libxml2-debuginfo >= 2.9.4-15.1
  • python-libxml2-debugsource >= 2.9.4-15.1
Patchnames:
openSUSE-2018-154
openSUSE Tumbleweed
  • chromedriver >= 55.0.2883.75-3.1
  • chromium >= 55.0.2883.75-3.1
Patchnames:
openSUSE Tumbleweed GA chromedriver


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 libxml2 Released
OpenStack Cloud Magnum Orchestration 7.0 libxml2 Released
SUSE Linux Enterprise Desktop 12 SP2 libxml2 Released
SUSE Linux Enterprise Desktop 12 SP3 libxml2 Released
SUSE Linux Enterprise SDK 11 SP4 libxml2 Released
SUSE Linux Enterprise SDK 12 SP2 libxml2 Released
SUSE Linux Enterprise SDK 12 SP3 libxml2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS libxml2 Affected
SUSE Linux Enterprise Server 11 SP4 libxml2 Released
SUSE Linux Enterprise Server 12 SP2 libxml2 Released
SUSE Linux Enterprise Server 12 SP3 libxml2 Released
SUSE Studio Onsite 1.3 v8 Ignore