Upstream information

CVE-2016-5116 at MITRE

Description

gd_xbm.c in the GD Graphics Library (aka libgd) before 2.2.0, as used in certain custom PHP 5.5.x configurations, allows context-dependent attackers to obtain sensitive information from process memory or cause a denial of service (stack-based buffer under-read and application crash) via a long name.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 4.3
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 982176 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gd >= 2.1.0-12.1
  • gd-32bit >= 2.1.0-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-1347
SUSE Linux Enterprise Desktop 12 SP2
  • gd >= 2.1.0-12.1
  • gd-32bit >= 2.1.0-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA gd
SUSE Linux Enterprise Desktop 12 SP3
  • gd >= 2.1.0-23.1
  • gd-32bit >= 2.1.0-23.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gd
SUSE Linux Enterprise Module for Basesystem 15
  • libgd3 >= 2.2.5-2.22
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libgd3
SUSE Linux Enterprise Module for Desktop Applications 15
  • gd >= 2.2.5-2.22
  • gd-devel >= 2.2.5-2.22
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA gd
SUSE Linux Enterprise Server 12 SP1
  • gd >= 2.1.0-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1347
SUSE Linux Enterprise Server 12 SP2
  • gd >= 2.1.0-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA gd
SUSE Linux Enterprise Server 12 SP3
  • gd >= 2.1.0-23.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gd
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gd >= 2.1.0-12.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA gd
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • gd >= 2.1.0-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-1347
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gd >= 2.1.0-12.1
  • gd-devel >= 2.1.0-12.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-1347
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gd-devel >= 2.1.0-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA gd-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gd-devel >= 2.1.0-23.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gd-devel
SUSE Linux Enterprise Workstation Extension 12 SP1
  • gd >= 2.1.0-12.1
  • gd-32bit >= 2.1.0-12.1
Patchnames:
SUSE-SLE-WE-12-SP1-2016-1347
SUSE Linux Enterprise Workstation Extension 12 SP2
  • gd-32bit >= 2.1.0-12.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA gd-32bit
SUSE Linux Enterprise Workstation Extension 12 SP3
  • gd-32bit >= 2.1.0-23.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA gd-32bit
openSUSE Leap 15.0
  • libgd3 >= 2.2.5-lp150.2.6
Patchnames:
openSUSE Leap 15.0 GA libgd3
openSUSE Leap 42.1
  • gd >= 2.1.0-10.1
  • gd-32bit >= 2.1.0-10.1
  • gd-debuginfo >= 2.1.0-10.1
  • gd-debuginfo-32bit >= 2.1.0-10.1
  • gd-debugsource >= 2.1.0-10.1
  • gd-devel >= 2.1.0-10.1
Patchnames:
openSUSE-2016-1108
openSUSE Leap 42.2
  • gd >= 2.1.0-11.1
  • gd-32bit >= 2.1.0-11.1
Patchnames:
openSUSE Leap 42.2 GA gd
openSUSE Leap 42.3
  • gd >= 2.1.0-19.3
  • gd-32bit >= 2.1.0-19.3
Patchnames:
openSUSE Leap 42.3 GA gd
openSUSE Tumbleweed
  • gd >= 2.2.3-2.1
  • gd-devel >= 2.2.3-2.1
  • libgd3 >= 2.2.3-2.1
  • libgd3-32bit >= 2.2.3-2.1
Patchnames:
openSUSE Tumbleweed GA gd


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP4 gd Not affected
SUSE Linux Enterprise Desktop 12 GA gd Released
SUSE Linux Enterprise Desktop 12 SP1 gd Released
SUSE Linux Enterprise Desktop 12 SP2 gd Released
SUSE Linux Enterprise SDK 11 SP4 gd Not affected
SUSE Linux Enterprise SDK 12 GA gd Released
SUSE Linux Enterprise SDK 12 SP1 gd Released
SUSE Linux Enterprise SDK 12 SP2 gd Released
SUSE Linux Enterprise Server 10 SP4 LTSS gd Not affected
SUSE Linux Enterprise Server 11 SP2 LTSS gd Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS gd Not affected
SUSE Linux Enterprise Server 11 SP4 gd Not affected
SUSE Linux Enterprise Server 12 GA gd Released
SUSE Linux Enterprise Server 12 GA LTSS gd Released
SUSE Linux Enterprise Server 12 SP1 gd Released
SUSE Linux Enterprise Server 12 SP2 gd Released
SUSE Linux Enterprise Workstation Extension 12 GA gd Released
SUSE Linux Enterprise Workstation Extension 12 SP1 gd Released