Upstream information

CVE-2016-5108 at MITRE

Description

Buffer overflow in the DecodeAdpcmImaQT function in modules/codec/adpcm.c in VideoLAN VLC media player before 2.2.4 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted QuickTime IMA file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 984382 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • libvlc5 >= 2.2.4-27.1
  • libvlc5-debuginfo >= 2.2.4-27.1
  • libvlccore8 >= 2.2.4-27.1
  • libvlccore8-debuginfo >= 2.2.4-27.1
  • vlc >= 2.2.4-27.1
  • vlc-debuginfo >= 2.2.4-27.1
  • vlc-debugsource >= 2.2.4-27.1
  • vlc-devel >= 2.2.4-27.1
  • vlc-noX >= 2.2.4-27.1
  • vlc-noX-debuginfo >= 2.2.4-27.1
  • vlc-noX-lang >= 2.2.4-27.1
  • vlc-qt >= 2.2.4-27.1
  • vlc-qt-debuginfo >= 2.2.4-27.1
Patchnames:
openSUSE-2016-754
openSUSE Tumbleweed
  • libvlc5 >= 2.2.4-11.1
  • libvlccore8 >= 2.2.4-11.1
  • vlc >= 2.2.4-11.1
  • vlc-codec-gstreamer >= 2.2.4-11.1
  • vlc-devel >= 2.2.4-11.1
  • vlc-lang >= 2.2.4-11.1
  • vlc-noX >= 2.2.4-11.1
  • vlc-qt >= 2.2.4-11.1
Patchnames:
openSUSE Tumbleweed GA libvlc5