Upstream information

CVE-2016-5009 at MITRE

Description

The handle_command function in mon/Monitor.cc in Ceph allows remote authenticated users to cause a denial of service (segmentation fault and ceph monitor crash) via an (1) empty or (2) crafted prefix.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.00 5.16
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P AV:A/AC:M/Au:S/C:N/I:N/A:C
Access Vector Network Adjacent Network
Access Complexity Low Medium
Authentication Single Single
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 987144 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 3
  • ceph >= 10.2.3+git.1475228057.755cf99-7.3
  • ceph-base >= 10.2.3+git.1475228057.755cf99-7.3
  • ceph-common >= 10.2.3+git.1475228057.755cf99-7.3
  • ceph-fuse >= 10.2.3+git.1475228057.755cf99-7.3
  • ceph-mds >= 10.2.3+git.1475228057.755cf99-7.3
  • ceph-mon >= 10.2.3+git.1475228057.755cf99-7.3
  • ceph-osd >= 10.2.3+git.1475228057.755cf99-7.3
  • ceph-radosgw >= 10.2.3+git.1475228057.755cf99-7.3
  • libcephfs1 >= 10.2.3+git.1475228057.755cf99-7.3
  • librados2 >= 10.2.3+git.1475228057.755cf99-7.3
  • libradosstriper1 >= 10.2.3+git.1475228057.755cf99-7.3
  • librbd1 >= 10.2.3+git.1475228057.755cf99-7.3
  • librgw2 >= 10.2.3+git.1475228057.755cf99-7.3
  • python-ceph-compat >= 10.2.3+git.1475228057.755cf99-7.3
  • python-cephfs >= 10.2.3+git.1475228057.755cf99-7.3
  • python-rados >= 10.2.3+git.1475228057.755cf99-7.3
  • python-rbd >= 10.2.3+git.1475228057.755cf99-7.3
  • rbd-fuse >= 10.2.3+git.1475228057.755cf99-7.3
  • rbd-mirror >= 10.2.3+git.1475228057.755cf99-7.3
  • rbd-nbd >= 10.2.3+git.1475228057.755cf99-7.3
Patchnames:
SUSE-Storage-3-2016-1653
SUSE Linux Enterprise Desktop 12 SP2
  • ceph >= 10.2.4+git.1481215985.12b091b-16.2
  • ceph-common >= 10.2.4+git.1481215985.12b091b-16.2
  • libcephfs1 >= 10.2.4+git.1481215985.12b091b-16.2
  • librados2 >= 10.2.4+git.1481215985.12b091b-16.2
  • libradosstriper1 >= 10.2.4+git.1481215985.12b091b-16.2
  • librbd1 >= 10.2.4+git.1481215985.12b091b-16.2
  • python-cephfs >= 10.2.4+git.1481215985.12b091b-16.2
  • python-rados >= 10.2.4+git.1481215985.12b091b-16.2
  • python-rbd >= 10.2.4+git.1481215985.12b091b-16.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-186
SUSE Linux Enterprise Server 12 SP2
  • ceph >= 10.2.4+git.1481215985.12b091b-16.2
  • ceph-common >= 10.2.4+git.1481215985.12b091b-16.2
  • libcephfs1 >= 10.2.4+git.1481215985.12b091b-16.2
  • librados2 >= 10.2.4+git.1481215985.12b091b-16.2
  • libradosstriper1 >= 10.2.4+git.1481215985.12b091b-16.2
  • librbd1 >= 10.2.4+git.1481215985.12b091b-16.2
  • python-cephfs >= 10.2.4+git.1481215985.12b091b-16.2
  • python-rados >= 10.2.4+git.1481215985.12b091b-16.2
  • python-rbd >= 10.2.4+git.1481215985.12b091b-16.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-186
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ceph >= 10.2.4+git.1481215985.12b091b-16.2
  • ceph-common >= 10.2.4+git.1481215985.12b091b-16.2
  • libcephfs1 >= 10.2.4+git.1481215985.12b091b-16.2
  • librados2 >= 10.2.4+git.1481215985.12b091b-16.2
  • libradosstriper1 >= 10.2.4+git.1481215985.12b091b-16.2
  • librbd1 >= 10.2.4+git.1481215985.12b091b-16.2
  • python-cephfs >= 10.2.4+git.1481215985.12b091b-16.2
  • python-rados >= 10.2.4+git.1481215985.12b091b-16.2
  • python-rbd >= 10.2.4+git.1481215985.12b091b-16.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-186
SUSE Linux Enterprise Software Development Kit 12 SP2
  • ceph >= 10.2.4+git.1481215985.12b091b-16.2
  • libcephfs-devel >= 10.2.4+git.1481215985.12b091b-16.2
  • librados-devel >= 10.2.4+git.1481215985.12b091b-16.2
  • libradosstriper-devel >= 10.2.4+git.1481215985.12b091b-16.2
  • librbd-devel >= 10.2.4+git.1481215985.12b091b-16.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-186
openSUSE Leap 42.2
  • ceph >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-base >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-base-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-common >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-common-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-fuse >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-fuse-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-mds >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-mds-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-mon >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-mon-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-osd >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-osd-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-radosgw >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-radosgw-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-resource-agents >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-test >= 10.2.4+git.1481215985.12b091b-4.1
  • ceph-test-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • libcephfs-devel >= 10.2.4+git.1481215985.12b091b-4.1
  • libcephfs1 >= 10.2.4+git.1481215985.12b091b-4.1
  • libcephfs1-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • librados-devel >= 10.2.4+git.1481215985.12b091b-4.1
  • librados-devel-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • librados2 >= 10.2.4+git.1481215985.12b091b-4.1
  • librados2-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • libradosstriper-devel >= 10.2.4+git.1481215985.12b091b-4.1
  • libradosstriper1 >= 10.2.4+git.1481215985.12b091b-4.1
  • libradosstriper1-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • librbd-devel >= 10.2.4+git.1481215985.12b091b-4.1
  • librbd1 >= 10.2.4+git.1481215985.12b091b-4.1
  • librbd1-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • librgw-devel >= 10.2.4+git.1481215985.12b091b-4.1
  • librgw2 >= 10.2.4+git.1481215985.12b091b-4.1
  • librgw2-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • python-ceph-compat >= 10.2.4+git.1481215985.12b091b-4.1
  • python-cephfs >= 10.2.4+git.1481215985.12b091b-4.1
  • python-cephfs-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • python-rados >= 10.2.4+git.1481215985.12b091b-4.1
  • python-rados-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • python-rbd >= 10.2.4+git.1481215985.12b091b-4.1
  • python-rbd-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • rbd-fuse >= 10.2.4+git.1481215985.12b091b-4.1
  • rbd-fuse-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • rbd-mirror >= 10.2.4+git.1481215985.12b091b-4.1
  • rbd-mirror-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
  • rbd-nbd >= 10.2.4+git.1481215985.12b091b-4.1
  • rbd-nbd-debuginfo >= 10.2.4+git.1481215985.12b091b-4.1
Patchnames:
openSUSE-2016-1500